It is currently Thu Sep 19, 2019 7:09 am


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: QT Compile help needed - GNS3 Fedora 64bit
PostPosted: Thu Jan 05, 2012 1:43 pm 
Offline

Joined: Sat Jun 04, 2011 12:43 pm
Posts: 2
Hey all

I am new to the forum and sorry for posting my first topic as a help topic.

I am getting a error when compiling qt-x11-opensource-src-4.5.1 this happens when i use the make command.
My OS is Fedora 15 64bit i need this for GNS3 any help would truly be appreciated.

The error: (THANKS IN ADVANCE)


make[1]: Entering directory `/tmp/qt-x11-opensource-src-4.5.1/src/network'
g++ -c -include .pch/debug-shared/QtNetwork -m64 -pipe -g -fno-exceptions -g -fvisibility=hidden -fvisibility-inlines-hidden -Wall -W -D_REENTRANT -fPIC -DQT_SHARED -DQT_BUILD_NETWORK_LIB -DQT_NO_USING_NAMESPACE -DQT_NO_CAST_TO_ASCII -DQT_ASCII_CAST_WARNINGS -DQT3_SUPPORT -DQT_MOC_COMPAT -DQT_CORE_LIB -D_LARGEFILE64_SOURCE -D_LARGEFILE_SOURCE -I../../mkspecs/linux-g++-64 -I. -I../../include/QtCore -I../../include -I../../include/QtNetwork -I.rcc/debug-shared -Ikernel -I/usr/include -I.moc/debug-shared -I/tmp/qt-x11-opensource-src-4.5.1/src/network/.uic/debug-shared -o .obj/debug-shared/qsslcertificate.o ssl/qsslcertificate.cpp
In file included from ssl/qsslcertificate.cpp:109:0:
ssl/qsslsocket_openssl_symbols_p.h:257:16: error: variable or field ‘q_sk_free’ declared void
ssl/qsslsocket_openssl_symbols_p.h:257:16: error: ‘STACK’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:257:23: error: ‘a’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:258:14: error: ‘STACK’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:258:21: error: ‘a’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:259:19: error: ‘STACK’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:259:26: error: ‘a’ was not declared in this scope
ssl/qsslsocket_openssl_symbols_p.h:259:29: error: expected primary-expression before ‘int’
ssl/qsslsocket_openssl_symbols_p.h:259:34: error: expression list treated as compound expression in initializer [-fpermissive]
ssl/qsslcertificate.cpp: In member function ‘QMultiMap<QSsl::AlternateNameEntryType, QString> QSslCertificate::alternateSubjectNames() const’:
ssl/qsslcertificate.cpp:365:5: error: ‘STACK’ was not declared in this scope
ssl/qsslcertificate.cpp:365:12: error: ‘altNames’ was not declared in this scope
ssl/qsslcertificate.cpp:365:31: error: expected primary-expression before ‘)’ token
ssl/qsslcertificate.cpp:365:32: error: expected ‘;’ before ‘q_X509_get_ext_d2i’
ssl/qsslcertificate.cpp:368:29: warning: cast to pointer from integer of different size [-Wint-to-pointer-cast]
ssl/qsslcertificate.cpp:386:27: error: ‘q_sk_free’ was not declared in this scope
ssl/qsslcertificate.cpp: In function ‘bool matchLineFeed(const QByteArray&, int*)’:
ssl/qsslcertificate.cpp:689:18: warning: value computed is not used [-Wunused-value]
make[1]: *** [.obj/debug-shared/qsslcertificate.o] Error 1
make[1]: Leaving directory `/tmp/qt-x11-opensource-src-4.5.1/src/network'
make: *** [sub-network-make_default-ordered] Error 2




Top
 Profile  
 
 Post subject: Re: QT Compile help needed - GNS3 Fedora 64bit
PostPosted: Sun Jan 08, 2012 9:37 pm 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
Why do u do that ?

*don't* compile Qt4 on platforms, that have it. Only on platforms, that lack it (such as RHEL5).
Just install python-qt4 (or equivalent in Fedora)


Top
 Profile  
 
 Post subject: Re: QT Compile help needed - GNS3 Fedora 64bit
PostPosted: Fri Jan 13, 2012 8:00 pm 
Offline

Joined: Tue Oct 04, 2011 3:54 pm
Posts: 3
Treschen wrote:
Hey all
I am new to the forum and sorry for posting my first topic as a help topic.

I am getting a error when compiling qt-x11-opensource-src-4.5.1 this happens when i use the make command.
My OS is Fedora 15 64bit i need this for GNS3 any help would truly be appreciated.
The error: (THANKS IN ADVANCE)



OK, Install this packets in Fedora to run well without dying !!!
this should take you few minutes xD this guide is a lot better!!!
Dev rpms files are for me xD


for some weirds problem in my machine with fedora 14 and 15 the compile version doesnt work but in Fedora 13 it works flawless I compile the last packets.

i have the 2 version 32 and 64. good luck

RPM fusion fedora 14-15-16-17
--------------------------------------------------
yum localinstall --nogpgcheck http://download1.rpmfusion.org/free/fed ... noarch.rpm http://download1.rpmfusion.org/nonfree/ ... noarch.rpm
------------------------------------------------------
Gns3
--------------------------------------
yum install python python-devel xorg-x11-proto-devel libXext-devel gcc-c++ gcc

yum install yum qt qt-x11 qt4 qt4-devel sip.x86_64 sip-devel.x86_64 PyQt4.x86_64 PyQt4-devel.x86_64

yum install kernel.x86_64 kernel-devel.x86_64 kernel-headers.x86_64 xdotool

-----------------------------------------


and to compile dynamips
libuuid-devel.x86_64 libpcap-devel.x86_64 elfutils-libelf-devel.x86_64 elfutils-libelf.x86_64

elfutils-libelf-devel-static.x86_64




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO