It is currently Tue Jun 25, 2019 1:53 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Small Voice Lab GNS3 with Vmware Problem
PostPosted: Sat Feb 04, 2012 6:49 am 
Offline

Joined: Sat Feb 04, 2012 6:47 am
Posts: 2
Voice Lab using GN3 and Vmware?

Okay first im not good in voice at all but i thought to give it a shoot.
i setup a voice gw router 3745 in GN3 and i install CUCM 7 on vmware and the both can ping each other normally and the CUCM sees the gateway IP when i add it , but registering is UNKOWN i dont know why , but i configure the GW and i add a partition and a call search space and a device pool.
the ip blue phones or the cisco ip coomunicator phone dont want to register at all. i dont know why.
the topology goes like thsi , the router on the GN3 is connected from interface fast 0/0 to a cloud wich is the vmnet 1 ( vmware network ) and the both are in the same subnet and the vmware have the CUCM 7
CUCM ip 192.168.100.100 , interface 100.1 , vmnet1 100.2 all /24
here is the Router GW config

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname VoiceGW
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.100
ip dhcp excluded-address 192.168.100.1
--More--  ip dhcp excluded-address 192.168.100.2
!
ip dhcp pool Voice
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
!
!
multilink bundle-name authenticated
!
!
!
!
voice call carrier capacity active
voice rtp send-recv
!
!
voice class codec 1
codec preference 1 g711ulaw
codec preference 2 g729r8
!
!
voice class h323 1
h225 timeout tcp establish 4
!
voice class h323 2
h225 timeout tcp establish 2
!
!
!
voice class dualtone-detect-params 1
!
!
voice class custom-cptone Guatemala
dualtone busy
frequency 425
cadence 250 250
dualtone reorder
frequency 425
cadence 320 320
!
!
!
!
!
!
application
global
service alternate DEFAULT
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.100.1 255.255.255.0
no ip mroute-cache
speed 10
half-duplex
h323-gateway voip interface
h323-gateway voip h323-id VoiceGW
h323-gateway voip bind srcaddr 192.168.100.1
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip http server
no ip http secure-server
ip forward-protocol nd
no ip forward-protocol udp tftp
no ip forward-protocol udp domain
no ip forward-protocol udp time
no ip forward-protocol udp netbios-ns
no ip forward-protocol udp netbios-dgm
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 20 voip
destination-pattern ....
session target ipv4:192.168.100.100
!
!
!
line con 0
login local
line aux 0
line vty 0 4
line vty 5 15
login local
!
!
end

VoiceGW#

could any one help me please ?
Thanks all.




Top
 Profile  
 
 Post subject: Re: Small Voice Lab GNS3 with Vmware Problem
PostPosted: Thu Feb 16, 2012 10:26 am 
Offline

Joined: Tue Feb 14, 2012 8:30 am
Posts: 35
OK, I know nothing about configuring Voice GWs ... But I can see a problem in your configuration that could be the cause ... It resides in the DHCP excluded IP addresses ...

mohamedselim wrote:
ip dhcp excluded-address 192.168.100.100
ip dhcp excluded-address 192.168.100.1
ip dhcp excluded-address 192.168.100.2


In this part you informed the DHCP to not provide IP addresses from 192.168.100.1 till 192.168.100.255

ip dhcp excluded-address explaination from Cisco:
Quote:
Router(config)# ip dhcp excluded-address low-address [high-address]


This means, you can either specify low/high IP range, or use only the low IP and the DHCP will consider the end of the subnet is the high IP.

Ex:

Router(config)# ip dhcp excluded-address 192.168.100.100 <<<<<<<< This will exclude the IP Addresses from 192.168.100 till the end of the subnet 192.168.100.255

Router(config)# ip dhcp excluded-address 192.168.100.1 192.168.100.100 <<<<<<<<<< This will exclude the IP Addresses from 192.168.100.192 till 192.168.100.100, this means that the connected hosts will obtain IPs starting from 192.168.100.101

Hope you get my point ...




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO