It is currently Mon Jan 25, 2021 10:39 am

All times are UTC

Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Connecting to a real network
PostPosted: Fri Mar 23, 2012 2:51 pm 

Joined: Fri Mar 23, 2012 2:37 pm
Posts: 6

Using Ubuntu to connect to GNS3



inter fast 0/0
ip address
no shutdown

checked this with:

show ip route
show ip interface brief

its there its all ok

Open GNS3 as root

Put the cloud network in, configure it with my eth0 interface, no current ip. switch everything on, everything. turns green

using the terminal on my machine ifconfig shows me that i dont have an ip - ok

sudo ifconfig eth0 netmask

checked again with ifconfig and yes its there

i can ping - local machine all ok so far

i then try and ping - NO, does not work, uh ?

ok, so what am i doing wrong ???

I used wireshark to capture the data, when i ping from the Virtual router, i can see the ARP requests, basically broadcasting asking where is, but of course there is no reply to the ARP request

so, i thought my method of assigning an ip address to my eth0 is only temp, as when i restart the IP address is gone, so i . . . . .

gksudo gedit /etc/network/interfaces

auto eth0
iface eth0 inet static

rebooted and now my eth0 interface has an IP at start up, but this has solved nothing.

last thing i tried was to assign a faste 0/0 to the router, but of course that didnt work either

Any help would be appreciated . . . . . .


 Post subject: Re: Connecting to a real network
PostPosted: Sat Mar 24, 2012 6:09 pm 

Joined: Fri Mar 23, 2012 2:37 pm
Posts: 6
So i managed to get ubuntu connected to the GNS3 network, i managed to set up a virtual interface on my connect that to the GNS3 network

Commands to set up a bridge group

1. Sets up a tap interface, a tap interface is just a virtual interface inside the systsem.

sudo tunctl -u username -t tap0

-t is the interface name
-u is the unsername

** After entering in the above command a message appears: Set 'tap0' persistent and owned by uid 1000
i thought this was an error message the first time i saw it, its not. Its a confirmation from the previous command, you can test to see if the interface was created by issuing:

ifconfig -a

-a Shows all interfaces even if they are not up.

** You may find tunctl is not installed, if this is the case you need to run the following

sudo apt-get install uml-utilities

2. remove any ip addresses assigned to the interfaces and set them to promiscuous mode

sudo ifconfig tap0 promisc up
sudo ifconfig eth0 promisc up

3. Use the bridge control command to setup a new interface

sudo brctl addbr br0

4. Then add our tap0 & eth0 to the bridge interface

sudo brctl addif br0 tap0
sudo brctl addif br0 eth0

5. Bring the bridge interface up and assign it an ip address

sudo ifconfig br0 up
sudo ifconfig br0 **** not sure about the IP address


sudo btctl show OR use ifconfig to see all the interface

Your tap0 & eth0 will not have an ip address

GOOGLE SEARCH : gns3 linux tap interface

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 0 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group