It is currently Mon Aug 19, 2019 10:46 pm


All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Thu Jul 07, 2011 9:16 pm 
Offline

Joined: Thu Jul 07, 2011 9:12 pm
Posts: 2
Hi all,


I need some help here.


I have configured Frame Relay with 4 routers (c2691) in GNS3, one router acting as FRS (Frame Relay Switch)


My Lab Objectives are:
1. Configure EIGRP using AS 25
2. All networks should be announced via EIGRP and should be reachable from all routers (we need to ping loopback interfaces to test connection). You may not change

the underlying Frame Relay configuration or IP addressing to accomplish this.


the Lab objective does not allow me to create a manual map between EAST and WEST router using frame-relay map ip command


my 4 routers are named HQ, FRS, EAST and WEST


I have oulined my 4 routers configuration below.


Router EAST and WEST can't ping each other but they see each other's loopback interfaces in the routing table


Both EAST and WEST routers can ping HQ router and HQ router can ping all routers interfaces.
Slit-horizon if turned off on sub-interfaces


can anyone check my configuration files tell me what I am doing wrong?


thank you in advance.
======Frame-relay Switch - Router configuration======
!
hostname FRS
!
!
frame-relay switching
!
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 102 interface Serial0/1 201
frame-relay route 103 interface Serial0/2 301
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 201 interface Serial0/0 102
!
interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 2000000
frame-relay intf-type dce
frame-relay route 301 interface Serial0/0 103
***************
FRS#show frame-relay route
Input Intf Input Dlci Output Intf Output Dlci Status
Serial0/0 102 Serial0/1 201 active
Serial0/0 103 Serial0/2 301 active
Serial0/1 201 Serial0/0 102 active
Serial0/2 301 Serial0/0 103 active
FRS#
=======HQ Router configuration=====
!
hostname HQ
!
!
interface Loopback1
ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
ip address 10.1.3.1 255.255.255.0
!
interface Serial0/0
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/0.1 multipoint
ip address 172.16.124.1 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.2 102 broadcast
frame-relay map ip 172.16.124.3 103 broadcast
!
!
router eigrp 25
network 10.1.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
**************************
HQ#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/0.1
10.0.0.0/24 is subnetted, 9 subnets
D 10.3.1.0 [90/2297856] via 172.16.124.3, 00:25:47, Serial0/0.1
C 10.1.3.0 is directly connected, Loopback3
D 10.2.1.0 [90/2297856] via 172.16.124.2, 00:25:47, Serial0/0.1
C 10.1.2.0 is directly connected, Loopback2
D 10.3.3.0 [90/2297856] via 172.16.124.3, 00:25:47, Serial0/0.1
D 10.2.2.0 [90/2297856] via 172.16.124.2, 00:25:47, Serial0/0.1
C 10.1.1.0 is directly connected, Loopback1
D 10.3.2.0 [90/2297856] via 172.16.124.3, 00:25:48, Serial0/0.1
D 10.2.3.0 [90/2297856] via 172.16.124.2, 00:25:48, Serial0/0.1
=====EAST Router Configuration====
!
hostname EAST
!
interface Loopback1
ip address 10.2.1.1 255.255.255.0
!
interface Loopback2
ip address 10.2.2.1 255.255.255.0
!
interface Loopback3
ip address 10.2.3.1 255.255.255.0
!
!
interface Serial0/1
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/1.2 multipoint
ip address 172.16.124.2 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.1 201 broadcast
!
!
router eigrp 25
network 10.2.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
************
EAST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/1.2
10.0.0.0/24 is subnetted, 9 subnets
D 10.3.1.0 [90/2809856] via 172.16.124.1, 00:25:32, Serial0/1.2
D 10.1.3.0 [90/2297856] via 172.16.124.1, 00:25:32, Serial0/1.2
C 10.2.1.0 is directly connected, Loopback1
D 10.1.2.0 [90/2297856] via 172.16.124.1, 00:25:32, Serial0/1.2
D 10.3.3.0 [90/2809856] via 172.16.124.1, 00:25:32, Serial0/1.2
C 10.2.2.0 is directly connected, Loopback2
D 10.1.1.0 [90/2297856] via 172.16.124.1, 00:25:33, Serial0/1.2
D 10.3.2.0 [90/2809856] via 172.16.124.1, 00:25:33, Serial0/1.2
C 10.2.3.0 is directly connected, Loopback3
======WEST Router Configuration====
!
hostname WEST
!
!
interface Loopback1
ip address 10.3.1.1 255.255.255.0
!
interface Loopback2
ip address 10.3.2.1 255.255.255.0
!
interface Loopback3
ip address 10.3.3.1 255.255.255.0
!
!
interface Serial0/2
no ip address
encapsulation frame-relay
clock rate 2000000
!
interface Serial0/2.3 multipoint
ip address 172.16.124.3 255.255.255.248
no ip split-horizon eigrp 25
frame-relay map ip 172.16.124.1 301 broadcast
!
!
router eigrp 25
network 10.3.0.0 0.0.255.255
network 172.16.0.0
no auto-summary
!
**********
WEST#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route


Gateway of last resort is not set


172.16.0.0/29 is subnetted, 1 subnets
C 172.16.124.0 is directly connected, Serial0/2.3
10.0.0.0/24 is subnetted, 9 subnets
C 10.3.1.0 is directly connected, Loopback1
D 10.1.3.0 [90/2297856] via 172.16.124.1, 00:25:58, Serial0/2.3
D 10.2.1.0 [90/2809856] via 172.16.124.1, 00:25:57, Serial0/2.3
D 10.1.2.0 [90/2297856] via 172.16.124.1, 00:25:58, Serial0/2.3
C 10.3.3.0 is directly connected, Loopback3
D 10.2.2.0 [90/2809856] via 172.16.124.1, 00:25:57, Serial0/2.3
D 10.1.1.0 [90/2297856] via 172.16.124.1, 00:25:59, Serial0/2.3
C 10.3.2.0 is directly connected, Loopback2
D 10.2.3.0 [90/2809856] via 172.16.124.1, 00:25:59, Serial0/2.3
==============

Again Thank you all in advance.

Vayanga




Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Sun Jul 10, 2011 7:53 am 
Offline

Joined: Wed Feb 16, 2011 5:07 pm
Posts: 114
the problem is the source of the ping.
by default the ip source of the ping is the ip of the outgoing interface.
Also, you have frame relay static mapping and not inverse arp.

HQ knows what dlci to use to ping both east and west.

EAST knows only what dlci to use to ping HQ ip

WEST know only what dlci to use to ping HQ ip

EAST (or WEST) doesn't know what dlci to use to forward packets to WEST (or EAST)


the real solution would be to map into EAST the ip addr of WEST using the EAST-HQ dlci like:

frame-relay map ip 172.16.124.3 201 broadcast (note you are using the same dlci to forward packets to HQ and WEST)

the same should be done on WEST.

BUT because looks like you cannot edit the frame-relay configuration, your lab is over and successful.
to test it, use as source of the ping the loopback ip address.

for example

i want to ping FROM EAST the WEST loopback 3

ping 10.3.3.1 --> this ping will fail because of what explained before, and infact:

EAST#ping 10.3.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


but, if i ping FROM EAST loopback (any of them, in this case loopback3) the WEST loopback 3

EAST#ping 10.3.3.1 source 10.2.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
Packet sent with a source address of 10.2.3.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/81/104 ms
EAST#

the ping succed.


please note carefully the reason of the successful/unsuccessful ping again is:

pinging without source, i use the serial ip address, i know where to sent the packet, but when the packet reach the other end it doesn't know how to come back. ping FAIL

pinging with the source ip address of a loopback, the packets knows the way to go and come back (it's in the routers routing table) than the ping succed

hope this helps


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Mon Jul 11, 2011 7:10 pm 
Offline

Joined: Thu Jul 07, 2011 9:12 pm
Posts: 2
HI anubisg1,

Thank you indeed for your time and reply.

I did your suggestion before and that worked fine, I was just thinking that disabling slip-horizon on HQ sub-interface which allowed both EAST and WEST routers to see each other's routing table information, could also allow them to ping without further configuration changes.

but your explaination helped me understand the point I was missing.

again Thanks!

Vayanga.


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Mon Jul 11, 2011 9:23 pm 
Offline

Joined: Wed Feb 16, 2011 5:07 pm
Posts: 114
happy it was useful :)

you will understand that better when you'll study the chapter about ospf virtual links and frame-relay issues.

Andrea


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Sun Sep 18, 2011 7:01 am 
Offline

Joined: Wed Feb 16, 2011 5:07 pm
Posts: 114
i guess you had the same issue isn't it :D


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Thu Jun 07, 2012 6:12 pm 
Offline

Joined: Mon May 21, 2012 6:10 am
Posts: 2
Hi,

I tried adding the frame relay map for both EAST and WEST but still unable to ping but can ping with source. Do I need to change the configurations on my relay switch?

I'm following this lab on my self study.

Kindly advise.



EAST#ping 10.3.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.3.3.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)



EAST
++++
frame-relay map ip 172.16.124.1 201 broadcast
frame-relay map ip 172.16.124.3 201 broadcast



WEST
++++
frame-relay map ip 172.16.124.1 301 broadcast
frame-relay map ip 172.16.124.2 301 broadcast


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Mon Dec 31, 2012 8:25 pm 
Offline

Joined: Mon Dec 31, 2012 8:23 pm
Posts: 1
Great, this post is really helpful :) Thanks


Top
 Profile  
 
 Post subject: Re: CCNP Frame-Relay Configuration Lab hub and spoke
PostPosted: Tue Apr 23, 2013 11:42 pm 
Offline

Joined: Tue Apr 23, 2013 11:31 pm
Posts: 1
Hello!
I have encountered very similar problem to the described one above, but I was using different routing protocol - OSPF and while I was playing with using point-to-point, multipoint and raw interface during configuration of the frame-relay.

When I was running debug ip packet and pinging, that was my result:

R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
*Mar 1 02:31:31.171: IP: tableid=0, s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), routed via RIB
*Mar 1 02:31:31.171: IP: s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), len 100, sending
*Mar 1 02:31:31.171: IP: s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), len 100, encapsulation failed.
*Mar 1 02:31:33.167: IP: tableid=0, s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), routed via RIB
*Mar 1 02:31:33.167: IP: s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), len 100, sending
*Mar 1 02:31:33.171: IP: s=172.12.123.2 (local), d=3.3.3.3 (Serial1/0.123), len 100, encapsulation failed.


Another thing that is worthy to menton here in this topic:

R1#show frame-relay lmi

LMI Statistics for interface Serial1/0 (Frame Relay DTE) LMI TYPE = ANSI
Invalid Unnumbered info 0 Invalid Prot Disc 0
Invalid dummy Call Ref 0 Invalid Msg Type 0
Invalid Status Message 0 Invalid Lock Shift 0
Invalid Information ID 0 Invalid Report IE Len 0
Invalid Report Request 0 Invalid Keep IE Len 0
Num Status Enq. Sent 751 Num Status msgs Rcvd 706
Num Update Status Rcvd 0 Num Status Timeouts 45
Last Full Status Req 00:00:01 Last Full Status Rcvd 00:00:01

You cannot help that, it will stay like that, it is not possible to change (for whatever testing reason you would possibly wanted to do it), but instead using that drag and drop device which is Frame Relay switch you can utilize router in order to accomplish more advanced features.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO