It is currently Sun Aug 25, 2019 8:16 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Issues with router throughput while using multihomed BGP net
PostPosted: Thu May 02, 2013 12:59 pm 
Offline

Joined: Thu May 02, 2013 12:56 pm
Posts: 1
We have a multihomed WAN connectivity, the primary link is give the priority as it has 100 Mbps and we wish to failover to secondary (30 Mbps) only when primary is down. Attached the diagram for reference.

Previous to the BGP link we had a static connectivity to single ISP(ISP1) and this used to be the default routing path. Now for redundancy purpose we have changed the default path to go via the bgp network.

After changing the default route to BGP we have noticed that the download speed dropped down to 20 kb/s, also the outside interface usage not crossing 3 Mb/s. Later for testing purpose we have shutdown the secondary ISP interface (int g0/2) and suddenly the outside interface bandwidth gone up to 50 % of its capacity and also the download speed increased to the normal values.

We are continuiing with the secondary interface shutdown and planning to manually bring this interface if primary goes down. Any idea why the bandwidth is dropping when both ISP interfaces are active. Below are the BGP configurations in the WAN router, please help me to fix this issue because i am clueless about the problem.

!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/1
description ISP-1 OUTSIDE
ip address 141.41.176.26 255.255.255.252
load-interval 30
duplex full
speed 100
!
interface GigabitEthernet0/2
description ISP-2 OUTSIDE
ip address 180.51.19.10 255.255.255.252
load-interval 30
shutdown
duplex full
speed 1000
!
interface GigabitEthernet0/1/0
description Static INT to FIREWALL
switchport access vlan 141
no ip address
duplex full
speed 100
!
interface GigabitEthernet0/1/1
description BGP INT to FIREWALL
switchport access vlan 102
no ip address
duplex full
speed 100
!
interface GigabitEthernet0/1/2
description DNS
switchport access vlan 102
no ip address
!
interface Vlan102
description ###BGP WAN Pool - VLAN ###
ip address 102.15.150.1 255.255.255.224
!
interface Vlan141
description ISP-1 WAN Pool VLAN
ip address 141.41.176.125 255.255.255.224
!
router bgp 123456
bgp log-neighbor-changes
network 102.15.150.0 mask 255.255.255.0
neighbor 180.51.19.10 remote-as 12121
neighbor 180.51.19.10 description isp2
neighbor 180.51.19.10 soft-reconfiguration inbound
neighbor 180.51.19.10 route-map isp2 out
neighbor 141.41.176.26 remote-as 45450
neighbor 141.41.176.26 description isp1
neighbor 141.41.176.26 soft-reconfiguration inbound
neighbor 141.41.176.26 route-map isp1 out
maximum-paths 2
!
ip route 102.15.150.0 255.255.255.0 Null0 220
!
ip prefix-list isp1 seq 5 permit 102.15.150.0/24
!
ip prefix-list isp2 seq 5 permit 102.15.150.0/24
access-list 10 permit 102.15.150.0 0.0.0.255
!
route-map isp1 permit 10
match ip address prefix-list isp1
!
route-map isp2 permit 20
match ip address 10
set as-path prepend 123456 123456
!




Attachments:
BGP.jpg
BGP.jpg [ 32.64 KiB | Viewed 2537 times ]
Top
 Profile  
 
 Post subject: Re: Issues with router throughput while using multihomed BGP
PostPosted: Sat May 04, 2013 1:51 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
I think you might be in the wrong forum - GNS3 is never going to run 30Mb/s let alone 100Mb/s.

Try the Cisco learning forum.



_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO