It is currently Thu Jul 18, 2019 12:48 am


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Can't ping Router in GNS3 from Physical Switch & Vice Versa
PostPosted: Tue Apr 05, 2011 7:34 am 
Offline

Joined: Wed Mar 16, 2011 7:35 pm
Posts: 20
Hello All...

After a while of trying to use real switches with GNS3, I have made great progress, but I still haven't won the war! After I perform a ping, I can see the each device's MAC address in the other end's respective ARP tables, put the pings are still unsuccessful....

I have seen numerous post about seeing the "encapsulation failed" message that is generated from using debug ip packet...

The only time that I see the encapsulation failed message is when I unplug the ethernet cable and plug it back it and then perform pings. After the first initial ping sequence, it no longer says that.



This is the messages that are generated when I unplug the ethernet cable, plug it pack in, then ping Sw1 from R3 (debug ip packet is on on both devices):



Rack1R3#ping 155.1.37.7 repeat 1



Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 155.1.37.7, timeout is 2 seconds:



*Mar 1 01:23:34.095: IP: tableid=0, s=155.1.37.3 (local), d=155.1.37.7 (FastEthernet0/0), routed via FIB

*Mar 1 01:23:34.095: IP: s=155.1.37.3 (local), d=155.1.37.7 (FastEthernet0/0), len 100, sending.

Success rate is 0 percent (0/1)



Rack1SW1#

*Mar 1 02:07:26.539: IP: s=155.1.37.3 (FastEthernet0/3), d=155.1.37.7, len 100, rcvd 2

*Mar 1 02:07:26.539: IP: s=155.1.37.3 (FastEthernet0/3), d=155.1.37.7, len 100, stop process pak for forus packet

*Mar 1 02:07:26.539: IP: s=155.1.37.7 (local), d=155.1.37.3, len 100, local feature, Clustering(7), rtype 0, forus FALSE, sendself FALSE, mtu 0

*Mar 1 02:07:26.539: IP: tableid=0, s=155.1.37.7 (local), d=155.1.37.3 (FastEthernet0/3), routed via RIB

*Mar 1 02:07:26.539: IP: s=155.1.37.7 (local), d=1

Rack1SW1#55.1.37.3 (FastEthernet0/3), len 100, sending

*Mar 1 02:07:26.543: IP: s=155.1.37.7 (local), d=155.1.37.3 (FastEthernet0/3), len 100, encapsulation failed <------ encap failed message



Now, after the initial ping, this is what the debug ip packet prints to the console if I perform more pings:



Rack1R3#ping 155.1.37.7 repeat 1



Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 155.1.37.7, timeout is 2 seconds:



*Mar 1 01:27:52.771: IP: tableid=0, s=155.1.37.3 (local), d=155.1.37.7 (FastEthernet0/0), routed via FIB

*Mar 1 01:27:52.771: IP: s=155.1.37.3 (local), d=155.1.37.7 (FastEthernet0/0), len 100, sending.

Success rate is 0 percent (0/1)



Rack1SW1#

*Mar 1 02:11:45.215: IP: s=155.1.37.3 (FastEthernet0/3), d=155.1.37.7, len 100, rcvd 2

*Mar 1 02:11:45.215: IP: s=155.1.37.3 (FastEthernet0/3), d=155.1.37.7, len 100, stop process pak for forus packet

*Mar 1 02:11:45.215: IP: s=155.1.37.7 (local), d=155.1.37.3, len 100, local feature, Clustering(7), rtype 0, forus FALSE, sendself FALSE, mtu 0

*Mar 1 02:11:45.215: IP: tableid=0, s=155.1.37.7 (local), d=155.1.37.3 (FastEthernet0/3), routed via FIB

*Mar 1 02:11:45.215: IP: s=155.1.37.7 (local), d=1

Rack1SW1#55.1.37.3 (FastEthernet0/3), len 100, sending

*Mar 1 02:11:45.215: IP: s=155.1.37.7 (local), d=155.1.37.3 (FastEthernet0/3), len 100, sending full packet



**I noticed, when I ping SW1 from R3, the debug ip packet messages pops up on Sw1. If I ping R3 from Sw1, no debug ip packet messages pop up on R3**



----------------------------------------------------------------





As you can see, you can see both of the end devices' MAC address in their respective ARP tables:



Rack1SW1#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 1.1.1.1 - 000d.edd6.4080 ARPA Vlan2

Internet 150.1.7.7 - 000d.edd6.4080 ARPA Vlan79

Internet 155.1.7.7 - 000d.edd6.4080 ARPA Vlan7

Internet 155.1.37.7 - 000d.edd6.4080 ARPA FastEthernet0/3

Internet 155.1.37.3 5 c205.0271.0000 ARPA FastEthernet0/3

Internet 155.1.67.7 - 000d.edd6.4080 ARPA Vlan67





Rack1R3#sh arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 155.1.37.3 - c205.0271.0000 ARPA FastEthernet0/0

Internet 155.1.37.7 5 000d.edd6.4080 ARPA FastEthernet0/0



----------------------------------------------------------------



Below is the show run from the Breakout Switch and SW1:



BREAKOUT#sh run

Building configuration...



Current configuration : 5983 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname BREAKOUT

!

!

no aaa new-model

ip subnet-zero

!

vtp mode transparent

!

!

crypto pki trustpoint TP-self-signed-3991959936

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3991959936

revocation-check none

rsakeypair TP-self-signed-3991959936

!

!

crypto pki certificate chain TP-self-signed-3991959936

certificate self-signed 01

30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 33393931 39353939 3336301E 170D3933 30333031 30303031

30355A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39393139

35393933 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100CA0C 91456D21 01159132 2DF52CFD 9FBD3DCC 45F9DBD2 5515D159 F75787A8

4AB8E41A D720545A 762D8ED5 A4D7A899 053849D8 C386FC7B 8742F1D5 49E1900F

B7ADB168 BC6A4C6B 05CFB03C E0C4A420 69369C47 A5BA6963 A9D93178 E0FDA71D

1AD6E049 A908AC3B AC63F394 9809A9BD 09B3A56A 68219E4A 2D2F5567 D8788AA4

12410203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603

551D1104 0D300B82 09425245 414B4F55 542E301F 0603551D 23041830 1680147D

DBEF81B2 30EAB0EE 656FFF37 61B922AA 7390C930 1D060355 1D0E0416 04147DDB

EF81B230 EAB0EE65 6FFF3761 B922AA73 90C9300D 06092A86 4886F70D 01010405

00038181 003E9C37 53E1B5F9 B70195DD 24884804 9340F8F9 467F789D C2B83904

EC82C8BE DCD7E0A0 EB3FA3D8 D9936B2A 1853A260 ED8A4656 9B62509F 6FDC043A

88A20103 551C2284 6BB581B3 BBC25D41 FBAACBBE 279DA5C1 58155BC6 D873E879

132B461E C7E57880 049D69FC 2CA05CB1 EFB67327 DD4A61C6 873615A6 8509A676

7BFDC16C EE

quit

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

vlan 101

name R1-F0/0

!

vlan 102

name R2-F0/0

!

vlan 103

name R3-F0/0

!

vlan 104

name R3-F0/1

!

vlan 105

name R4-F0/0

!

vlan 106

name R4-F0/1

!

vlan 107

name R5-F0/0

!

vlan 108

name R5-F0/1

!

vlan 109

name R6-F0/0

!

vlan 110

name R6-F0/1

!

vlan 111

name BB2-F0/0

!

vlan 112

name BB3-F0/0

!

!

!

!

!

!

interface FastEthernet0/1

description Connection to R1 F0/0

switchport access vlan 101

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/2

description Connection to R2 F0/0

switchport access vlan 102

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

spanning-tree portfast

!

interface FastEthernet0/3

description Connection to R3 F0/0

switchport access vlan 103

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/4

description Connection to R3 F0/1

switchport access vlan 104

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/5

description Connection to R4 F0/0

switchport access vlan 105

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

spanning-tree portfast

!

interface FastEthernet0/6

description Connection to R4 F0/1

switchport access vlan 106

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/7

description Connection to R5 F0/0

switchport access vlan 107

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/8

description Connection to R5 F0/1

switchport access vlan 108

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/9

description Connection to R6 F0/0

switchport access vlan 109

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

no cdp enable

spanning-tree portfast

!

interface FastEthernet0/10

description Connection to R6 F0/1

switchport access vlan 110

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

spanning-tree portfast

!

interface FastEthernet0/11

description Connection to BB2 F0/0

switchport access vlan 111

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

spanning-tree portfast

!

interface FastEthernet0/12

description Connection to BB3 F0/1

switchport access vlan 112

switchport mode access

speed 100

duplex full

l2protocol-tunnel cdp

spanning-tree portfast

!

interface FastEthernet0/13

description Trunk to Macbook Pro

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 101-112

switchport mode trunk

spanning-tree portfast trunk



----------------------------------------------------------------







Rack1SW1#sh run

Building configuration...



Current configuration : 4127 bytes

!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Rack1SW1

!

!

no aaa new-model

ip subnet-zero

ip routing

no ip domain-lookup

!

!

!

crypto pki trustpoint TP-self-signed-3990241408

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-3990241408

revocation-check none

rsakeypair TP-self-signed-3990241408

!

!

crypto pki certificate chain TP-self-signed-3990241408

certificate self-signed 01

30820241 308201AA A0030201 02020101 300D0609 2A864886 F70D0101 04050030

31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

69666963 6174652D 33393930 32343134 3038301E 170D3933 30333031 30303031

30315A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 39393032

34313430 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

8100BE20 87ACAD50 D783B53E 0467D58D 1C519E97 35A1FBB3 80BA2D43 AD4579A8

B101FF22 B970A8CA 6D9E3256 AC711D5C C2F038AF D1E54968 8ED290E5 77DFB55B

E380FACB D2980377 63055C0F 08407CE4 42D267A2 91198349 4F90D0F6 C9AEC86F

3FF6856C F9CD89D5 545B537E 8846B095 871D5537 96CE4E21 FF1620E2 C96ED98B

5E090203 010001A3 69306730 0F060355 1D130101 FF040530 030101FF 30140603

551D1104 0D300B82 09526163 6B315357 312E301F 0603551D 23041830 16801419

ECFD7E45 6FB050D9 C45B2CD4 36339753 A1CD9730 1D060355 1D0E0416 041419EC

FD7E456F B050D9C4 5B2CD436 339753A1 CD97300D 06092A86 4886F70D 01010405

00038181 0088C06E 40B8438C 60D9BD8C 8D6DF61B 21DAD938 EF35D88B 0E4D3533

9BE94BE0 65E83DFA 6BEADE47 C542E5FB 7DCAB07B 61BAB2E1 63F64477 22551B03

2A0642AD F4F80F1D 77678F20 CA96E6CB 50F96CDD 2AABF691 B6B1FA13 2DB438AC

EBCDBFF4 C3424EF1 35962F1A 13C41287 D641F7BB B4AF2533 608E19AA 10D6C22E

912B6DEE BE

quit

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

!

!

!

interface FastEthernet0/1

description Connection to R1 F0/0

switchport access vlan 101

switchport mode access

!

interface FastEthernet0/2

switchport mode access

!

interface FastEthernet0/3

description Connection to R3 F0/0

no switchport

ip address 155.1.37.7 255.255.255.0

!

interface FastEthernet0/4

switchport mode access

!

interface FastEthernet0/5

switchport access vlan 105

switchport mode access

!

interface FastEthernet0/6

switchport mode access

!

interface FastEthernet0/7

description Connection to R5 F0/0

switchport mode access

switchport access van 107

!

interface FastEthernet0/8

switchport mode access

!

interface FastEthernet0/9

switchport mode access

!

--More--







As you can see I can see all the devices in GNS3 from the Breakout switch per "sh cdp nei"



BREAKOUT#sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone



Device ID Local Intrfce Holdtme Capability Platform Port ID

BB2 Fas 0/13 130 R S I 3725 Fas 0/0

BB3 Fas 0/13 123 R S I 3725 Fas 0/0

Rack1R1 Fas 0/13 148 R S I 3725 Fas 0/0

Rack1R2 Fas 0/13 160 R S I 3725 Fas 0/0

Rack1R3 Fas 0/13 171 R S I 3725 Fas 0/0

Rack1R4 Fas 0/13 173 R S I 3725 Fas 0/1

Rack1R4 Fas 0/13 172 R S I 3725 Fas 0/0

Rack1R5 Fas 0/13 126 R S I 3725 Fas 0/1

Rack1R5 Fas 0/13 126 R S I 3725 Fas 0/0

Rack1R6 Fas 0/13 128 R S I 3725 Fas 0/1

Rack1R6 Fas 0/13 128 R S I 3725 Fas 0/0



----------------------------------------------------------------



Here is my revised .net file:



autostart = False

[localhost:7200]

workingdir = /tmp

udp = 10000

[[3725]]

image = /Users/Edwin/Documents/Cisco/Cisco Images/c3725-adventerprisek9.bin.unpacked

ram = 128

idlepc = 0x6148b534

ghostios = True

[[ROUTER R4]]

model = 3725

console = 2004

cnfg = /Applications/GNS3.app/Contents/Resources/R4.cfg

wic0/0 = WIC-2T

s0/0 = FR0 5

s0/1 = R5 s0/1

f0/0 = nio_gen_eth:vlan5

f0/1 = nio_gen_eth:vlan6

x = -665.751599423

y = -92.8598054844

[[ROUTER R5]]

model = 3725

console = 2005

cnfg = /Applications/GNS3.app/Contents/Resources/R5.cfg

wic0/0 = WIC-2T

s0/0 = FR0 6

s0/1 = R4 s0/1

f0/0 = nio_gen_eth:vlan7

f0/1 = nio_gen_eth:vlan8

x = -577.587552236

y = 33.4403683251

[[ROUTER R6]]

model = 3725

console = 2006

cnfg = /Applications/GNS3.app/Contents/Resources/R6.cfg

wic0/0 = WIC-2T

s0/0 = BB1 s0/0

f0/0 = nio_gen_eth:vlan9

f0/1 = nio_gen_eth:vlan10

x = -300.209422727

y = 28.6282681803

[[ROUTER R1]]

model = 3725

console = 2001

cnfg = /Applications/GNS3.app/Contents/Resources/R1.cfg

wic0/0 = WIC-2T

s0/0 = FR0 1

s0/1 = R3 s1/2

f0/0 = nio_gen_eth:vlan1

x = -297.624200289

y = -315.259457866

[[ROUTER R2]]

model = 3725

console = 2002

cnfg = /Applications/GNS3.app/Contents/Resources/R2.cfg

wic0/0 = WIC-2T

s0/0 = FR0 2

s0/1 = R3 s1/3

f0/0 = nio_gen_eth:vlan2

x = -598.67597352

y = -321.853407794

[[ROUTER R3]]

model = 3725

console = 2003

cnfg = /Applications/GNS3.app/Contents/Resources/R3.cfg

f0/0 = nio_gen_eth:vlan3

f0/1 = nio_gen_eth:vlan4

slot1 = NM-4T

s1/0 = FR0 3

s1/1 = FR0 4

s1/2 = R1 s0/1

s1/3 = R2 s0/1

x = -449.548574387

y = -389.183831964

[[FRSW FR0]]

1:102 = 2:201

1:103 = 3:301

1:104 = 5:401

1:105 = 6:501

1:113 = 4:311

2:201 = 1:102

2:203 = 3:302

2:204 = 5:402

2:205 = 6:502

2:213 = 4:312

3:301 = 1:103

3:302 = 2:203

3:304 = 5:403

3:305 = 6:503

4:311 = 1:113

4:312 = 2:213

4:314 = 5:413

4:315 = 6:513

5:401 = 1:104

5:402 = 2:204

5:403 = 3:304

5:405 = 6:504

5:413 = 4:314

6:501 = 1:105

6:502 = 2:205

6:503 = 3:305

6:504 = 5:405

6:513 = 4:315

1 = R1 s0/0

2 = R2 s0/0

3 = R3 s1/0

4 = R3 s1/1

5 = R4 s0/0

6 = R5 s0/0

x = -415.363873377

y = 77.5

[[ROUTER BB3]]

model = 3725

console = 2013

cnfg = /Applications/GNS3.app/Contents/Resources/BB3.cfg

wic0/0 = WIC-2T

s0/0 = BB1 s0/1

f0/0 = nio_gen_eth:vlan12

x = -235.792907072

y = -208.123331242

[[ROUTER BB2]]

model = 3725

console = 2012

cnfg = /Applications/GNS3.app/Contents/Resources/BB2.cfg

f0/0 = nio_gen_eth:vlan11

x = -666.848748196

y = -208.311231098

[[ROUTER BB1]]

model = 3725

console = 2011

cnfg = /Applications/GNS3.app/Contents/Resources/BB1.cfg

wic0/0 = WIC-2T

s0/0 = R6 s0/0

s0/1 = BB3 s0/0

x = -237.842350505

y = -87.6719056288

[GNS3-DATA]

configs = /Applications/GNS3.app/Contents/Resources

m11 = 0.831237896143

m22 = 0.831237896143

[[Cloud C1]]

x = -496.960153103

y = -140.945896969

connections = R6:f0/0:nio_gen_eth:vlan9 R5:f0/1:nio_gen_eth:vlan8 R5:f0/0:nio_gen_eth:vlan7 R4:f0/1:nio_gen_eth:vlan6 R4:f0/0:nio_gen_eth:vlan5 R3:f0/1:nio_gen_eth:vlan4 R3:f0/0:nio_gen_eth:vlan3 R2:f0/0:nio_gen_eth:vlan2 R1:f0/0:nio_gen_eth:vlan1 BB3:f0/0:nio_gen_eth:vlan12 BB2:f0/0:nio_gen_eth:vlan11 R6:f0/1:nio_gen_eth:vlan10





----------------------------------------------------------------





I have checked numerous sites and I have worked on this for almost a week and I still can't get to the bottom of this… I don't want to give up, but I can't afford to keep wasting study time…



Does anything stick out to anyone? I wonder could it be my something with my Mac's en0 NIC stripping the 8021.q tag? I am going to try to install wire shark to investigate. I can't think of anything else it could be. I just find that so weird that I can ARP entry, but I can't ping….



Also, I just food out that the NIC on my mac can't do jumbo frames, but since I am not really doing a QinQ setup, could this still be a problem?



Thank you VERY much with your assistance with this.




Top
 Profile  
 
 Post subject: Re: Can't ping Router in GNS3 from Physical Switch & Vice Ve
PostPosted: Sat Jan 07, 2012 7:10 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

Did you manage to find a solution to your prob?

I've a problem too, I can see my ARP requests being answered by my real switch while capturing traffic on en0 but if I capture on vlan0, I cannot see the reply. Looks like en0 is not forwarding tagged and unicast traffic to vlan interfaces. This works for multicast/broadcast tagged frames.

Please, let me know your solution if you found one.

Cheers,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Can't ping Router in GNS3 from Physical Switch & Vice Ve
PostPosted: Sat May 11, 2013 8:02 am 
Offline

Joined: Sat May 11, 2013 7:53 am
Posts: 1
Try using one dot 1q trunk from the EtherSwitch to the Break Out Switch (nio_) interface. Do not use the nio_linux on the cloud as this made me lose two days just in t-shoot. Use the nio_gen_eth:eth0 instead. This seems to work for me. I am using a 3750 as the break out and I get duplex mismatch messages on the consoles in GNS3 and the real switches so I just disabled console logging until I need it.


Top
 Profile  
 
 Post subject: Re: Can't ping Router in GNS3 from Physical Switch & Vice Ve
PostPosted: Sat May 11, 2013 1:48 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
You can disable the duplex error messages without turning off console logging:

Quote:
R1(config)#no cdp log mismatch duplex


Cheers,



_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO