It is currently Sun Sep 23, 2018 12:52 am


All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: problem of ping
PostPosted: Fri May 17, 2013 9:23 am 
Offline

Joined: Fri May 17, 2013 8:55 am
Posts: 3
Hi

i'm usig GNS3 and i have to deal with this situation:

see the file : ca.jpg .

R5 has NM-1FE-TX modul (connected to R4).

R5 has also NM-16ESW modul (connected to R1,R2 and R3).

here are the config :

R4 :

!
interface FastEthernet0/0
ip address 190.1.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
ip address 190.1.2.1 255.255.255.0
duplex auto
speed auto
!
no ip http server
no ip http secure-server
!
ip classless
ip route 191.1.1.0 255.255.255.0 190.1.1.2
ip route 191.1.1.0 255.255.255.0 190.1.2.2
!
!
R5:

ip dhcp excluded-address 191.1.1.1 191.1.1.10
!
ip dhcp pool URNE
network 191.1.1.0 255.255.255.0
default-router 191.1.1.1
!
!
interface FastEthernet0/0
ip address 190.1.1.2 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet2/0
ip address 190.1.2.2 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet1/11
switchport access vlan 10
!
interface FastEthernet1/12
switchport access vlan 10
!
interface FastEthernet1/13
switchport access vlan 10
!
!
interface Vlan10
ip address 191.1.1.1 255.255.255.0
!
R1 :

!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
R2 :
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
R3 :
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
R1#ping 190.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/30/52 ms

R1#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/42/68 ms

R2#ping 190.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/68 ms

R2#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/39/60 ms

R3#ping 190.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/38/72 ms

R3#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/32/72 ms

EVREY THING IS FINE :

now i will shutdown interface f0/0 of R5:

R5(config)#interface f0/0
R5(config-if)#sh
R5(config-if)#end
R5#
*Mar 1 00:24:58.887: %SYS-5-CONFIG_I: Configured from console by console
*Mar 1 00:24:59.799: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state to administratively down
R5#
*Mar 1 00:25:00.799: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to down

And i ping from routers R1, R2 and R3 190.1.2.1 (other link :(f2/0-----f2/0)).

R1#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/32/64 ms

R2#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

why R2 can't ping and R1 can ?

R3#ping 190.1.2.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 190.1.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/53/84 ms




Attachments:
ca.jpg
ca.jpg [ 32.68 KiB | Viewed 3857 times ]
Top
 Profile  
 
 Post subject: Re: problem of ping
PostPosted: Fri May 17, 2013 10:35 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
try
no ip cef
in R5



Just a thought

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: problem of ping
PostPosted: Fri May 17, 2013 10:54 am 
Offline

Joined: Fri May 17, 2013 8:55 am
Posts: 3
rednectar wrote:
try
no ip cef
in R5



Just a thought


thank you for the reply

it didn't work :-(


Top
 Profile  
 
 Post subject: Re: problem of ping
PostPosted: Fri May 17, 2013 12:18 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
OK Try this:
Replace the links between R4 & R5 with serial links rather than Ethernet. I think you'll find that when you shut down the interface, it doesn't shout down the OTHER end of the link, so R4 still thinks it can get back to R5 via 190.1.1.2. (And so is load balancing per connection - and one router is unlucky getting ping replies on the "downed" link")

You should check R4 to see if this is the case

Alternatively, shut down the R4 end of the same link - that should do it.

Problem is, dynamips doesn't detect a link down on ethernet if the other end is down (probably because it has no way of knowing if there is one or many other devices on the same subnet - like if you had a switch between them)

HTH

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: problem of ping
PostPosted: Fri May 17, 2013 1:47 pm 
Offline

Joined: Fri May 17, 2013 8:55 am
Posts: 3
rednectar wrote:
OK Try this:
Replace the links between R4 & R5 with serial links rather than Ethernet. I think you'll find that when you shut down the interface, it doesn't shout down the OTHER end of the link, so R4 still thinks it can get back to R5 via 190.1.1.2. (And so is load balancing per connection - and one router is unlucky getting ping replies on the "downed" link")

You should check R4 to see if this is the case

Alternatively, shut down the R4 end of the same link - that should do it.

Problem is, dynamips doesn't detect a link down on ethernet if the other end is down (probably because it has no way of knowing if there is one or many other devices on the same subnet - like if you had a switch between them)

HTH


i got an answer from an expert in cisco forum the problem is in GNS3 ,that 's the expert's answer :

Hi,
on R4 f0/0 is still UP( that's GNS3 behaviour) and so both routes stay in the routing table of R4 and if R4 decided to forward the traffic out this interface then it is failing. You should implement tracking with IP SLA on your first static route on R4 and it will delete the route from the routing table when R5 next-hop is unreachable and it will only have one route and so one interface to send the replies and it will work.

Regards

Alain

i must add this on router R4 :

ip sla monitor 1
type echo protocol ipIcmpEcho 190.1.1.2 source-interface FastEthernet0/0

frequency 5
ip sla monitor schedule 1 life forever start-time now
!
!
!
track 1 rtr 1 reachability
!
access-list 199 permit icmp any host 190.1.1.2
route-map SLA
match ip add 199
ip local policy route-map SLA

ip route 191.1.1.0 255.255.255.0 190.1.1.2 track 1
ip route191.1.1.0 255.255.255.0 190.1.2.2 254


thank you for the reply




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO