It is currently Wed Nov 14, 2018 2:52 am


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: lesson on VLAN trunking
PostPosted: Sun Jun 30, 2013 6:43 pm 
Offline

Joined: Thu Mar 28, 2013 2:23 am
Posts: 6
Hey guys, not sure if Im in the right place here but a question about trunking. Im about done the CCENT book and shoring up my understanding about vlans.

On my router I have a switch hanging off fa0/0 and off that switch are two windows virtual boxes. I am using the default built in switch for this exercise. the port connecting the switch to the router is on VLAN 1 and is designated for DOT1Q trunking. One port is designated for VLAN 5 access mode to one winbox, and the other is designated for VLAN 10 to the other winbox.

The physical interface config I want to run trunking on pointing towards the switch:

interface FastEthernet0/0
ip address 50.50.50.1 255.255.255.0
ip helper-address 10.10.10.200
speed 100
full-duplex

In my router config I have created two vlans using two subinterfaces:

in fa0/0.5
FastEthernet0/1.5 7.7.7.1 YES manual up up

interface FastEthernet0/1.5
encapsulation dot1Q 5
ip address 7.7.7.1 255.255.255.0


in fa0/1.10
FastEthernet0/0.10 8.8.8.1 YES manual up up

interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 8.8.8.1 255.255.255.0


I am looking through the book and Im having a difficult time picturing their explanation. Do I now associate both of these subinterfaces with my actual FA0/0 interface that connects to the switch?

Do I associate the VLANS with the interface?


How does the router know which interface I want the subinterfaces to run through? or more appropriately how does the router know I want to trunk those two subinterface subnets on f0/0?


Also as an aside, lets say I configured vlan trunking on this segment, and wanted to attach this segment to the rest of my network. Do I need to add routing statements for the vlan's subnets on all the upstream routers (or add ospf routes) or does the router I originally configured trunking on send that packet to the next hop encapsulated in its own IP header?


attached is a pic of my so-called vlan setup




Attachments:
vlantest.JPG
vlantest.JPG [ 22.25 KiB | Viewed 2869 times ]
Top
 Profile  
 
 Post subject: Re: lesson on VLAN trunking
PostPosted: Sun Jun 30, 2013 6:50 pm 
Offline

Joined: Thu Mar 28, 2013 2:23 am
Posts: 6
OK OK OK OK OK OK OK OK..............................


I just realized what SUB interface is telling me...... I associate the subinterface with the interface because I noted F0/0.# where 0/0 denotes the physical interface I want create sub interfaces on......


yeash....


still wondering about the second part of my question regarding routing statements.


so now my config is as follows :

interface FastEthernet0/0
ip address 50.50.50.1 255.255.255.0
ip helper-address 10.10.10.200
speed 100
full-duplex
!
interface FastEthernet0/0.5
encapsulation dot1Q 5
ip address 7.7.7.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 8.8.8.1 255.255.255.0




thats it?


Top
 Profile  
 
 Post subject: Re: lesson on VLAN trunking
PostPosted: Sun Jun 30, 2013 7:05 pm 
Offline

Joined: Thu Mar 28, 2013 2:23 am
Posts: 6
AAAAAAAAAAAAAAAAAAAAAAAAAND I just answered my second question so yes I did have to add my new subnets to my ospf routes on my local gateway -- so the router doing the trunking. the only other place I needed to add a statement was to permit traffic out to the internet via an access list for that subnet on my primary boarder router.


Thanks for the help!


Top
 Profile  
 
 Post subject: Re: lesson on VLAN trunking
PostPosted: Sun Jun 30, 2013 7:16 pm 
Offline

Joined: Thu Mar 28, 2013 2:23 am
Posts: 6
and the final question is answered YES you do need IP helper statements in each subinterface if you want your clients on the vlans to get an address from a dhcp server over on the other segment!


I should come here more often....




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO