It is currently Sun Sep 23, 2018 12:52 am


All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Linux(vlan) + GNS3
PostPosted: Sat Sep 07, 2013 1:04 pm 
Offline

Joined: Sat Sep 07, 2013 12:47 pm
Posts: 3
Hi!
What i have:
Cisco catalyst 2950 real switch + PC with Kubuntu 13.04 and GNS 0.8.3.1 on it.


Task:
Interconnect real gear with GNS3 emulated network through trunk link

I have an issue with tagged frames passing through PC interface. When it passing from GNS3 to equipment tags stays in frame but when the answer coming back from equipment to PC(GNS3) PC interface removes tag from the frame. I took the dump with Wireshark.

I tried to configure vlans on the interface on my PC with 'vconfig', but issue still exists.
Please help me to solve this problem!




Attachments:
trouble.png
trouble.png [ 27.76 KiB | Viewed 3099 times ]
WSH2.png
WSH2.png [ 169.38 KiB | Viewed 3099 times ]
WSH1.png
WSH1.png [ 171.13 KiB | Viewed 3099 times ]
Top
 Profile  
 
 Post subject: Re: Linux(vlan) + GNS3
PostPosted: Sat Sep 07, 2013 8:17 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

Do you use Generic Ethernet NIO or Linux Ethernet NIO? The later method drops VLAN tagged packets.

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Linux(vlan) + GNS3
PostPosted: Mon Sep 09, 2013 12:04 pm 
Offline

Joined: Sat Sep 07, 2013 12:47 pm
Posts: 3
Hi, i use Linux Ethernet NIO
I try to use Generic eth1 and eth1.10 - the same sh... thing as with Linux Ethernet NIO eth1 and eth1.10


Top
 Profile  
 
 Post subject: Re: Linux(vlan) + GNS3
PostPosted: Mon Sep 09, 2013 6:12 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

This may help -> http://www.gns3.net/articles/ccie-routi ... ion/#Linux

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Linux(vlan) + GNS3
PostPosted: Sat Sep 14, 2013 7:53 am 
Offline

Joined: Sat Sep 07, 2013 12:47 pm
Posts: 3
Actually the problem probably can be in 8169 driver for Linux

http://marc.info/?l=linux-netdev&m=129492964820033&w=1

Quote:
This may help -> http://www.gns3.net/articles/ccie-routi ... ion/#Linux

I done everything like in your link but it didn't help. I consider its a linuxs network adater dirver issue.
Soon i hope i can get intel NIC to approve or disapprove my consideration.


Top
 Profile  
 
 Post subject: Re: Linux(vlan) + GNS3
PostPosted: Sun Sep 22, 2013 7:09 am 
Offline

Joined: Sat Nov 17, 2012 7:01 pm
Posts: 21
I believe you've been facing a similar issue that I was. My GNS3 router and switches kept giving ARP errors ("creating incomplete entry.....bla bla" in debug arp/ip icmp outputs) while pinging between them back and forth. If you're seeing a similar behavior in your routers/switch, then you're right; Intel PROSet/ANS (Advanced Networking Services) drivers may do the trick for you.

I'm using 3x Intel PRO/1000 GT Quad Port Server Adapters and they support ANS VLANs. If you want to consider them, then they're available real cheap (http://www.amazon.com/Intel-1000-Quad-P ... 00+gt+quad).

Their only problem is that they're old; they support ANS only till Windows Server 2003 and Linux Kernel 2.4.x.


Regards.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO