It is currently Fri Aug 14, 2020 7:32 am


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Unable to ping far IP on router
PostPosted: Tue Jan 21, 2014 3:55 pm 
Offline

Joined: Tue Jan 21, 2014 3:17 pm
Posts: 36
I have a simple setup as per the attached diagram.

This is most likely a beginner problem more than anything else, but from PC1 I can ping the near router and the serial interface of the router, but not the far serial interface IP or anything further. Likewise from PC2.

I suspect a routing propblem but am not sure where to look.

From Router1 I can ping Router2 (1.1.1.2)
From Router2 I can ping Router1 (1.1.1.1)


Router 1:
Quote:
10.10.11.1 0 FULL/ - 00:00:34 1.1.1.2 Serial0/0


Router 2
Quote:
10.10.10.1 0 FULL/ - 00:00:30 1.1.1.1 Serial0/0


vpcs config:

Quote:
NAME IP/MASK GATEWAY MAC DNS
VPCS1 10.10.10.2/24 10.10.10.1 00:50:79:66:68:00
VPCS2 10.10.11.2/24 10.10.11.1 00:50:79:66:68:01


Router 1 config:

Quote:
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$yoX1$1nxKU0M06muawS8Oz8Ggi.
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
no ip domain lookup
ip domain name example.com
!
multilink bundle-name authenticated
archive
log config
hidekeys
ip tcp synwait-time 5
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
control-plane
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end


Router 2 config:
Quote:
!
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$tFQQ$5j0/N8aai19QS0VvebevQ0
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
no ip domain lookup
ip domain name example.com
!
multilink bundle-name authenticated
archive
log config
hidekeys
ip tcp synwait-time 5
interface FastEthernet0/0
ip address 10.10.11.1 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
control-plane
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end




Attachments:
topology.png
topology.png [ 23.33 KiB | Viewed 2424 times ]
Top
 Profile  
 
 Post subject: Re: Unable to ping far IP on router
PostPosted: Tue Jan 21, 2014 4:29 pm 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
You are correct that it is a routing problem (I shall try and avoid giving you the entire answer here)

Using the configuration you posted, if we take a look at the routing table on Router1 we see the following:
Code:
Router1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Serial0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, FastEthernet0/0

The problem should become fairly obvious now... take a look at the networks that the router is aware of. Can it reach your destination?

Try the same on Router2 and see what you find

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: Unable to ping far IP on router
PostPosted: Tue Jan 21, 2014 7:40 pm 
Offline

Joined: Tue Jan 21, 2014 3:17 pm
Posts: 36
Thanks Dan - that did the trick.

Of course...the def gateway on the router!

Everything is pingable now.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO