It is currently Sat May 25, 2019 7:48 pm


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Layer 3 switch with vlan routing
PostPosted: Thu Jan 23, 2014 9:22 pm 
Offline

Joined: Thu Jan 23, 2014 8:14 pm
Posts: 1
Hey,
from school i got the work to make an setup with an Layer 3 Switch and 2 Vlan´s. I just should make to Ping from PC1 to PC3 also PC2 to PC 4.

Attachment:
File comment: This is the Setup of my work:
Setup.jpg
Setup.jpg [ 45.11 KiB | Viewed 12821 times ]


I can ping from every PC to Layer3 also to the gateway of it, my Internet router.

But i can´t Ping from PC1 to PC3, like you see in the picture. I hope i find help here.

Attachment:
File comment: PC1
pc1.jpg
pc1.jpg [ 204.87 KiB | Viewed 12820 times ]


To the Setup:

IOS-Image: c3640-jk9o3s-mz.124-16a.image
Modell: 3640

SW1: slot 0 : NM-16ESW

Layer3: slot 0: NM1FE-TX
slot 1: NM-16ESW

PC1-4: Windows XP VM(Oracle VM Virtual Box)

Configuration:


SW1:
Code:
SW1#vlan database
SW1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
SW1(vlan)#vlan 20
VLAN 20 added:
    Name: VLAN0020
SW1(vlan)#exit
SW1(config)#int f0/1
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 10
SW1(config-if)#exit
SW1(config)#int f0/2
SW1(config-if)#switchport mode access
SW1(config-if)#switchport access vlan 20
SW1(config-if)#exit
SW1(config)#int f0/0
SW1(config-if)#switchport mode trunk
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#end



Layer3:
Code:
Layer3#vlan database
Layer3(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Layer3(vlan)#vlan 20
VLAN 20 added:
    Name: VLAN0020
Layer3(vlan)#exit
Layer3(config)#ip routing
Layer3(config)#int f1/0
Layer3(config-if)#switchport mode trunk
Layer3(config-if)#switchport trunk encapsulation dot1q
Layer3(config-if)#exit
Layer3(config)#int f1/1
Layer3(config-if)#switchport mode access
Layer3(config-if)#switchport access vlan 10
Layer3(config-if)#exit
Layer3(config)#int f1/2
Layer3(config-if)#switchport mode access
Layer3(config-if)#switchport access vlan 20
Layer3(config-if)#exit
Layer3(config)#int vlan10
Layer3(config-if)#ip address 192.168.10.1 255.255.255.0
Layer3(config-if)#no shutdown
Layer3(config-if)#exit
Layer3(config)#int vlan 20
Layer3(config-if)#ip address 192.168.20.1 255.255.255.0
Layer3(config-if)#no shutdown
Layer3(config-if)#exit
Layer3(config)#int fa0/0
Layer3(config-if)#no shutdown
Layer3(config-if)#ip address 192.168.2.10 255.255.255.0
Layer3(config-if)#ip nat outside
Layer3(config-if)#exit
Layer3(config)#int vlan10
Layer3(config-if)#ip nat inside
Layer3(config-if)#exit
Layer3(config)#int vlan 20
Layer3(config-if)#ip nat inside
Layer3(config-if)#exit
Layer3(config)#ip nat inside source list 1 interface fa0/0 overload
Layer3(config)#access-list 1 permit 192.168.10.0 0.0.0.255
Layer3(config)#access-list 1 permit 192.168.20.0 0.0.0.255
Layer3(config)#exit
Layer3(config)#ip route 0.0.0.0 0.0.0.0 192.168.2.1
Layer3(config)#end



I hope someone here can help me.
Thanks and greetings from
Pefred




Top
 Profile  
 
 Post subject: Re: Layer 3 switch with vlan routing
PostPosted: Sat Jan 25, 2014 3:25 am 
Offline

Joined: Sat Jan 25, 2014 3:22 am
Posts: 1
try: on the trunk port of each switch, "switchport trunk allowed vlan 1,2"
then verify it by "sh int trunk"
hope it helps


Top
 Profile  
 
 Post subject: Re: Layer 3 switch with vlan routing
PostPosted: Sat Feb 01, 2014 10:25 pm 
Offline

Joined: Sat Feb 01, 2014 10:23 pm
Posts: 1
Also you could try a trace route and see where the packet is dropped




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO