It is currently Tue Dec 12, 2017 12:20 pm


All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Win8.1 - No Internet Access Behind Routers
PostPosted: Mon Mar 31, 2014 3:26 am 
Offline

Joined: Mon Mar 31, 2014 3:03 am
Posts: 3
Hey Everyone,

I'm a newbie to GNS3, so I apologize in advance if I'm missing something obvious. I can't seem to get devices (VBox VMs) behind my router in GNS3 to reach the internet. I'm running Windows 8.1 Pro x64, GNS 3 0.8.6, and Oracle VBox 4.1.32 r92798. Here’s my logical configuration:

Local Area Connection (on physical NIC with ICS to loopback) – 10.1.13.2 > loopback adapter (192.168.137.1) > GNS Cloud (with loopback adapter added) > R1 (g1/0 – 192.168.137.2 | g2/0 – 192.168.1.1) > XP VM (e1 – 192.168.1.2)

Initially, I couldn’t ping 192.168.137.1 (loopback adapter) from R1. Turned out to be a firewall rule. Had to change “unidentified networks” to a private network profile or change firewall rules. I opted for the first option. That fixed ping from R1. I am able to ping loopback and 8.8.8.8 from R1, however, I can’t ping loopback or internet from anything beyond R1. I captured packets between R1 and loopback and ICMP requests are going, but I never get a reply, like the loopback adapter is dropping the traffic or it’s hitting a firewall somewhere or there's some kind of routing issue.

Any recommendations on how I can troubleshoot/resolve this? Thanks in advance for your help/time.

Best Regards,
LearningToNetwork101




Top
 Profile  
 
 Post subject: Re: Win8.1 - No Internet Access Behind Routers
PostPosted: Mon Mar 31, 2014 7:27 pm 
Offline

Joined: Wed Mar 26, 2014 11:49 pm
Posts: 10
I'm having the exact problem. I'm assuming the problem is because you & I are using inside local ip addresses (not public IPs) so the ISP is dropping the packets, which is why you need NAT but then again my attempts at this are failing with NAT so whenever you find the answer I should be able to fix my problem.

If I get an answer on my question I'll let you know. My similar forumn question is below, using same windows 8.1 & same loopback address, First router can reach internet but nothing beyond that.

topic8892.html


Top
 Profile  
 
 Post subject: Re: Win8.1 - No Internet Access Behind Routers
PostPosted: Mon Mar 31, 2014 7:53 pm 
Offline

Joined: Mon Mar 31, 2014 3:03 am
Posts: 3
garrettstrahan wrote:
I'm having the exact problem. I'm assuming the problem is because you & I are using inside local ip addresses (not public IPs) so the ISP is dropping the packets, which is why you need NAT but then again my attempts at this are failing with NAT so whenever you find the answer I should be able to fix my problem.

If I get an answer on my question I'll let you know. My similar forumn question is below, using same windows 8.1 & same loopback address, First router can reach internet but nothing beyond that.

topic8892.html


Sounds good, thank you. I'll keep an eye out on your post as well. I've also got a message into Keith Barker from CBT Nuggets, but not sure yet if I'll get a reply from him. If I do and it works, I'll post it here.


Top
 Profile  
 
 Post subject: Re: Win8.1 - No Internet Access Behind Routers
PostPosted: Tue Apr 01, 2014 2:09 am 
Offline

Joined: Wed Mar 26, 2014 11:49 pm
Posts: 10
Finally got it to work, SERIOUS back pain from sitting down all day figuring it out (every website has ONLY 1 router for gns3 to work with internet behind router, never more than 1) + studying for my ICND1...but it was totally worth it. I was getting the syntax wrong on the "ip nat inside source list 1 interface FastEthernet0/1 overload" when the interface was supposed to be "0/0".

So use these commands I include in the next paragraph but your using gigabit so replace the obvious SEE MY TOPOLOGY FOR EXAMPLES! you can use any # you want on "source list 1" & "access-list 1" but make sure they are the same # (same access list). I'm so happy! Please learn from my back pain experience :)

Make sure your next router (R2) has "ip route 0.0.0.0 0.0.0.0 x" x=ip of interface on router that is doing the NAT!!!!

!
interface FastEthernet0/0
no shutdown
ip address 192.168.137.2 255.255.255.0
ip nat outside
!
interface FastEthernet0/1
no shutdown
ip address 192.168.138.1 255.255.255.0
ip nat inside
!
ip nat inside source list 1 interface FastEthernet0/0 overload
access-list 1 permit 192.168.138.0 0.0.0.255



-For my full configuration please see my forumn question I posted a day ago.
post27304.html#p27304


Attachments:
Solution.PNG
Solution.PNG [ 17.7 KiB | Viewed 2511 times ]
Top
 Profile  
 
 Post subject: Re: Win8.1 - No Internet Access Behind Routers
PostPosted: Tue Apr 01, 2014 2:33 am 
Offline

Joined: Mon Mar 31, 2014 3:03 am
Posts: 3
Awesome! Great work, thank you for posting the solution. I'll give it a shot and let you know. I think your Cisco knowledge is a bit further along than mine, lol. I'm working on Net+ first and then heading to CCENT, so I'm only catching bits and pieces of the syntax of the commands as it comes up in the test prep. Good thing the "?" exists, haha.

Best Regards,
LearningToNetwork101


Top
 Profile  
 
 Post subject: Re: Win8.1 - No Internet Access Behind Routers
PostPosted: Tue Apr 01, 2014 2:56 am 
Offline

Joined: Wed Mar 26, 2014 11:49 pm
Posts: 10
How I learned was simple, the CBT nuggets old CCNA series is on youtube, they have a new one too (I HIGHLY RECOMMEND YOU SEE IT), but its fun to watch but the information is not enough in his videos to pass CCNA(ICND1+2) by itself. So what I recommend is getting Todd Lammel's book http://www.amazon.com/CCNA-Routing-Swit ... odd+lammle

Its a great book but there are times where you can tell Todd is really trying to explain things but do a poor job on a few chapters (ie NAT), so when that happens watch CBT Nuggets to explain what Todd cannot! The book is pretty in depth & highly recommended, Wendell Odom is also but he wants you to buy 2 books instead of 1 to be CCNA certified; Todd is cheaper.

Network+ is good but CCNA covers more information for real work environment on the job and is more respected for your interview to make you look good. So unless you have a plan to EVERY 3 YEARS take Network+ & CCNA, I would just go for CCNA, because every Cisco certificate renews the older ones so if you take ICND1 & pass its 3 years, then pass ICND2 its another 3 years, then if you take CCNP its another 3 years. Network+ does not have this option...... Just my opinion...how do I know? I worked with network geniuses for 3 years (this was their advice) @ a Web Hosting I quit a month ago (technically Amazon hired me so I quit ServInt but they took back their offer so they F'ed me so I'm getting my CCNA instead) so I could take 3 months off to get CCNA certified (its around $70k-$100k a year salary, network+ is only $44k a year average).

There is nothing to stop you from starting @ CCNA instead of Network+. Just my 2 cents take it or leave it. If you read that book + cbt nuggets videos you wont need network+.

GOOD LUCK BUDDY! :)




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO