It is currently Mon Nov 20, 2017 6:55 pm


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: VLAN WITH HSRP & STP
PostPosted: Sat Mar 23, 2013 12:53 am 
Offline

Joined: Sat Mar 23, 2013 12:17 am
Posts: 2
Image

vlan 10,20,30 configured with 100% redundancy for clients at layer 2 & layer 3

R1 IS VTP DOMAIN SERVER, HOLDING VLANS FOR 10,20,30. R2,R3,R4 WORKING AS CLIENT SWITCH
HOSTS ARE ABLE TO REACH INTERNET VIA HSRP IP AS THEIR GATEWAY.

R1 IS PRIMARY GATEWAY FOR ALL VLANS BUT IF R1 LOSE CONNECTIVITY TO 4.2.2.2 SERVER DUE TO ISP OR INTERFACE FAILURE THEN R2 WILL TAKEOVER & PROVIDE VLAN USERS INTERNET

HERE IS THE CONFIGURTION -

R1 ########
Code:
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
ip sla monitor 1
type echo protocol ipIcmpEcho 4.2.2.2 source-interface FastEthernet0/0
frequency 5
ip sla monitor schedule 1 life forever start-time now
!
spanning-tree vlan 10 priority 8192
spanning-tree vlan 20 priority 16384
spanning-tree vlan 99 priority 8192
!
!
ip tcp synwait-time 5
!
track 10 rtr 1
!
!
!
!
!
interface Port-channel1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/0
ip address 100.100.100.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/2
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/3
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode on
!
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.1 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 priority 200
standby 10 preempt
standby 10 track 10 decrement 101
!
interface Vlan20
ip address 192.168.20.1 255.255.255.0
standby 20 ip 192.168.20.254
standby 20 priority 200
standby 20 preempt
standby 20 track 10 decrement 101
!
interface Vlan30
ip address 192.168.30.1 255.255.255.0
standby 30 ip 192.168.30.254
standby 30 priority 200
standby 30 preempt
standby 30 track 10 decrement 101
!
interface Vlan99
ip address 192.168.99.1 255.255.255.0
!
router eigrp 100
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 192.168.99.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 100.100.100.2

R2 #########################
Code:
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
spanning-tree vlan 10 priority 16384
spanning-tree vlan 20 priority 8192
spanning-tree vlan 99 priority 16384
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface Port-channel1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet0/0
ip address 200.200.200.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/2
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/3
switchport trunk native vlan 99
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.2 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 preempt
!
interface Vlan20
ip address 192.168.20.2 255.255.255.0
standby 20 ip 192.168.20.254
standby 20 preempt
!
interface Vlan30
ip address 192.168.30.2 255.255.255.0
standby 30 ip 192.168.30.254
standby 30 preempt
!
interface Vlan99
ip address 192.168.99.2 255.255.255.0
!
router eigrp 100
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 192.168.99.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 200.200.200.1
!

R3 ###############
Code:
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
spanning-tree vlan 30 priority 8192
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet1/11
switchport access vlan 20
spanning-tree portfast
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.3 255.255.255.0
!
interface Vlan20
ip address 192.168.20.3 255.255.255.0
!
interface Vlan30
ip address 192.168.30.3 255.255.255.0
!
interface Vlan99
ip address 192.168.99.3 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
mac-address-table static c202.0220.0000 interface FastEthernet1/0 vlan 1
!
!

R4 ####################
Code:
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
spanning-tree vlan 30 priority 16384
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/1
switchport trunk native vlan 99
switchport mode trunk
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
switchport access vlan 30
spanning-tree portfast
!
interface FastEthernet1/11
switchport access vlan 10
spanning-tree portfast
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.10.4 255.255.255.0
!
interface Vlan20
ip address 192.168.20.4 255.255.255.0
!
interface Vlan30
ip address 192.168.30.4 255.255.255.0
!
interface Vlan99
ip address 192.168.99.4 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
mac-address-table static c203.0220.0000 interface FastEthernet1/1 vlan 1
!
!

ISP1 ########
Code:
hostname ISP1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
ip address 100.100.100.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 1.1.1.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 100.100.100.0 mask 255.255.255.252
redistribute static
neighbor 1.1.1.2 remote-as 3
no auto-summary
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.0.0 100.100.100.1
!

ISP2 ##########
Code:
hostname ISP2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 200.200.200.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 200.200.200.0 mask 255.255.255.252
redistribute static
neighbor 2.2.2.1 remote-as 3
no auto-summary
!
ip forward-protocol nd
ip route 192.168.0.0 255.255.0.0 200.200.200.2




Attachments:
File comment: router config
configs.zip [4.89 KiB]
Downloaded 734 times


Last edited by rednectar on Fri Apr 25, 2014 3:57 am, edited 1 time in total.
Tidy formatting
Top
 Profile  
 
 Post subject: Re: VLAN WITH HSRP & STP
PostPosted: Fri Apr 25, 2014 4:21 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
@sudebdas_85 - I know this is a little old, but I'm re-visiting the GNS3 HSRP problem.

I have two questions:

1. Which IOS did you use?
2. Would you mind submitting your topolgy.net as well? I'm sure it would be useful for others.

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: VLAN WITH HSRP & STP
PostPosted: Tue May 20, 2014 10:02 pm 
Offline

Joined: Mon Apr 07, 2014 2:19 pm
Posts: 1
Same question as above. What IOU/IOS are you using? Appreciate feedback.


Top
 Profile  
 
 Post subject: Re: VLAN WITH HSRP & STP
PostPosted: Tue Jul 08, 2014 9:32 pm 
Offline

Joined: Sat Nov 09, 2013 1:52 pm
Posts: 23
Very interested to know regarding dissimilar subnet masks being used by the phi interfaces and the standby ip as well...




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO