It is currently Mon Mar 01, 2021 10:06 am


All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Wed Jun 25, 2014 8:22 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
Short:
When I run a particular Cisco IOS v15 image on Dynamips it works as long as no idle-pc value attached.
After I attach an IDLE-PC value, IOS would CRASH !!
Without IDLE-PC it boots and works fine. (at the cost of 100% CPU usage per core)
Have you experienced anything similar ? (This never happened to me with older IOS v12.3 series)

date: 25.06.2014.
idlepc = 0x60788d00 (also tried with 0x6077c110 and same result !)
IOS = c7200-adventerprisek9_sna-mz.150-1.M.bin
GNS3 = 0.8.6 on Windows 7 x64
Dynamips v0.2.10-x86 (comes with GNS3 all-in-one installer)

=============================================
Booting IOS v15 on Dynamips with IDLE-PC value attached:
=============================================

Cisco IOS Software, 7200 Software (C7200-ADVENTERPRISEK9_SNA-M), Version 15.0(1)M, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Wed 30-Sep-09 07:48 by prod_rel_team
Image text-base: 0x6000F624, data-base: 0x6432CC80



: TLB (store) exception, CPU signal 10, PC = 0x633AE134



--------------------------------------------------------------------
Possible software fault. Upon reccurence, please collect
crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------



: TLB (load or instruction fetch) exception, CPU signal 10, PC = 0x633E0788



--------------------------------------------------------------------
Possible software fault. Upon reccurence, please collect
crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback=
$0 : 00000000, AT : 66120000, v0 : 00000000, v1 : 00000000
a0 : 7CFFFFA8, a1 : 00000001, a2 : 653650AC, a3 : 00000000
t0 : 00000020, t1 : 00000038, t2 : 00000000, t3 : FFFF00FF
t4 : 60768438, t5 : 00000000, t6 : 00000001, t7 : 00000000
s0 : 00000000, s1 : 00000038, s2 : 633AE134, s3 : 65ED0000
s4 : 00000001, s5 : 65ED0000, s6 : 647E0000, s7 : 00000012
t8 : 00000000, t9 : 00000000, k0 : 665BAFF8, k1 : 00000000
gp : 66127640, sp : 659C53B0, s8 : 00000034, ra : 633E0774
EPC : 633E0788, ErrorEPC : 00000000, SREG : 34008003
MDLO : 00000000, MDHI : 00000006, BadVaddr : 00000040
CacheErr : 00000000, DErrAddr0 : 00000000, DErrAddr1 : 00000000
TEXT_START : 0x6000F624
DATA_START : 0x6432CC80
Cause 00000008 (Code 0x2): TLB (load or instruction fetch) exception


: TLB (load or instruction fetch) exception, CPU signal 10, PC = 0x633E0788



--------------------------------------------------------------------
Possible software fault. Upon reccurence, please collect
crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback=
$0 : 00000000, AT : 66120000, v0 : 00000000, v1 : 00000000
a0 : 7CFFFFA8, a1 : 00000001, a2 : 653650AC, a3 : 00000000
t0 : 00000020, t1 : 00000038, t2 : 00000000, t3 : FFFF00FF
t4 : 60768438, t5 : 00000000, t6 : 00000001, t7 : 00000000
s0 : 00000000, s1 : 00000038, s2 : 633AE134, s3 : 65ED0000
s4 : 00000001, s5 : 65ED0000, s6 : 647E0000, s7 : 00000012
t8 : 00000000, t9 : 00000000, k0 : 665BAFF8, k1 : 00000000
gp : 66127640, sp : 659C53B0, s8 : 00000034, ra : 633E0774
EPC : 633E0788, ErrorEPC : 00000000, SREG : 34008003
MDLO : 00000000, MDHI : 00000006, BadVaddr : 00000040
CacheErr : 00000000, DErrAddr0 : 00000000, DErrAddr1 : 00000000
TEXT_START : 0x6000F624
DATA_START : 0x6432CC80
Cause 00000008 (Code 0x2): TLB (load or instruction fetch) exception

Nested write_crashinfo call (2 times)


: TLB (load or instruction fetch) exception, CPU signal 10, PC = 0x633E0788



--------------------------------------------------------------------
Possible software fault. Upon reccurence, please collect
crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback=
$0 : 00000000, AT : 66120000, v0 : 00000000, v1 : 00000000
a0 : 7CFFFFA8, a1 : 00000001, a2 : 653650AC, a3 : 00000000
t0 : 00000020, t1 : 00000038, t2 : 00000000, t3 : FFFF00FF
t4 : 60768438, t5 : 00000000, t6 : 00000001, t7 : 00000000
s0 : 00000000, s1 : 00000038, s2 : 633AE134, s3 : 65ED0000
s4 : 00000001, s5 : 65ED0000, s6 : 647E0000, s7 : 00000012
t8 : 00000000, t9 : 00000000, k0 : 665BAFF8, k1 : 00000000
gp : 66127640, sp : 659C53B0, s8 : 00000034, ra : 633E0774
EPC : 633E0788, ErrorEPC : 00000000, SREG : 34008003
MDLO : 00000000, MDHI : 00000006, BadVaddr : 00000040
CacheErr : 00000000, DErrAddr0 : 00000000, DErrAddr1 : 00000000
TEXT_START : 0x6000F624
DATA_START : 0x6432CC80
Cause 00000008 (Code 0x2): TLB (load or instruction fetch) exception

-Traceback=


: TLB (load or instruction fetch) exception, CPU signal 10, PC = 0x633E0BE0



--------------------------------------------------------------------
Possible software fault. Upon reccurence, please collect
crashinfo, "show tech" and contact Cisco Technical Support.
--------------------------------------------------------------------


-Traceback=
$0 : 00000000, AT : 66120000, v0 : 00000000, v1 : 00000001
a0 : 7CFFFFA8, a1 : 00000000, a2 : 00000000, a3 : 00000000
t0 : 00000000, t1 : 00000000, t2 : 00000024, t3 : 654D0000
t4 : 01000000, t5 : 14683558, t6 : 6797C9F8, t7 : 01000058
s0 : 7BFFFF50, s1 : 7BFFFF50, s2 : 66910000, s3 : 65ED0000
s4 : 654D26DC, s5 : 66A77EA8, s6 : 00000000, s7 : 633E701C
t8 : 01000000, t9 : 01000000, k0 : 665BAFF8, k1 : 00000038
gp : 66127640, sp : 66A77DA8, s8 : 66A15844, ra : 633E0BCC
EPC : 633E0BE0, ErrorEPC : 00000000, SREG : 3400FF03
MDLO : 00001040, MDHI : 00000000, BadVaddr : 0000002C
CacheErr : 00000000, DErrAddr0 : 00000000, DErrAddr1 : 00000000
TEXT_START : 0x6000F624
DATA_START : 0x6432CC80
Cause 00000008 (Code 0x2): TLB (load or instruction fetch) exception


=== Flushing messages () ===

-Alexey "Technologov"
[email protected]




Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Wed Jun 25, 2014 9:09 pm 
Offline

Joined: Sat Aug 17, 2013 7:59 pm
Posts: 123
Location: Upper Silesia, Poland
I'm not able to reproduce results because I do not have such IOS. But I made simple test with images:
- c7200-adventerprisek9-mz.151-4.M4
- c7200-adventerprisek9-mz.152-4.S4
I made test using two environments:
- GNS3 0.8.6 dynamips 0.2.10-x86/Windows stable, WinXP
- GNS3 0.8.6 dynamips 0.2.11-x86/Linux stable, Debian testing, 32bit

After adding 7200 IOS I calculated idlepc value using autocalculation, and save IOS with that idlepc value. Everything went fine, CPU spiked to 100% only during IOS startup, and after initialization CPU usage was 5-8% per core.

Are you sure that your IOS has not been damaged in any way?

_________________
If you can see any inaccuracies or other language-related mistakes in my post(s), please forgive me - English is not my native language


Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Thu Jun 26, 2014 4:13 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
Since my image boots without idlepc, yeah, I'm sure.


Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Thu Jun 26, 2014 8:26 am 
Offline

Joined: Sat Aug 17, 2013 7:59 pm
Posts: 123
Location: Upper Silesia, Poland
Oops... I think I have been blind when reading your post - all tracebacks I've ever seen in gns3 was caused by bad settings (especially low RAM) or corrupted image.

_________________
If you can see any inaccuracies or other language-related mistakes in my post(s), please forgive me - English is not my native language


Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Thu Jun 26, 2014 8:46 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Quote:
Since my image boots without idlepc, yeah, I'm sure.


I recommended to post this to https://github.com/GNS3/dynamips/issues because only Flavio may do something about it.

It could also be the amount of RAM you allocated is not enough.

Cheers,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Thu Jun 26, 2014 8:54 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
I allocated 512 MB RAM for IOS. (16 GB RAM on host)

Opened issue in github.


Top
 Profile  
 
 Post subject: Re: [CRITICAL] Dynamips Router crash with IDLE PC value !!!
PostPosted: Thu Jul 10, 2014 2:54 pm 
Offline

Joined: Wed May 22, 2013 7:48 am
Posts: 93
Location: Portugal
Related bug report: https://github.com/GNS3/dynamips/issues/49

(Original bug report: https://github.com/GNS3/dynamips/issues/48)



_________________
Dynamips maintainer and sporadic developer
https://github.com/GNS3/dynamips


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO