It is currently Fri Aug 23, 2019 3:52 pm


All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Voice Port config
PostPosted: Sat Jul 26, 2014 11:11 am 
Offline

Joined: Sat Jul 26, 2014 11:03 am
Posts: 4
Hello, everyone.
I have an interesting problem: I can't config any voice ports although my router says they exist and working. These are the prompts I get:
R1#show voice port sum
IN OUT
PORT CH SIG-TYPE ADMIN OPER STATUS STATUS EC
============== == ============ ===== ==== ======== ======== ==
50/0/1 1 efxs up up on-hook idle y
50/0/2 1 efxs up dorm on-hook idle y

PWR FAILOVER PORT PSTN FAILOVER PORT
================= ==================

R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#voice-port 50/0/1
^
% Invalid input detected at '^' marker.

R1(config)#voice-port 50/0/1
^
% Invalid input detected at '^' marker.

R1(config)#voice-port ?
<50-50> Voice interface slot #

R1(config)#voice-port 50?
/

R1(config)#voice-port 50/?
<0-0> Voice interface SubUnit #

R1(config)#voice-port 50/0?
/

R1(config)#voice-port 50/0/?
<1-2> Voice interface port # within vic

R1(config)#voice-port 50/0/1
^
% Invalid input detected at '^' marker.

R1(config)#voice-port 50/0/2
^
% Invalid input detected at '^' marker.

What could be the reason? I'm using a 3725 router with IOS c3725-adventerprisek9-mz.124-15.T14.bin. The invalid input seems to be at the number 5 for some reason.
Thanks for any answer, advice.




Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Sun Jul 27, 2014 3:30 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
I'm surprised you got any output from the show voice port summary command. Did you add any modules to your device to get the voice ports added?. I'd love to see the output of a show run command from the GNS3 console (and from the router too I guess)

But the long and the short of it is that Dynamips (the IOS emulator for GNS3) does not emulate voice ports. End of story. If you have an IOS that supports voice, I would expect the same as I would on a normal router with no voice ports.

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Last edited by rednectar on Tue Jul 29, 2014 1:19 pm, edited 1 time in total.
form=>from


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Tue Jul 29, 2014 12:20 pm 
Offline

Joined: Sat Jul 26, 2014 11:03 am
Posts: 4
Hi, thanks for your quick answer, I didn't see you've already written. Here is my running config:
R1#show run
Building configuration...

Current configuration : 1665 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool Data
network 192.168.10.0 255.255.255.0
default-router 192.168.10.1
!
ip dhcp pool Voice
network 192.168.20.0 255.255.255.0
default-router 192.168.20.1
option 150 ip 192.168.20.1
!
!
no ip domain lookup
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
telephony-service
max-ephones 2
max-dn 2
ip source-address 192.168.20.1 port 2000
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 101
!
!
ephone-dn 2
number 102
!
!
ephone 1
device-security-mode none
mac-address 001D.72D4.F998
button 1:2
!
!
!
ephone 2
device-security-mode none
mac-address 0800.27B0.6E48
button 1:1
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end

R1#

I don't have a real router, everything is simulated in GNS3. I didn't add any modules or slots, I have the default slot in slot0, GT96100-FE


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Tue Jul 29, 2014 1:17 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
Great. Got the router config. Can you share your GNS3 config too?
Quote:
I'd love to see the output of a 'show run' command from the GNS3 console

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Tue Jul 29, 2014 1:23 pm 
Offline

Joined: Sat Jul 26, 2014 11:03 am
Posts: 4
Hm? What? I have the router simulated in GNS3, this is not a real router. I generated this in GNS3 console. I don't really understand what you would like to see... I have another router too in GNS3, a VirtualBox Guest and a Host connected through Loopback Adapter.

This is my topology: http://kepfeltoltes.hu/140729/topology_www.kepfeltoltes.hu_.png

I have R1.cfg and R2.cfg files in GNS3/Projets/Telephony/configs folder but those are the same as my running configs.


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Tue Jul 29, 2014 4:34 pm 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
The "GNS3 console" is the section under you topology, in the middle. It will probably currently just be telling you the version of GNS3.

Type show run in this box

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Tue Jul 29, 2014 11:43 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
Here's a pic (from the GNS3 Network Simulation Guide) that explains where the GNS3 Management Console is:

Attachment:
0809_02_03-WorkSpace Window description.png
0809_02_03-WorkSpace Window description.png [ 206.25 KiB | Viewed 4817 times ]


If you can't see the GNS3 Management Console Dock, choose View | Docks and make sure the Console dock is selected.

When you issue the show run command in the console, you should see something like this:
Code:
=> show run
autostart = False
[127.0.0.1:7200]
    workingdir = /home/user/GNS3/Projects/ICND1 Exercises/Test/working
    udp = 10001
    [[3725]]
        image = /home/user/GNS3/Images/c3725-adventerprisek9-mz.124-15.T10.image
        ram = 128
        idlepc = 0x60c06d20
        sparsemem = True
        ghostios = True
    [[ROUTER SW1]]
        model = 3725
        console = 2103
        aux = 2503
        idlepc = 0x614ac27c
        cnfg = /home/user/GNS3/Projects/ICND1 Exercises/Test/configs/SW1.cfg
        slot1 = NM-16ESW
        f1/0 = R1 f0/1
        f1/1 = NIO_udp:30000:127.0.0.1:20000
        f1/2 = NIO_udp:30001:127.0.0.1:20001
        f1/3 = NIO_udp:30002:127.0.0.1:20002
        f1/4 = NIO_udp:30003:127.0.0.1:20003
        f1/5 = NIO_udp:30004:127.0.0.1:20004
        f1/6 = NIO_udp:30005:127.0.0.1:20005
        f1/7 = NIO_udp:30006:127.0.0.1:20006
    [[ROUTER ServiceProvider]]
        model = 3725
        console = 2104
        aux = 2504
        idlepc = 0x614ac27c
        cnfg = /home/user/GNS3/Projects/ICND1 Exercises/Test/configs/ServiceProvider.cfg
        wic0/0 = WIC-2T
        s0/0 = R2 s0/0
        f0/0 = NIO_udp:30008:127.0.0.1:20008
    [[ROUTER R1]]
        model = 3725
        console = 2101
        aux = 2501
        idlepc = 0x614ac27c
        cnfg = /home/user/GNS3/Projects/ICND1 Exercises/Test/configs/R1.cfg
        f0/0 = R2 f0/0
        f0/1 = SW1 f1/0
    [[ROUTER R2]]
        model = 3725
        console = 2102
        aux = 2502
        ram = 256
        idlepc = 0x614ac27c
        cnfg = /home/user/GNS3/Projects/ICND1 Exercises/Test/configs/R2.cfg
        wic0/0 = WIC-2T
        s0/0 = ServiceProvider s0/0
        f0/0 = R1 f0/0
=>


This will tell me which router model and IOS image you are using, as well as connected devices.

Disclaimer: I am the author of the GNS3 Network Simulation Guide

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: Voice Port config
PostPosted: Wed Jul 30, 2014 8:49 am 
Offline

Joined: Sat Jul 26, 2014 11:03 am
Posts: 4
Oh, ok, I see now what you mean.
=> show run
autostart = False
[127.0.0.1:7200]
workingdir = c:\users\henrik\appdata\local\temp\GNS3__mnex4\working
udp = 10001
[[3725]]
image = C:\Program Files\GNS3\c3725-adventerprisek9-mz.124-15.T14.bin
ram = 128
idlepc = 0x60c09c58
sparsemem = True
ghostios = True
[[ROUTER R1]]
model = 3725
ghostios = False
console = 2101
aux = 2501
ram = 256
cnfg = C:\Users\Henrik\GNS3\Projects\Telephony\configs\R1.cfg
f0/0 = R2 f1/0
[127.0.0.1:7201]
workingdir = c:\users\henrik\appdata\local\temp\GNS3__mnex4\working
udp = 10101
[[3725]]
image = C:\Program Files\GNS3\c3725-adventerprisek9-mz.124-15.T14.bin
idlepc = 0x60c09c58
sparsemem = True
ram = 128
ghostios = True
[[ROUTER R2]]
model = 3725
ghostios = False
console = 2102
aux = 2502
cnfg = C:\Users\Henrik\GNS3\Projects\Telephony\configs\R2.cfg
slot1 = NM-16ESW
f1/0 = R1 f0/0
f1/1 = CIPC e0
f1/2 = nio_gen_eth:\device\npf_{d5e81f4b-4cc5-400e-a8a6-91db704cd316}
[vbox 127.0.0.1:11525]
workingdir = c:\users\henrik\appdata\local\temp\GNS3__mnex4\working
udp = 20900
[[VBoxDevice]]
image = CIPC
nics = 2
first_nic_managed = False
[[VBOX CIPC]]
e0 = R2 f1/1
=> 




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO