It is currently Wed May 24, 2017 5:43 pm


All times are UTC




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: switching issue
PostPosted: Sat Sep 06, 2014 8:46 am 
Offline

Joined: Sat Sep 06, 2014 8:39 am
Posts: 2
Hi

I have a problem with my switch topology and i'm not sure if i'm missing something here, or it's just a bug.
i have a four-switch topology and i have no communication between two vpcs stations connected to different switches when the trunking encapsulation between switches is n-isl, unless they are in vlan 1. As soon as i move both of them in another vlan, they stop communicating. If i switch all trunks to dot1q, the problem goes away. I'm using the latest GNS3 version (beta2). Am i missing something ordinary here?

Thanks




Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Mon Sep 08, 2014 11:22 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
I grabbed a pen a paper and tried to draw your scenario, but didn't have enough information. What kind of switches? Generic Switches? IOS Switches? IF IOS, what version... to many unknowns

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Mon Sep 08, 2014 3:58 pm 
Offline

Joined: Sat Sep 06, 2014 8:39 am
Posts: 2
i86bi-linux-l2-adventerprise-15.1b
Every switch with two connections to each other switch (full mesh).


Attachments:
topology.png
topology.png [ 31.47 KiB | Viewed 3974 times ]
Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Wed Sep 10, 2014 6:45 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
OK. I now have a picture - apart from the ports the VPCs are. But still not enough information.

What is the output (on each switch) of:
show spanning-tree blocked ports
show interface trunk
show interface status

Also it worries me that you have multiple links between switches in case you are tempted to do port channel (or ether channel) which I believe doesn't work with IOU (or IOS on the NM-ESW16 for that matter)

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Tue Sep 16, 2014 1:19 pm 
Offline

Joined: Tue Sep 16, 2014 1:07 pm
Posts: 4
Yes, also i. I have a problem with same switch topology. My image is i86bi-linux-l2-ipbasek9-15.1a.bin. I've noticed that when IOU1 is down, is all OK but when it is UP a lot PING failed ... I have Etherchannel L2 ... Is it BUG????

Thanks
Bye guys


Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Tue Sep 16, 2014 4:30 pm 
Offline

Joined: Fri May 13, 2011 10:35 pm
Posts: 83
Location: Seattle, WA (USA)
Lack of Cisco Inter-Switch Link (ISL) support is a known limitation with L2 IOL (http://www.routereflector.com/cisco/cisco-iou-web-interface/features-not-supported). Currently, you have a choice of 802.1Q VLAN trunks or 802.1Q VLAN trunks. :) (post37130.html#p37130).

_________________
http://binarynature.blogspot.com/search/label/GNS3


Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Tue Sep 16, 2014 4:52 pm 
Offline

Joined: Tue Sep 16, 2014 1:07 pm
Posts: 4
OK but I've same problem with 802.1Q VLAN trunks


Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Wed Sep 17, 2014 2:52 am 
Offline

Joined: Fri May 13, 2011 10:35 pm
Posts: 83
Location: Seattle, WA (USA)
Quote:
OK but I've same problem with 802.1Q VLAN trunks

Interesting. I just created a lab to test this more thoroughly. Everything checks out fine with my configuration. I've attached a screenshot and a notepad file, with the lab configuration, for you to reference. FYI, I'm using Ubuntu Server for my IOU VM instead of the standard one provided by the GNS3 community. Shouldn't make a difference, though.


Attachments:
topic11900-config.txt [4.38 KiB]
Downloaded 134 times
topic11900-gns3-screen.png
topic11900-gns3-screen.png [ 346.88 KiB | Viewed 3871 times ]

_________________
http://binarynature.blogspot.com/search/label/GNS3
Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Fri Sep 19, 2014 9:27 am 
Offline

Joined: Tue Sep 16, 2014 1:07 pm
Posts: 4
... These are my topology and configuration files ... i don't know ...

Bye guys


Attachments:
configMyTopology.txt [10.34 KiB]
Downloaded 126 times
PC4.jpg
PC4.jpg [ 105.84 KiB | Viewed 3812 times ]
PC1.jpg
PC1.jpg [ 103.67 KiB | Viewed 3812 times ]
MyTopology.jpg
MyTopology.jpg [ 68.45 KiB | Viewed 3812 times ]
Top
 Profile  
 
 Post subject: Re: switching issue
PostPosted: Sat Sep 20, 2014 10:27 am 
Offline

Joined: Tue Sep 16, 2014 1:07 pm
Posts: 4
I noticed that replacing the VPCs with VMs, the problem of connectivity between different PC resolves and everything is OK. But I have yet to understand why.

Bye




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO