It is currently Sun Nov 18, 2018 4:39 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Odd problem found during Q in Q setup
PostPosted: Tue Oct 07, 2014 4:08 pm 
Offline

Joined: Tue Oct 07, 2014 3:39 pm
Posts: 2
Hello,

I ran into problem when I configured Q in Q by following the instructions from this site, http://www.gns3.net/articles/ccie-routi ... ch-option/ and see the odd problem that come from the gns3 router ping to real switch.

Topology:
Code:
version = 0.8.7
[127.0.0.1:7208]
    workingdir = /tmp
    udp = 10801
    [[3725]]
        image = /Volumes/media/Kickstart/cisco/c3725/C3725-AD.BIN
        idlepc = 0x60753be0
        sparsemem = True
    [[ROUTER R2]]
        model = 3725
        console = 2102
        aux = 2502
        cnfg = configs/R2.cfg
        f0/0 = SW1 2
        x = -293.0
        y = -22.0
        z = 1.0
[127.0.0.1:7200]
    workingdir = /tmp
    udp = 10001
    [[ETHSW SW1]]
        2 = access 102 R2 f0/0
        24 = dot1q 1 nio_gen_eth:en1
        x = -110.5
        y = -15.0
        z = 1.0
[GNS3-DATA]
    configs = configs
    [[NOTE 1]]
        text = "f0/0"
        x = 11.6096668809
        y = 56.8837879492
        interface = R2 f0/0
    [[NOTE 2]]
        text = "2"
        x = -16.1096668809
        y = 27.1162120508
        interface = SW1 2
    [[NOTE 3]]
        text = "nio_gen_eth:en1"
        x = -19.4998724626
        y = 56.3989902211
        interface = C1 nio_gen_eth:en1
    [[Cloud C1]]
        symbol = multilayer_switch
        x = 97.5
        y = -22.0
        z = 1.0
        connections = SW1:24:nio_gen_eth:en1


Cloud connect to breakout switch at port 48.
# breakout switch

Code:
system mtu routing 1998
vtp mode transparent
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
vlan dot1q tag native
!
vlan 102
!
interface FastEthernet0/3
description Downlink to SW01
switchport access vlan 102
switchport mode dot1q-tunnel
speed 100
duplex full
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast
!
interface FastEthernet0/48
description Uplink to MacPRO
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1-102
switchport mode trunk
speed 100
duplex full
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast trunk
!


breakout switch connect to access switch with crossover cat6 cable at port 3.

Code:
interface FastEthernet0/3
switchport trunk encapsulation dot1q
switchport mode trunk
speed 100
duplex full
spanning-tree portfast
!


Here is router config.
Code:
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.2.10.1 255.255.255.0
no snmp trap link-status
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.2.20.1 255.255.255.0
no snmp trap link-status
!


I configure SPAN to observe the traffic from breakout.

When I switch on gns3 and real switch, both SW1 and R2 can be able to see CDP traffic fine.

Code:
R2#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
SW1              Fas 0/0            131         S I       WS-C3560-4Fas 0/3
R2               Fas 0/0            179        R S I      3725      Fas 0/0

Code:
R2#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.10.1               -   c200.025d.0000  ARPA   FastEthernet0/0.10
Internet  10.2.20.1               -   c200.025d.0000  ARPA   FastEthernet0/0.20
Internet  10.2.20.254            30   0015.63c7.1ac3  ARPA   FastEthernet0/0.20
Internet  10.2.10.254            31   0015.63c7.1ac2  ARPA   FastEthernet0/0.10



Code:
SW1#sh cdp ne
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
R2               Fas 0/3           152             R S I  3725      Fas 0/0
SW1#sh arp
Protocol  Address          Age (min)  Hardware Addr   Type   Interface
Internet  10.2.10.254             -   0015.63c7.1ac2  ARPA   Vlan10
Internet  10.2.20.1              32   c200.025d.0000  ARPA   Vlan20
Internet  10.2.20.254             -   0015.63c7.1ac3  ARPA   Vlan20


When I start pinging from R2 to SW1, problem starts.
ping to R1

Code:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.10.1, timeout is 2 seconds:
...!
01:31:22: ICMP: echo reply rcvd, src 10.2.10.1, dst 10.2.10.254, topology BASE, dscp 0 topoid 0.
Success rate is 20 percent (1/5), round-trip min/avg/max = 17/17/17 ms


try again, I got the same result. I can *always* see 1-2 ping reply from R1 router. either result is 20-40% succcessful...

Code:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.10.1, timeout is 2 seconds:
!
01:38:58: ICMP: echo reply rcvd, src 10.2.10.1, dst 10.2.10.254, topology BASE, dscp 0 topoid 0...!
Success rate is 40 percent (2/5), round-trip min/avg/max = 17/21/26 ms
SW1#
01:39:04: ICMP: echo reply rcvd, src 10.2.10.1, dst 10.2.10.254, topology BASE, dscp 0 topoid 0


ping to SW1 from R2 and observe with debug icmp flag on
switch replied with this:
Code:
01:32:58: ICMP: echo reply sent, src 10.2.10.254, dst 10.2.10.1, topology BASE, dscp 0 topoid 0
01:33:00: ICMP: echo reply sent, src 10.2.10.254, dst 10.2.10.1, topology BASE, dscp 0 topoid 0
01:33:02: ICMP: echo reply sent, src 10.2.10.254, dst 10.2.10.1, topology BASE, dscp 0 topoid 0


from tcpdump:
9:00:35.566919 IP (tos 0x0, ttl 255, id 40, offset 0, flags [none], proto ICMP (1), length 100)
10.2.10.1 > 10.2.10.254: ICMP echo request, id 8, seq 0, length 80
09:00:35.569652 IP (tos 0x0, ttl 255, id 40, offset 0, flags [none], proto ICMP (1), length 100)
10.2.10.254 > 10.2.10.1: ICMP echo reply, id 8, seq 0, length 80

but, R2 show ICMP failed.

Code:
R2#ping s10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.2.10.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


I use native lan port from mac pro to breakout and configure with 100 Mb/s full duplex.

I have no idea what happens why the ping failed from both end.




Last edited by claydon_dan on Tue Oct 07, 2014 6:12 pm, edited 1 time in total.
Add code blocks


Top
 Profile  
 
 Post subject: Re: Odd problem found during Q in Q setup
PostPosted: Tue Oct 07, 2014 4:11 pm 
Offline

Joined: Tue Oct 07, 2014 3:39 pm
Posts: 2
This is what I have from SPAN

No. Time Source Destination Protocol Length Info
15370 3760.066317000 10.2.10.254 10.2.10.1 ICMP 122 Echo (ping) request id=0x001d, seq=4/1024, ttl=255 (no response found!)

Frame 15370: 122 bytes on wire (976 bits), 122 bytes captured (976 bits) on interface 0
Ethernet II, Src: Cisco_c7:1a:c2 (00:15:63:c7:1a:c2), Dst: c2:00:02:5d:00:00 (c2:00:02:5d:00:00)
Destination: c2:00:02:5d:00:00 (c2:00:02:5d:00:00)
Source: Cisco_c7:1a:c2 (00:15:63:c7:1a:c2)
Type: 802.1Q Virtual LAN (0x8100)
802.1Q Virtual LAN, PRI: 0, CFI: 0, ID: 102
000. .... .... .... = Priority: Best Effort (default) (0)
...0 .... .... .... = CFI: Canonical (0)
.... 0000 0110 0110 = ID: 102
Type: 802.1Q Virtual LAN (0x8100)
802.1Q Virtual LAN, PRI: 0, CFI: 0, ID: 10
000. .... .... .... = Priority: Best Effort (default) (0)
...0 .... .... .... = CFI: Canonical (0)
.... 0000 0000 1010 = ID: 10
Type: IP (0x0800)
Internet Protocol Version 4, Src: 10.2.10.254 (10.2.10.254), Dst: 10.2.10.1 (10.2.10.1)
Internet Control Message Protocol
Type: 8 (Echo (ping) request)
Code: 0
Checksum: 0x07d0 [correct]
Identifier (BE): 29 (0x001d)
Identifier (LE): 7424 (0x1d00)
Sequence number (BE): 4 (0x0004)
Sequence number (LE): 1024 (0x0400)
[No response seen]
Data (72 bytes)




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO