It is currently Sat Sep 26, 2020 3:08 pm


All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: GNS3 Alpha5 "Remote system refused the connection."
PostPosted: Wed May 28, 2014 12:13 am 
Offline

Joined: Wed May 28, 2014 12:07 am
Posts: 1
Hi Everyone,

Long time user, first time poster on these forums. I'm really loving the use of GNS 1.0, especially the capability of using IOU on it, definitely awesome!!

I haven't run into many issues really, the only one I have run into is in the following scenario;

My GNS3 1.0 server running on Linux Mint (Virtual Machine) is bound to my internal network so that I can telnet from my favourite client outside of the linux host, everything works as expected, no issues at all except for, when i telnet into the devices (primarily IOU) devices and I disconnect my session from them attempting to reconnect will give me the message;

"The remote system refused the connection"

This also seems to happen while using it directly from the GNS3 application on Linux Mint when clicking "Console Connect to All devices".

I was wondering if anyone else has experienced this little thing, it's not major really, the only way I could fix it is by turning off all the devices and turning them back on, then my console access works just fine.

Just wanted to take the time to thank the developers on this product, seeing its capability, i'm debating on selling off my physical lab equipment and build a dedicated GNS3 environment on a standalone server.

Thanks in advance!!




Top
 Profile  
 
 Post subject: Re: GNS3 Alpha5 "Remote system refused the connection."
PostPosted: Thu May 29, 2014 7:52 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

Thanks for the feedback :) This is a strange issue, I don't think anyone excepting you got it so far.

Quote:
"The remote system refused the connection"


I would confirm that the console TCP ports are still listening just before you try to console again.

Here is an example with 3 IOU devices running, default ports should be 4000 to 40003:

Code:
$ netstat -lnpt
(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:4001          0.0.0.0:*               LISTEN      20966/python3   
tcp        0      0 127.0.0.1:4002          0.0.0.0:*               LISTEN      20966/python3   
tcp        0      0 127.0.0.1:4003          0.0.0.0:*               LISTEN      20966/python3


If you don't see anything, please start the gns3server first, then the GUI using terminals. Finally when the issue happen, post the gns3server logging output.

Thanks,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: GNS3 Alpha5 "Remote system refused the connection."
PostPosted: Thu Jun 05, 2014 4:54 pm 
Offline

Joined: Thu Jun 05, 2014 4:11 pm
Posts: 2
Jeremy,

Great job so far. First time poster but love the new release. I too am having the same problem.....or very similar at least, I'm now on Alpha 6.

When I telnet remotely from a client to a GNS3 router on my (Ubuntu 14.04) server using SecureCRT to 10.26.8.116:4001 it connects fine and everything's OK:

[I 140605 17:04:06 ioucon:320] Telnet connection from 10.26.14.1:63647

However, when I disconnect the SecureCRT session on the client, the GNS3 server console throws up the following - and I have to restart the router to reconnect to it via telnet:

[I 140605 17:04:39 ioucon:337] Telnet client disconnected
[W 140605 17:04:39 ioucon:341] shutdown: [Errno 107] Transport endpoint is not connected
Exception in thread Thread-1:
Traceback (most recent call last):
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/threading.py", line 921, in _bootstrap_inner
self.run()
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/threading.py", line 869, in run
self._target(*self._args, **self._kwargs)
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/site-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 614, in start_ioucon
send_recv_loop(console, router, b'', stop_event)
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/site-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 504, in send_recv_loop
data = console.read(fileno, BUFFER_SIZE)
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/site-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 224, in read
buf = self._read_cur(bufsize, socket.MSG_DONTWAIT)
File "/home/graham/.pyenv/versions/3.4.0/lib/python3.4/site-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 253, in _read_cur
return self.fd_dict[self._cur_fileno].recv(bufsize, flags)
ConnectionResetError: [Errno 104] Connection reset by peer


It doesn't happen with IOS images. Any ideas or suggestions?

Graham


Top
 Profile  
 
 Post subject: Re: GNS3 Alpha5 "Remote system refused the connection."
PostPosted: Fri Jun 06, 2014 11:52 am 
Offline

Joined: Thu Jun 05, 2014 4:11 pm
Posts: 2
Apologies - there's a typo in my post above, the Ubuntu Version for the output in my previous post is 12.04 LTS (64-bit) not 14.04.
Here is the output from an Ubuntu 14.04 LTS (64-bit) server for the same issue:

[I 140606 12:32:01 ioucon:337] Telnet client disconnected
[W 140606 12:32:01 ioucon:341] shutdown: [Errno 107] Transport endpoint is not connected
Exception in thread Thread-1:
Traceback (most recent call last):
File "/usr/lib/python3.4/threading.py", line 920, in _bootstrap_inner
self.run()
File "/usr/lib/python3.4/threading.py", line 868, in run
self._target(*self._args, **self._kwargs)
File "/usr/local/lib/python3.4/dist-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 614, in start_ioucon
send_recv_loop(console, router, b'', stop_event)
File "/usr/local/lib/python3.4/dist-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 504, in send_recv_loop
data = console.read(fileno, BUFFER_SIZE)
File "/usr/local/lib/python3.4/dist-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 224, in read
buf = self._read_cur(bufsize, socket.MSG_DONTWAIT)
File "/usr/local/lib/python3.4/dist-packages/gns3_server-1.0a6-py3.4.egg/gns3server/modules/iou/ioucon.py", line 253, in _read_cur
return self.fd_dict[self._cur_fileno].recv(bufsize, flags)
ConnectionResetError: [Errno 104] Connection reset


Graham


Top
 Profile  
 
 Post subject: Re: GNS3 Alpha5 "Remote system refused the connection."
PostPosted: Thu Jun 12, 2014 1:14 pm 
Offline

Joined: Fri Apr 04, 2014 12:53 pm
Posts: 26
Jeremy,

I get this error as well. I've just worked through the problems by restarting the device(s). Since they boot so fast, it isn't too much of a pain. But it sure would be nice if this didn't happen.

FYI, I'm using the windows version. I have Linux version at home, but have not tested it there yet.

Thanks,
Tony




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO