It is currently Sat Feb 27, 2021 12:28 pm


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Ping works but can't trace
PostPosted: Wed Jun 11, 2014 1:36 pm 
Offline

Joined: Tue Jan 21, 2014 3:17 pm
Posts: 36
I have a fairly simple network setup with 2 routers and ospf. On each router I have a switch and pc's attached.

Using

vpcs I can ping the PC on the far side but when tracing to it I get this error:

Code:
VPCS[1]> trace 10.1.0.4
trace to 10.1.0.4, 8 hops max, press Ctrl+C to stop
1   10.0.0.1   19.000 ms  9.000 ms  9.000 ms
2   192.168.0.2   62.000 ms  29.000 ms  29.000 ms
3   *10.1.0.4   38.000 ms (ICMP type:3, code:3, Destination port unreachable)


I get the same error if I try and trace from 10.1.0.4 to 10.0.0.3 (PC1)

Tracing between routers works fine so it looks like the default gateway is not working on the PC even though I've set it.

I also can't trace from PC1 to PC2 (On the same switch)

Code:
VPCS[1]> trace 10.0.0.4
trace to 10.0.0.4, 8 hops max, press Ctrl+C to stop
1   *10.0.0.4   2.000 ms (ICMP type:3, code:3, Destination port unreachable)


Here are all the configs - is there something glaringly obvious I'm missing?

VPCS Config
Code:
1
ip 10.0.0.3 10.0.0.1 24
2
ip 10.0.0.4 10.0.0.1 24
3
ip 10.1.0.3 10.1.0.1 24
4
ip 10.1.0.4 10.1.0.1 24
5
6
7
8
9
1


Router1
Code:
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback0
no ip address
!
interface Serial0/0
ip address 192.168.0.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
ip address 192.168.3.1 255.255.255.0
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
description LAN1
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end



Router2:
Code:
!

!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
!
!
ip cef
no ip domain lookup
!
ip tcp synwait-time 5
!
interface Loopback0
no ip address
!
interface Serial0/0
ip address 192.168.0.2 255.255.255.0
serial restart-delay 0
!
interface Serial0/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial0/3
no ip address
shutdown
serial restart-delay 0
!
interface FastEthernet1/0
ip address 10.1.0.1 255.255.255.0
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
network 10.1.0.0 0.0.0.255 area 0
network 192.168.0.0 0.0.0.255 area 0
!
no ip http server
no ip http secure-server
!
control-plane
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end





Attachments:
File comment: Topology
topology.png
topology.png [ 28.05 KiB | Viewed 8237 times ]
Top
 Profile  
 
 Post subject: Re: Ping works but can't trace
PostPosted: Wed Jun 11, 2014 6:17 pm 
Offline

Joined: Sat Aug 17, 2013 7:59 pm
Posts: 123
Location: Upper Silesia, Poland
vpcs' traceroute use udp by default. You can change it with "-P <protocol>" from vpcs cmdline.
For example, for traceroute with TCP packets, do "trace 10.1.0.4 -P 6".

...And yes, in present days, default for traceroute is to use TCP (am I wrong? Correct me, please). Besides that, many network-oriented people (and especially admins) prefer to use mtr (or winmtr on windows) instead of tracert...

I would be interested in changing defaults in any way (for example, from GNS3 and/or VPCS config file)

_________________
If you can see any inaccuracies or other language-related mistakes in my post(s), please forgive me - English is not my native language


Top
 Profile  
 
 Post subject: Re: Ping works but can't trace
PostPosted: Wed Jun 11, 2014 7:16 pm 
Offline

Joined: Tue Jan 21, 2014 3:17 pm
Posts: 36
Thanks - that did the trick. Trace is working fine now.

Curious to know why udp traces dont work but a tcp trace does.

Would be great if you can change the defaults of vpcs - I'll look into it.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO