It is currently Sat Jan 18, 2020 1:59 am


All times are UTC




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Packet Capture Issues
PostPosted: Sun Jul 20, 2014 4:33 pm 
Offline

Joined: Sun Jul 20, 2014 4:22 pm
Posts: 1
Old Sports,

I have just downloaded the early release for the first time, alpha 8. Everything works hunky dory apart from the packet capture functionality.

I originally installed this on my Mac (running Mavericks) however I could not get it working, so I tried the Linux version on a brand new installed of Ubuntu, same problem.

Basically, I start the capture by right clicking the interface from the right hand side menu and click Start Capture.

Console confirms the capture should be working OK:

Code:
[I 140720 09:16:51 router:1588] router "R2" [id=1]: starting packet capture on port 0/0
[I 140720 09:16:51 router:565] R2 has successfully started capturing packets on FastEthernet0/0

When I right click the interface with the magnifying glass on it and click Start Wireshark, I receive the following error in the GUI:

Code:
Cannot start Wireshark: the /home/martin/GNS3/projects/test/test-files/dynamips/captures/R2_FastEthernet0-0_to_Cloud 1_nio_gen_eth:eth0.pcap capture file does not exist on this host

And when I check that directory, it is correct, that file does not exist.

Neither the traditional or live capture options work.

I have tried everything under the sun, re-read all the information I can find, but im still stumped. Everything I have read suggests these features should be working.

Where should I start to resolve this?

Thanks
Martin




Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Sun Jul 27, 2014 2:33 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
There must be a bug... I'll investigate.

I supposed you have the same issue with beta1?

Regards,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Thu Jul 31, 2014 11:14 pm 
Offline

Joined: Tue Apr 01, 2014 9:42 pm
Posts: 32
Did we find a resolve for this, im experiencing the same issue with beta1.0

regards

warren


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Sat Aug 02, 2014 7:19 pm 
Offline

Joined: Tue Jul 29, 2014 2:52 am
Posts: 2
Plus 1 here.
I'm testing with Beta1 and IOU. Most things work very well, but I can't start packet capture.
The server logs show the capture starts - [I 140802 15:15:30 iou_device:496] tad1 has successfully started capturing packets on Ethernet0/0
However WShark can't start - msg is 'home/.../..pcap capture file does not exist on host.

I looked at the directory and the message is correct ..there are no capture files


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Wed Aug 20, 2014 12:26 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Quote:
Cannot start Wireshark: the /home/martin/GNS3/projects/test/test-files/dynamips/captures/R2_FastEthernet0-0_to_Cloud 1_nio_gen_eth:eth0.pcap capture file does not exist on this host


The file could not be created because a reserved character (:) was used. This bug will be fixed for the next release.

Thanks,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Thu Sep 04, 2014 6:15 pm 
Offline

Joined: Sat Jul 26, 2014 10:16 am
Posts: 3
Hello!
You promised to fix this, but in beta2 the problem still exist.


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Thu Sep 04, 2014 8:12 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Quote:
You promised to fix this, but in beta2 the problem still exist.


Do you still have the same error message? Is your Windows in English or another language?

Thanks,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Sun Sep 07, 2014 12:57 pm 
Offline

Joined: Sat Jul 26, 2014 10:16 am
Posts: 3
grossmj wrote:

Do you still have the same error message? Is your Windows in English or another language?

Thanks,


I use Windows 7 x64 english version

Image


Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Mon Sep 08, 2014 4:38 pm 
Offline

Joined: Mon Sep 08, 2014 4:08 pm
Posts: 1
UBUNTU 14.04, GNS3 1.0beta2 Cannot capture between IOUs!
The cap just doesn't appear in the folder.
Please help solve this!

Update: solved this just by compiling the latest iouyap by myself.


Attachments:
no_capture_linux.jpeg
no_capture_linux.jpeg [ 219.16 KiB | Viewed 6209 times ]
Top
 Profile  
 
 Post subject: Re: Packet Capture Issues
PostPosted: Tue Sep 09, 2014 11:03 am 
Offline

Joined: Thu Jul 19, 2012 3:53 am
Posts: 14
Location: DC
gmu wrote:
grossmj wrote:

Do you still have the same error message? Is your Windows in English or another language?

Thanks,


I use Windows 7 x64 english version

Image


I concur, same error message on WIN7_x64 (eng) with the latest GNS3-IOU-VM.



_________________
Image
Linux GNS3-IOUVM 3.13.1-686-pae
GNS3 1 Beta 2 xfce4 3.14.15-686-pae
GNS3 1 Alpha 1/2/3/4/6 Debian 3.13-1-686-pae
GNS3 0.8.3/GNS3 0.8.5/0.8.6 Windows 7 x64


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO