It is currently Mon Dec 11, 2017 12:09 am


All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: cant ping if "tunn mpls traffic-eng autor announce" confgrd
PostPosted: Sat Aug 09, 2014 4:19 pm 
Offline

Joined: Sat Aug 09, 2014 4:12 pm
Posts: 2
Dear Folks,

I have built GNS service provider LAB which has a vrf configured on PEs and if command "tunnel mpls traffic-eng autoroute announce" is issued inside tunnel interface in order to prefer routes via tunnel then ping fails.
Need support to resolve the issue.

LAB Set up:

CE1------PE1------P1------P2------P3------P4------PE2------CE2

Inputes:
1. Tunnel0 is configured on P1 destined to P4
2. PE2 loopback is preferred through tunnel interface and able to ping the same.
3. trace from CE1 fails on PE1.
4. Able to ping end to end if subjected command is not issued i.e. tunnel is not used.

Pls help to solve the problem.

[img]C:\Users\Shardul\Desktop\Capture.PNG[/img]


Rgds,
Shardul




Top
 Profile  
 
 Post subject: Re: cant ping if "tunn mpls traffic-eng autor announce" conf
PostPosted: Mon Aug 11, 2014 8:30 am 
Offline

Joined: Fri Nov 07, 2008 12:04 pm
Posts: 179
Location: Netherlands
Can you please post the configuration?

_________________
Image Image Image Image ImageImage


Top
 Profile  
 
 Post subject: Re: cant ping if "tunn mpls traffic-eng autor announce" conf
PostPosted: Mon Aug 11, 2014 7:16 pm 
Offline

Joined: Sat Aug 09, 2014 4:12 pm
Posts: 2
[img]C:\Users\Shardul\Desktop\Capture.PNG[/img] Mod: Images must be uploaded using the attachment system on the post


CE1 -->


Code:
interface FastEthernet0/0
ip address 10.0.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
neighbor 10.0.0.1 remote-as 55410
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 10.0.0.1


----------------

PE1 ==>

Code:
ip vrf cust_A
rd 182.19.96.3:10
route-target export 55410:10
route-target import 55410:10
route-target import 65010:10
!
no ip domain lookup
!
mpls label protocol ldp
mpls ldp neighbor 182.19.96.38 targeted ldp
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.3 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding cust_A
ip address 10.0.0.1 255.255.255.252
duplex auto
speed auto
!
interface Serial1/0
ip address 182.19.96.100 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/1
description TO_PE2
ip address 182.19.96.102 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/2
description TO_P2
ip address 182.19.96.108 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
description TO_PUN-PE1
ip address 182.19.96.144 255.255.255.254
ip ospf cost 65535
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 182.19.96.0 0.0.0.255 area 0
!
router bgp 55410
bgp log-neighbor-changes
neighbor peer-rr peer-group
neighbor peer-rr remote-as 55410
neighbor peer-rr ebgp-multihop 2
neighbor peer-rr update-source Loopback0
neighbor 182.19.96.50 peer-group peer-rr
!
address-family ipv4
  neighbor peer-rr route-reflector-client
  no neighbor 182.19.96.50 activate
  no auto-summary
  no synchronization
exit-address-family
!
address-family vpnv4
  neighbor peer-rr send-community extended
  neighbor 182.19.96.50 activate
exit-address-family
!
address-family ipv4 vrf cust_A
  redistribute connected
  neighbor 10.0.0.2 remote-as 65101
  neighbor 10.0.0.2 activate
  neighbor 10.0.0.2 as-override
  no synchronization
exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip access-list standard igp
deny   182.19.0.0 0.0.255.255 log
permit any
!

***********************************

P1==>

Code:
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
mpls ldp neighbor 182.19.96.100 targeted
mpls ldp neighbor 182.19.96.106 targeted
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.1 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
mpls traffic-eng tunnels
tunnel destination 182.19.96.36
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth  1000
tunnel mpls traffic-eng path-option 1 dynamic
no routing dynamic
ip rsvp bandwidth
ip rsvp resource-provider none
!
interface Tunnel9
no ip address
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 182.19.96.101 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
!
interface Serial1/1
description TO_P2
ip address 182.19.96.107 255.255.255.254
mpls label protocol ldp
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/2
description TO_PE2
ip address 182.19.96.111 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
description TO_BHO-P
ip address 182.19.96.153 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
ip rsvp bandwidth
!
interface Serial2/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 182.19.96.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mpls ldp router-id Loopback0
!
control-plane

**************************************

P2==>

Code:
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.41 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
description TO_PUN-P1
ip address 182.19.96.152 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
ip rsvp bandwidth
!
interface Serial2/1
description TO_NGP-P
ip address 182.19.96.137 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial2/2
description TO_MUM-P
ip address 182.19.96.127 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial2/3
description TO_BHU-P
ip address 182.19.96.138 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
ip rsvp bandwidth
ip rsvp resource-provider none
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 182.19.96.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mpls ldp router-id Loopback0
!
control-plane
!



************************

P3==>



Code:
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.36 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
mpls traffic-eng tunnels
tunnel destination 182.19.96.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth  1000
tunnel mpls traffic-eng path-option 1 dynamic
no routing dynamic
ip rsvp bandwidth
ip rsvp resource-provider none
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description TO_PE1
ip address 182.19.96.112 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/1
description TO_P2
ip address 182.19.96.114 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/2
description TO_PE2
ip address 182.19.96.123 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
description TO_BHU-P
ip address 182.19.96.141 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
ip rsvp bandwidth
ip rsvp resource-provider none
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 182.19.96.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mpls ldp router-id Loopback0
!
control-plane


*****************

P4 ==>

Code:
ip cef
!
no ip domain lookup
!
mpls label protocol ldp
mpls traffic-eng tunnels
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.36 255.255.255.255
!
interface Tunnel0
ip unnumbered Loopback0
mpls traffic-eng tunnels
tunnel destination 182.19.96.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng bandwidth  1000
tunnel mpls traffic-eng path-option 1 dynamic
no routing dynamic
ip rsvp bandwidth
ip rsvp resource-provider none
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description TO_PE1
ip address 182.19.96.112 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/1
description TO_P2
ip address 182.19.96.114 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/2
description TO_PE2
ip address 182.19.96.123 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
description TO_BHU-P
ip address 182.19.96.141 255.255.255.254
mpls ip
mpls traffic-eng tunnels
serial restart-delay 0
clock rate 4032000
ip rsvp bandwidth
ip rsvp resource-provider none
!
interface Serial2/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
log-adjacency-changes
network 182.19.96.0 0.0.0.255 area 0
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
mpls ldp router-id Loopback0
!
control-plane



*****************************

PE2 ==>

Code:
ip cef
!
ip vrf cust_A
rd 182.19.96.38:10
route-target export 55410:10
route-target import 55410:10
route-target import 65010:10
!
no ip domain lookup
!
mpls label protocol ldp
mpls ldp neighbor 182.19.96.3 targeted ldp
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 182.19.96.38 255.255.255.255
!
interface FastEthernet0/0
ip vrf forwarding cust_A
ip address 10.0.0.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
description TO_P1
ip address 182.19.96.113 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/1
description TO_PE2
ip address 182.19.96.118 255.255.255.254
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial1/2
description TO_P2
ip address 182.19.96.120 255.255.255.254
mpls ip
no keepalive
serial restart-delay 0
clock rate 4032000
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial2/1
ip address 30.0.0.2 255.255.255.252
mpls label protocol ldp
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial2/2
description TO_KOL-PE1
ip address 182.19.96.149 255.255.255.254
ip ospf cost 65535
mpls label protocol ldp
mpls ip
serial restart-delay 0
clock rate 4032000
!
interface Serial2/3
no ip address
shutdown
serial restart-delay 0
!
router ospf 1
log-adjacency-changes
redistribute bgp 55410 subnets
network 182.19.96.0 0.0.0.255 area 0
distribute-list 1 in Serial2/2
!
router bgp 55410
bgp log-neighbor-changes
neighbor peer-rr peer-group
neighbor peer-rr remote-as 55410
neighbor peer-rr ebgp-multihop 2
neighbor peer-rr update-source Loopback0
neighbor 30.0.0.1 remote-as 65010
neighbor 182.19.96.50 peer-group peer-rr
!
address-family ipv4
  redistribute ospf 1
  neighbor 30.0.0.1 activate
  neighbor 30.0.0.1 send-community both
  neighbor 30.0.0.1 route-map ospf-bgp out
  neighbor 30.0.0.1 send-label
  no neighbor 182.19.96.50 activate
  no auto-summary
  no synchronization
exit-address-family
!
address-family vpnv4
  neighbor peer-rr send-community extended
  neighbor 182.19.96.50 activate
exit-address-family
!
address-family ipv4 vrf cust_A
  redistribute connected
  neighbor 10.0.0.6 remote-as 65101
  neighbor 10.0.0.6 activate
  neighbor 10.0.0.6 as-override
  no synchronization
exit-address-family
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip prefix-list ospf2bgp seq 5 permit 182.19.96.1/32
ip prefix-list ospf2bgp seq 10 permit 182.19.96.2/32
ip prefix-list ospf2bgp seq 15 permit 182.19.96.3/32
ip prefix-list ospf2bgp seq 20 permit 182.19.96.4/32
ip prefix-list ospf2bgp seq 25 permit 182.19.96.50/32
ip prefix-list ospf2bgp seq 30 permit 182.19.96.41/32
ip prefix-list ospf2bgp seq 35 permit 182.19.96.36/32
ip prefix-list ospf2bgp seq 40 permit 182.19.96.37/32
ip prefix-list ospf2bgp seq 45 permit 182.19.96.38/32
ip prefix-list ospf2bgp seq 50 permit 182.19.96.39/32
access-list 1 deny   182.19.96.3
access-list 1 permit any
!
route-map igp_block permit 10
match ip address 1
!
route-map ospf-bgp permit 10
match ip address prefix-list ospf2gnp
set mpls-label
!
mpls ldp router-id Loopback0
!
control-plane

**************************************************

CE2 ==>

Code:
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
archive
log config
  hidekeys
!
ip tcp synwait-time 5
!
interface Loopback0
ip address 100.0.0.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.0.0.6 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 65101
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 10.0.0.5 remote-as 55410
no auto-summary
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
control-plane




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO