It is currently Wed Aug 16, 2017 1:02 pm


All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Asking for Help - Step by Step Guide
PostPosted: Tue Sep 23, 2014 7:11 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
If you'd like someone on the forum to help you with your GNS3/Networking problem, follow these steps:

  1. On this forum, go to General Issues and click on New Topic
    Attachment:
    NewTopic.png
    NewTopic.png [ 27.02 KiB | Viewed 30981 times ]
  2. Describe your problem, making sure you include your topology using one or both of the following methods:
    • Method #1 - use show run from the console - This is the BEST method because someone can now re-produce your topology and it will reveal which IOS you are using
      1. In GNS3, find the GNS3 Console window - see the diagram below (taken from the GNS3 Network Simulation Guide) for reference
        Attachment:
        0809_02_03-WorkSpace Window description.png
        0809_02_03-WorkSpace Window description.png [ 206.25 KiB | Viewed 30981 times ]

        • If the console window does not appear, click View | Docks | Console
      2. In the Console window, type show run and hit Enter
      3. Select the output of the command, right-click and select Copy
      4. In your GNS3 posting, click on the [ code ] button from the formatting tools
      5. Paste in the output from the show run command. It should look something like this:
        Code:
        autostart = False
        [127.0.0.1:7200]
            workingdir = /var/folders/53/sl8_hqnj0wn3gl14tst6sw3w0000gn/T/GNS3_lrYVwb/working
            udp = 10001
            [[3725]]
                image = /Users/chriswelsh/GNS3/Images/c3725-adventerprisek9-mz.124-15.T10.image
                ram = 128
                idlepc = 0x60c056e4
                sparsemem = True
                ghostios = True
            [[ROUTER R1]]
                model = 3725
                console = 2101
                aux = 2501
                f0/0 = R2 f0/0
            [[ROUTER R2]]
                model = 3725
                console = 2102
                aux = 2502
                f0/0 = R1 f0/0

        Or if using GNS3 v1, like this:
        Code:
        {
            "name": "unsaved",
            "resources_type": "local",
            "topology": {
        <...large snip...>
                "servers": [
                    {
                        "host": "127.0.0.1",
                        "id": 1,
                        "local": true,
                        "port": 8000
                    }
                ]
            },
            "type": "topology",
            "version": "1.0beta2"
        }
    • Method #2 - screen dump - worth doing even if you have already done the show run
      1. In GNS3, make sure your topology is showing interface labels [Select View | Show/Hide interface labels. You may have to move the labels a little so they are clearly visible - be careful. Make sure you put the right label next o the right interface]
      2. Take a picture of your screen
        • On a PC, hit Alt+PrintScreen, open Paint and paste in your screendump. Save your file
        • On a Mac, Hit Shift+Ctrl+Cmd+4 - when the crossbar appears click and drag a rectangle to select your screendump. Open the Preview app, select File|New from clipboard . Save your picture
      3. Back at the post where you are describing your problem, look at the area UNDER you post where the (hard to read) Upload Attachment section is.
      4. Click on [Choose File], find the file you saved earlier and click [OK] - but that's not all
      5. Now you ALSO have to click [Add the File] - still not done
        Attachment:
        ChooseFile.png
        ChooseFile.png [ 26.35 KiB | Viewed 30981 times ]
      6. Finally, you have to realise that your cursor will have been moved in the above steps. Place your cursor back where you want the picture to go and look just under the section where you are typing and click [Place inline]
        Attachment:
        PlaceInline.png
        PlaceInline.png [ 13.57 KiB | Viewed 30981 times ]
      7. Your picture should now be in your post
  3. If your problem involves configs, you MIGHT want to include them, or include parts of them.
  4. Before posting make sure you read How to Ask for Help
  5. Before posting, RE-READ your posting, putting yourself in the mind of someone else reading it. Have you made assumptions that another person might miss? Have you included details that are not relevant to the problem?

Note: This post was inspired by the following post - which does a pretty good explanation, but no screendump or show run:

Quote:
Hi All !
I am setting up HSRP routing lab in GNS3. I am using 2 multilayer switches and 2 access switches with IOS 3700. I have created 5 VLANS in the network. Every thing has been set-up successfully. HSRP functionality is fine on multilayer switches. It has been tested and verified. Ip routing has been activated on multilayer switches and I am getting all the VLAN interfaces in routing tables of both multilayer switches.
After all my efforts I could not get VLAN routing working. All the nodes in the VLANs are able to ping the related virtual gateway configured on the HSRP (Multilayer Switches) but not able to ping the host in the other VLAN. Please guide me what I am missing here. I really appreciate the response.

Regards



Disclaimer: I am the author of the GNS3 Network Simulation Guide



_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO