It is currently Sat Oct 24, 2020 3:46 am


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: SecureCRT kills IOU connections?
PostPosted: Sun Sep 28, 2014 4:58 pm 
Offline

Joined: Sun Sep 28, 2014 4:35 pm
Posts: 3
OS: Windows 7 x64 SP1
GNS3: GNS3-ER-1.0-beta3-all-in-one.exe
IOU: GNS3 IOU VM.ova
Hypervisor: VMware Workstation 10.0.3
SecureCRT: 7.2.6 x64

First, if I chose Putty as the console application, everything works just fine.
Attachment:
Putty.png
Putty.png [ 17.5 KiB | Viewed 3123 times ]


However, If I chose SecureCRT as the console application, I experience the following problem:
Attachment:
SecureCRT.png
SecureCRT.png [ 21.27 KiB | Viewed 3123 times ]


1) I double-click the router symbol to open console.
2) GNS3 brings up SecureCRT and connect to the router. Everything works fine so far.
3) I close SecureCRT
4) I try double-click the router symbol to open console.
5) SecureCRT not able to connect and give "Remote system refused the connection" message.

I looked at the IOU VM. It looks like when I close SecureCRT the first time, the IOU VM closed the connection to the router console port (port 4001 in this case). At this point, no matter what client you use (putty, windows telnet, etc.), you won't be able to connect because the IOU VM doesn't listen on port 4001 anymore. The only solution is to reload the router from GNS3.

This behavior doesn't happen with Putty. i.e. if you close Putty client, IOU VM will continue listen on the port.

What would cause the IOU VM stop listening to a port (router console port)?

Before closing SecureCRT client. IOU VM is listening on port 4001 (for Router1) and 4002 (for Router2):
Attachment:
before.png
before.png [ 12.81 KiB | Viewed 3123 times ]


After making connection to Router 1 with SecureCRT and closing the client. IOU VM is not listening on port 4001 anymore:
Attachment:
after.png
after.png [ 11.53 KiB | Viewed 3123 times ]



_________________
GNS3: GNS3-ER-1.0-beta3-all-in-one.exe
IOU VM: gns3-iouvm 3.13-1-686-pae
OS: Windows 7 x64 SP1
Hypervisor: VMware Workstation 10.0.3
SecureCRT: 7.2.6 x64


Top
 Profile  
 
 Post subject: Re: SecureCRT kills IOU connections?
PostPosted: Sun Sep 28, 2014 7:41 pm 
Offline

Joined: Sun Sep 28, 2014 4:35 pm
Posts: 3
Did some research, and it looks similar to topic10172.html

Seems to be something in GNS3server?



_________________
GNS3: GNS3-ER-1.0-beta3-all-in-one.exe
IOU VM: gns3-iouvm 3.13-1-686-pae
OS: Windows 7 x64 SP1
Hypervisor: VMware Workstation 10.0.3
SecureCRT: 7.2.6 x64


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO