It is currently Tue Aug 22, 2017 5:22 am


All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Cannot ping beyond SVI on each vlan connected to physical 35
PostPosted: Thu Oct 16, 2014 1:19 am 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
In the below topology, L3SW1 is a physical 3550. I have configured several vlans ( 40, 20, 1) on the 3550 and on the generic GNS3 switch. The physical port on the 3550 that connects to the map is configured as a trunk as is the port on the generic GNS3 switch. The XP machines are Windows XP virtual machines running in Hyper-V on this machine. From XP1 I can ping all the SVIs fine, but I can't ping passed the SVI. Same for the switch. I can serial into the switch and cannot ping XP3 or XP2. It seems devices that are in vlan 1 ( the 3550, R1 and XP1) can ping their local gateway as well as the other two SVIs, but that's it.

Am I missing something obvious as to why I cannot ping between vlans on this 3550? I have enabled ip routing on the switch and all vlans are trunked to fa0/23 ( the port used to connect to GNS3)



Image




Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 5:01 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
do a show run in the GNS3 console. Details here: topic12130.html

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 1:19 pm 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
Code:
autostart = False
[127.0.0.1:7202]
    workingdir = C:\Users\ARCADI~1.TES\AppData\Local\Temp\2
    udp = 10201
[qemu 127.0.0.1:10525]
    workingdir = E:\GNS3\Projects\GNS3_Physical router test\qemu-flash-drives
    udp = 40000
    qemupath = qemu.exe
    qemuimgpath = qemu-img.exe
    [[5520]]
        ram = 1024
        netcard = e1000
        options = -vnc none -vga none -m 1024 -icount auto -hdachs 980,16,32
        initrd = E:\GNS3\Cisco IOS\ASA842\asa842-initrd.gz
        kernel = E:\GNS3\Cisco IOS\ASA842\asa842-vmlinuz
        kernel_cmdline = -append ide_generic.probe_mask=0x01 ide_core.chs=0.0:980,16,32 auto nousb console=ttyS0,9600 bigphysarea=65536
    [[ASA ASA1]]
        e0 = EXT 2
        e1 = Int 3
[127.0.0.1:7200]
    workingdir = C:\Users\ARCADI~1.TES\AppData\Local\Temp\2
    udp = 10001
    [[2691]]
        image = E:\GNS3\Cisco IOS\c2691-advipservicesk9-mz.124-15.T6.image
        ram = 256
        idlepc = 0x60b6c5c8
        sparsemem = True
        ghostios = True
    [[ROUTER R1]]
        model = 2691
        console = 2101
        aux = 2501
        cnfg = E:\GNS3\Projects\GNS3_Physical router test\configs\R1.cfg
        f0/0 = EXT 3
        f0/1 = Int 4
    [[ROUTER R2]]
        model = 2691
        console = 2102
        aux = 2502
        cnfg = E:\GNS3\Projects\GNS3_Physical router test\configs\R2.cfg
        f0/0 = nio_gen_eth:\device\npf_{13fd3507-25cd-4934-b65b-461f5ef3048b}
    [[ETHSW Int]]
        1 = dot1q 1 nio_gen_eth:\device\npf_{d0a1f5b3-7131-410a-8391-a914e5b6b61b}
        2 = access 1 nio_gen_eth:\device\npf_{4e74b89b-e610-4988-ad81-b849f616ae2b}
        3 = access 1 ASA1 e1
        4 = access 1 R1 f0/1
        5 = access 20 nio_gen_eth:\device\npf_{42e786f2-374b-458f-a9bb-b82f364abf46}
        6 = access 40 nio_gen_eth:\device\npf_{71063f4d-a55f-4581-9bbc-cbac9fa82f35}
    [[ETHSW EXT]]
        1 = access 1 nio_gen_eth:\device\npf_{e2eec78d-a8f9-45c5-90bc-57a0df235424}
        2 = access 1 ASA1 e0
        3 = access 1 R1 f0/0
=>


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 1:45 pm 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
I just checked to see if the mac addr of one of the virtual machines not pinging their default gateway ( the etherSVI on the 3550) would show up in the mac addr table on the 3550, and it does. The XP3 vm has mac addr 0015.5d00.7059


L3SW1#sh mac address-table addr 0015.5d00.7059
Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- -----
40 0015.5d00.7059 DYNAMIC Fa0/23
Total Mac Addresses for this criterion: 1
L3SW1#

Can't figure out why I can't ping....


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 2:27 pm 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
Here is config of the 3550:

Code:
L3SW1#sh run
Building configuration...

Current configuration : 4268 bytes
!
! Last configuration change at 10:18:57 UTC Thu Oct 16 2014
! NVRAM config last updated at 10:18:25 UTC Thu Oct 16 2014
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname L3SW1
!
logging buffered notifications
no logging console
!
no aaa new-model
ip subnet-zero
ip routing
!
!
!
crypto pki trustpoint TP-self-signed-812520960
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-812520960
revocation-check none
rsakeypair TP-self-signed-812520960
!
!
crypto pki certificate chain TP-self-signed-812520960
certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 38313235 32303936 30301E17 0D393330 33303130 30303130
  365A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3831 32353230
  39363030 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100
  D8A0DFDA 1F174C1B 1D951996 3AF49AC9 A489946A D971CDE2 C698F3B0 AD4C4ED3
  2E13EDAF 9C0EDEC3 CDC11A1D 909B3DB4 2B7E074C 2395E965 7D5DBE55 E8BF5542
  B5C2C6E1 B7990F5A 29E63F21 FAF8544E 17F54ACC 714A8ECF 947CF831 CD7E37ED
  B57932BE 0C9F0767 4E7E6AE8 AAEA6DFD E99C3C27 933B49DA 85CB349B 84442DBD
  02030100 01A36630 64300F06 03551D13 0101FF04 05300301 01FF3011 0603551D
  11040A30 0882064C 33535731 2E301F06 03551D23 04183016 8014F567 1B9B3CAC
  F831614E DFC16F35 6511F535 35C8301D 0603551D 0E041604 14F5671B 9B3CACF8
  31614EDF C16F3565 11F53535 C8300D06 092A8648 86F70D01 01040500 03818100
  21C80C68 84D7DBFA 8895323C A3CCB3E9 DAF44D6B 291CA29D D42A3BC4 54FBADBB
  4BEB3D97 7DD27978 E5FE08AA 0D22ED09 AA9A1781 017D482C C0AEFA6A 419872F1
  9FF62B9C 212922BA 9B8E5FDA EF25FCB7 9978C361 E35FC393 96E54824 6E502C1B
  46A7B49B 54E0A972 6866935B EE5EE4D6 83775647 20C7BEFF 645B4CAE 81A038D7
  quit
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface FastEthernet0/1
switchport mode dynamic desirable
!
interface FastEthernet0/2
switchport mode dynamic desirable
!
interface FastEthernet0/3
switchport mode dynamic desirable
!
interface FastEthernet0/4
switchport mode dynamic desirable
!
interface FastEthernet0/5
switchport mode dynamic desirable
!
interface FastEthernet0/6
switchport mode dynamic desirable
!
interface FastEthernet0/7
switchport mode dynamic desirable
!
interface FastEthernet0/8
switchport mode dynamic desirable
!
interface FastEthernet0/9
switchport mode dynamic desirable
!
interface FastEthernet0/10
switchport mode dynamic desirable
!         
interface FastEthernet0/11
switchport mode dynamic desirable
!
interface FastEthernet0/12
switchport mode dynamic desirable
!
interface FastEthernet0/13
switchport mode dynamic desirable
!
interface FastEthernet0/14
switchport mode dynamic desirable
!
interface FastEthernet0/15
switchport mode dynamic desirable
!
interface FastEthernet0/16
switchport mode dynamic desirable
!
interface FastEthernet0/17
switchport mode dynamic desirable
!
interface FastEthernet0/18
switchport mode dynamic desirable
!
interface FastEthernet0/19
switchport mode dynamic desirable
!
interface FastEthernet0/20
switchport mode dynamic desirable
!
interface FastEthernet0/21
switchport mode dynamic desirable
!
interface FastEthernet0/22
switchport mode dynamic desirable
!
interface FastEthernet0/23
description RTDP01
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/24
switchport mode dynamic desirable
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
ip address 10.10.20.1 255.255.255.0
!
interface Vlan40
ip address 10.10.40.1 255.255.255.0
!
!
router eigrp 500
network 10.10.20.0 0.0.0.255
network 10.10.40.0 0.0.0.255
network 192.168.10.0
!
ip classless
ip http server
ip http secure-server
!         
!
!
control-plane
!
!
line con 0
line vty 0 4
privilege level 15
password cisco
login
line vty 5 15
login
!
end

L3SW1#


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 4:57 pm 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
I also confirmed that I can disconnect the switch and configure R1 for router on a stick and all vlans can talk amongst each other. So it is definitely something with the 3550 that I am over looking.


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Thu Oct 16, 2014 11:34 pm 
Offline

Joined: Fri Feb 22, 2013 7:31 pm
Posts: 31
Been playing with this some more. So I connected another ethernet adapter to fa0/20 on the 3550 and the used a cloud in GNS3 for that port and another cloud for another XP vm. I had to use a GNS3 switch to connect the two clouds, but that at least gives me a client directly ( sort of ) connected to the 3550. I still cannot ping even the default gateway, much less to other vlans. When I put the port into vlan 1, I can ping devices in vlan 1 as well as the SVI for the other vlans.

Can't figure this out. It's getting annoying.


EDIT: Ok, suddenly the vm connected the second port on the switch, fa0/20, is now pinging all layer SVIs, its gateway, and a router on vlan 1 from vlan 50. So that's an improvement, but it still cannot ping any of the other xp vms in vlan 20 or 40, but can also ping the xp vm in vlan 1 right now. Oddly enough, I can ping the xp vm in vlan 1 from the xp vm in vlan 50 connected to the switch, but I cannot do the reverse. This is extremely puzzling.


Top
 Profile  
 
 Post subject: Re: Cannot ping beyond SVI on each vlan connected to physica
PostPosted: Fri Oct 17, 2014 2:45 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
I have seen some weird stuff like this where only broadcasts get through, but that was between a local host and an external interface. I've never played with Hyper-V (because I use VMware Fusion) so something similar may be going on.

However, even if this is the case, it does not help you much.

But at least it might be worth looking at. Do you have another PC that you could use to to a port monitor of the VLAN trunk port on the physical 3550 to verify that the correct packets are being received and sent with the correct tags?



_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO