It is currently Mon Sep 01, 2014 6:29 pm


All times are UTC




Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: can't connect qemu host to a switch?
PostPosted: Sun Jun 12, 2011 1:53 am 
Offline

Joined: Sun Jun 12, 2011 1:11 am
Posts: 2
Hi, guys

I'm having the same problem using Ubuntu. When the qemu host in not connected, It works fine (running microcore-3.4 ), and I can see the qemu process started:

# ps -aux | grep qemu
root 4725 9.5 4.6 322852 45496 ? SNl 22:23 0:04 /usr/bin/qemu -name QEMU1 -m 256 /home/marcelo/.gns3/Pix2Qemu/working/QEMU1/FLASH -hdb /home/marcelo/.gns3/Pix2Qemu/working/QEMU1/SWAP -net nic,vlan=0,macaddr=00:aa:00:42:24:00,model=e1000 -serial telnet:127.0.0.1:3000,server,nowait -no-acpi -vnc 127.0.0.1:1 -cdrom /home/marcelo/IOS/microcore-current.iso

But if I connect the host to a router or another device, the qemu process doesn´t start anymore and It doesn't work. I don't know where the problem could be. I tried to connect it directly writing the .net file and starting the topology , but the result is the same.

Any help would very appreciated

Cheers

Marcelo




Top
 Profile  
 
 Post subject: Re: can't connect qemu host to a switch?
PostPosted: Mon Jun 20, 2011 11:58 pm 
I can connect Qemu host to generic switch and ping router.
Ubuntu 64
2.6.32-32
GNS3-0.7.4
Qemu host = nic model virtio


Top
  
 
 Post subject: Re: can't connect qemu host to a switch?
PostPosted: Tue Jun 21, 2011 7:27 am 
Exactly the same issue, and no one seems any closer to an answer on this one. I tried just about every image out there, with no success.

I suppose the answer lies somewhere in how network I/O is redirected ..

Chelo wrote:
Hi, guys

I'm having the same problem using Ubuntu. When the qemu host in not connected, It works fine (running microcore-3.4 ), and I can see the qemu process started:

# ps -aux | grep qemu
root 4725 9.5 4.6 322852 45496 ? SNl 22:23 0:04 /usr/bin/qemu -name QEMU1 -m 256 /home/marcelo/.gns3/Pix2Qemu/working/QEMU1/FLASH -hdb /home/marcelo/.gns3/Pix2Qemu/working/QEMU1/SWAP -net nic,vlan=0,macaddr=00:aa:00:42:24:00,model=e1000 -serial telnet:127.0.0.1:3000,server,nowait -no-acpi -vnc 127.0.0.1:1 -cdrom /home/marcelo/IOS/microcore-current.iso

But if I connect the host to a router or another device, the qemu process doesn´t start anymore and It doesn't work. I don't know where the problem could be. I tried to connect it directly writing the .net file and starting the topology , but the result is the same.

Any help would very appreciated

Cheers

Marcelo


Top
  
 
 Post subject: Re: can't connect qemu host to a switch?
PostPosted: Wed Jul 06, 2011 7:49 pm 
HEY buddy's ,the best and easyest way to figure this problem out ,is to use win xp as GNS 3 host,use it and enjoy...


Top
  
 
 Post subject: Re: can't connect qemu host to a switch?
PostPosted: Wed Jul 06, 2011 8:36 pm 
Offline

Joined: Sun Jun 12, 2011 1:11 am
Posts: 2
Hi cisprime,

You are right. I tried GNS3 with WinXP and qemu works fine.

But I just want to run it under Ubuntu and I´m not finding where the problem is. That makes me crazy :)

Anyway, It´s a very nice toy.

Cheers




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2

All times are UTC


Who is online

Users browsing this forum: Bing [Bot] and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO