It is currently Sat Mar 23, 2019 12:53 pm


All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: GTK error with GNS3 0.7.3 on Ubuntu 10.04
PostPosted: Tue Mar 01, 2011 3:48 pm 
Hi all,

I had a running install of GNS3 0.6.1 on Ubuntu Server 9.04, but when I downloaded and then tried to run GNS3 0.7.3, it complained that my installed version of Qt (4.5.0) was not current enough. When I checked if it could be upgraded, I found that the Qt package 4.5.0 was the lastest one released for that version of Ubuntu. So, I thought, it's time to upgrade the Ubuntu Server OS anyways. So I did, once from 9.04 to 9.10, and then from 9.10 to 10.04 (via use of "do-release-upgrade".)

So now I'm on 10.04, and installed Qt version is 4.6.2. But now when I start GNS3 (either 0.7.3, or the old 0.6.1 version) I get the following errors on the console:

Code:
$ /opt/gns3/GNS3-0.7.3/gns3
QGtkStyle was unable to detect the current GTK+ theme.

(process:1966): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:1966): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

(process:1966): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:1966): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:1966): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:1966): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:1966): GLib-GObject-CRITICAL **: /build/buildd/glib2.0-2.24.1/gobject/gtype.c:2706: You forgot to call g_type_init()

(process:1966): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed

(process:1966): Gtk-CRITICAL **: gtk_widget_style_get: assertion `GTK_IS_WIDGET (widget)' failed


The GNS3 UI does come up, but it is unusable, and I have to kill off the python process to get out of it.

Any way to fix this error, or do I need to save off my labs/images, reinstall 10.04, and put GNS3 0.7.3 back on again?




Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO