It is currently Mon May 29, 2017 1:29 pm


All times are UTC




Post new topic Reply to topic  [ 56 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Patches for Qemu
PostPosted: Wed Nov 09, 2011 5:13 am 
Offline

Joined: Tue Mar 08, 2011 2:25 pm
Posts: 101
The patch for Qemu has been submitted to the qemu-dev mailing list, it's different and cleaner.

About the e1000 patch, it appears it's not needed at all, it may have fixed a bug a few years ago though. The patch for block/raw-w32.c has not been submitted yet, I am not familiar with the issue it is supposed to fix so you will have to wait a few more days to see the patch on qemu-devel.

For those who want to build qemu themselves or don't want to wait for the release, just use this patch: http://lists.gnu.org/archive/html/qemu- ... 00787.html.

Cheers




Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Wed Nov 09, 2011 5:27 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
benjamin: Good job !

OK. This seems to be accepted by Jan.
Just need to follow-up and test with actual (BETA) Qemu.

benjamin: You also wanted "Xen" support in GNS3 -- since Xen is now merged into Qemu -- it may be easier to add now. You're free to try. (probably only HVM will work, not sure about PV)

Note -- this patch differs *significantly* from what we currently use. It means, that this version of Qemu is not supported by existing versions of GNS3, so we will need to patch GNS3.


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Thu Nov 10, 2011 8:33 am 
Offline

Joined: Tue Mar 08, 2011 2:25 pm
Posts: 101
Thanks.

The patch will probably get in the 1.1 branch which opens in December. We have time to integrate that into GNS3, anyway it's on my TODO list and it's really easy. I really liked Qemu, their code and workflow, I didn't know that Xen has been merged into Qemu, I will definitely look more into this soon. Stay tuned on the Redmine.


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Thu Nov 10, 2011 9:36 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
benjamin: try to push the patch into v1.0 branch... (it is not regression-risky)


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Mon Nov 21, 2011 4:00 pm 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
update: (21.11.2011)
The patch is still not accepted by Qemu:
http://fpaste.org/8dSK/


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Mon Dec 19, 2011 2:37 am 
Offline

Joined: Thu Oct 21, 2010 2:04 am
Posts: 9
hey

i'm using ubuntu 11.04 64-bit i have patched Qemu but i still having problem when i connect ASA to switch or Qemu host to switch or router, the Console disappear as if it's still Qemu issue!!

how i can fix this?

thanks in advance


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Mon Jan 02, 2012 5:47 am 
Offline

Joined: Fri Jun 04, 2010 4:45 pm
Posts: 16
Location: San Diego
I apologize for being off topic, but I thought I might find people here (qemu patching users) doing ASA emulation in GNS3. I've not had any responses to my ASA ping problem http://forum.gns3.net/topic4445.html. Thanks.


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Thu Jan 12, 2012 6:09 pm 
Offline

Joined: Tue Mar 08, 2011 2:25 pm
Posts: 101
Sorry, my TODO list is full for now. If someone wishes to help with the project, there's much to do (even if you can't code). Especially concerning documentation and user support. Just send me a PM.



As for Qemu, many users have been following this issue, so I though you might want to know. The new patch got in, except the windows one, but we should test if it's still mandatory, and if it is, we can just include it in the qemu for windows. So users will not have to patch anything whatsoever.
GNS3 is ready to use the new patch for qemu, for now it's optional and can be turned on in qemuwrapper.py, change the value of qemuprotocol to 1 and it will use the new -net socket,id=...,udp=...,localaddr=... syntax (instead of the old -net udp). Moreover, the old -net nic is deprecated and is replaced by -device. There are other problems to solve in the meantime (-net dump, source addr for tunnels, check for patched qemu in the GUI), but this will work.

I'll probably keep gns3 compatible with both versions, detect which one is installed and use the right syntax. Anyways, newer Qemu means less crash, more support and nothing to patch. So I greatly encourage you to install it when it's out.

I'll document how to build and install Qemu correctly since there have been some issues about Qemu configuration/installation. "Soon" you'll be able to use your packaging system to get it.

Here's the commit message: http://git.qemu.org/?p=qemu.git;a=commi ... d09f316c8b (http://code.gns3.net/gns3-devel/rev/3b8976f05281)


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Fri Feb 03, 2012 3:11 pm 
Offline

Joined: Fri Feb 03, 2012 3:00 pm
Posts: 1
I'm using windows and can do simple ASA to router pings. Initially I couldn't and not having used an ASA device before, thought that I needed ACL's and/or something else. In my case, I shut down the ASA and router, deleted the cable, manually added the cable back, turned on ASA and router, and put in these configurations:

ASA1
interface Ethernet0/0
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
no shut

R1
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
no shut

I've tried it on three different new setups and each time if I didn't attached the cable first and then start up it wouldn't work.


Top
 Profile  
 
 Post subject: Re: Patches for Qemu
PostPosted: Fri Feb 17, 2012 1:50 am 
Offline

Joined: Tue Mar 08, 2011 2:25 pm
Posts: 101
Dnard wrote:
I've tried it on three different new setups and each time if I didn't attached the cable first and then start up it wouldn't work.


Attaching the cable first is important. Did you expect to be able to add the cable after the nodes have been started?
This will work for the next next release (0.8.3) though, however adding a NIC will always require a reboot (automatic).




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 56 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO