It is currently Tue Sep 02, 2014 1:59 pm


All times are UTC




Post new topic Reply to topic  [ 10 posts ] 
Author Message
 Post subject: Failed to start Dynamips
PostPosted: Fri Jan 16, 2009 6:14 am 
I followed the installation instructions for Windows XP. Under Preferences->Dynamips, I clicked the ellipsis by executable and there is no bin file in the installation directory. I only see dynamips-wxp.exe so I point it there by when I test, I get "Failed to start Dynamips"




Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Mon Jan 26, 2009 7:05 pm 
I went to the working directory and ran dynamips-start.cmd This launched a DOS window that starting the Dynamips server and everything went well from there on. I did close out the window and tested connectivity to the DB, no problems. I suspect that after a reboot you will have to restart the server since it is not running as a service.


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Tue Apr 21, 2009 6:46 pm 
In Windows XP, Go to the control panel > windows firewall > exceptions > add program. Add GNS3.exe and Dynamips-wxp.exe. Then go to add port and add UDP Port number 7200. Then OK and Reboot.


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Fri Jul 17, 2009 2:26 pm 
I know this is old, but just got the same problem and since nothing from the posts above mine solved it - here is my solution: check your working directory in GNS preferences -> dynamips subcategory. The directory must be already created by you, since dynamips service is CLI based and cannot create directories alone.

Hope that helps!

Kind regards.


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Tue Jul 21, 2009 11:20 am 
gns3: failed to start dynamips - Solved

This is how I solved it.

Added the GNS3 and Dynampis Executables to Windows Firewalls exceptions. Added port UDP 7200 to Firewall Exception. Restarted the Firewall/ICS service from Services.msc.

>Change the preferences path under Dynamips from default to something like “C:\DynampsTemp” (Make sure you create the folder yourself. I think it doesn’t like the Space in this path)

>Then, click the Test Button under Edit > Preferences > Dynamips and see “Dynamips sucessfully started”

Wasted a lot of time fixing this, hope someone sees this later by arriving here through Google and also realise the value of sharing and learning.

God bless.

Take Care,
Zoom


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Mon Feb 01, 2010 9:47 pm 
WOW. Changed the working directory and couldn't start the Dynamips.
It`s happen after working with GNS for more than a year ))

Remember to configure the paths correctly !!!

Thanks to all.


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Tue Feb 16, 2010 7:53 pm 
looks like adding program exception and the port required Admin Privilege.
I didn't got my winpcap installed due to this issue as well.

any available workaround?
if i can get the program exception added into the firewall (somehow), will dynamips still run without winpcap?

thanks


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Wed May 25, 2011 9:09 am 
Hi,

Im a novice as well with GNS3. Ive also been getting the same message every time I drag a router like c2600 in, saying "Hypervisor.. Please test the path to Dynamips in preferences ". What should I do to get it started? Do I need to config something inside my PC?

Thanks, your help is greatly appreciated.. :)


Top
  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Wed Aug 29, 2012 9:40 pm 
Offline

Joined: Wed Aug 29, 2012 9:34 pm
Posts: 1
Thanks sunzoom, the configuration set worked perfect, all i have to do is to download ios image for gns3


Top
 Profile  
 
 Post subject: Re: Failed to start Dynamips
PostPosted: Wed Dec 19, 2012 2:19 pm 
Offline

Joined: Wed Dec 19, 2012 2:08 pm
Posts: 1
Problem:
When trying to drag over a router to create my topology, I was getting the cant connect to hypervisor situation and when I clicked the "test settings" button for dynamips it would come back with "failed to start dynamips" error. All I did was to change the "working directory for dynamips" to c:\dynamips
The default location was going to "c:\users\username\appdata\local\temp\"
I am using windows 7 ultimate 64 with 4GB ram.




This did the trick for me.. thanks to others in this forum and google for leading me into this forum. :-)




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 10 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO