It is currently Sat Dec 07, 2019 5:32 am

All times are UTC

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Get ASA to run in GNS3 on Snow Leopard
PostPosted: Fri Apr 08, 2011 6:08 am 

Joined: Sun May 31, 2009 12:41 pm
Posts: 22
I know... I know... there have been several posts about this subject already.
I've got the basics covered: see ... -gns3-os-x

I'm stuck with the initial start of the ASA.

In the link mentioned above it says:
When you start the ASA you need to run the following commands to start it up:

This is your first boot, please wait about 1 min and then type the following commands:
cd /mnt/disk0

First of all, my ASA doesn't have the lina_monitor file in the /mnt/disk0/ directory, but I'm able to copy the file from the /asa/bin/ directory.

Here's the output of what happens when I run /mnt/disk0/lina_monitor:

# /mnt/disk0/lina_monitor

Processor memory 138174464, Reserved memory: 20971520 (DSOs: 0 + kernel: 20971520)
open /proc/bigphysarea failed, error 2
Failed to open /proc/sys/vm/nr_hugepages for write
Restarting system.
Linux version ([email protected]) (gcc version 4.0.2) #5 PREEMPT Mon May 7 18:35:37 EDT 2007
BIOS-provided physical RAM map:
BIOS-e820: 0000000000000000 - 000000000009f400 (usable)
BIOS-e820: 000000000009f400 - 00000000000a0000 (reserved)
BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
BIOS-e820: 0000000000100000 - 000000000fffd000 (usable)
BIOS-e820: 000000000fffd000 - 0000000010000000 (reserved)
BIOS-e820: 00000000fffc0000 - 0000000100000000 (reserved)
0MB HIGHMEM available.
255MB LOWMEM available.
DMI 2.4 present.
Allocating PCI resources starting at 20000000 (gap: 10000000:effc0000)
Built 1 zonelists
Kernel command line: auto console=ttyS0,9600 bigphysarea=16384 ide1=noprobe
ide_setup: ide1=noprobe
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Initializing CPU#0
PID hash table entries: 1024 (order: 10, 4096 bytes)
Detected 2695.608 MHz processor.
Using tsc for high-res timesource
Console: colour dummy device 80x25
Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
Memory: 178516k/262132k available (1553k kernel code, 82928k reserved, 348k data, 116k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay using timer specific routine.. 5401.98 BogoMIPS (lpj=10803973)
Mount-cache hash table entries: 512
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 4096K
CPU: Intel QEMU Virtual CPU version 0.13.0 stepping 03
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 0k freed
Unpacking initramfs... done
Freeing initrd memory: 12913k freed
NET: Registered protocol family 16
PCI: PCI BIOS revision 2.10 entry at 0xffe77, last bus=0
Setting up standard PCI resources
PCI: Probing PCI hardware
PCI quirk: region b000-b03f claimed by PIIX4 ACPI
PCI quirk: region b100-b10f claimed by PIIX4 SMB
PCI: Using IRQ router PIIX/ICH [8086/7000] at 0000:00:01.0
NET: Registered protocol family 2
IP route cache hash table entries: 2048 (order: 1, 8192 bytes)
TCP established hash table entries: 8192 (order: 3, 32768 bytes)
TCP bind hash table entries: 4096 (order: 2, 16384 bytes)
TCP: Hash tables configured (established 8192 bind 4096)
TCP reno registered
Total HugeTLB memory allocated, 0
bigphysarea: Allocated 16384 pages at 0xe0000000.
Initializing Cryptographic API
io scheduler noop registered
io scheduler anticipatory registered (default)
io scheduler deadline registered
io scheduler cfq registered
Limiting direct PCI/PCI transfers.
PCI: PIIX3: Enabling Passive Release on 0000:00:01.0
Activating ISA DMA hang workarounds.
Serial: 8250/16550 driver $Revision: #2 $ 4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
loop: loaded (max 8 devices)
pcnet32.c:v1.32 18.Mar.2006 [email protected]
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <[email protected]>
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 512KiB
hda: 524288 sectors (268 MB) w/256KiB Cache, CHS=980/255/63
hda: cache flushes supported
hda: unknown partition table
TCP bic registered
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI Shortcut mode
Freeing unused kernel memory: 116k freed
Bummer, could not run '/etc/init.d/rcS': No such file or directory

Please press Enter to activate this console.

Not sure what the first 2 errors at the top mean, but I have a feeling they're not relevant.
What I don't understand is that it cannot find /etc/init.d/rcS, while it's actually in place:

# ls /etc/init.d/
rcS rcS.common

If anyone has come across this issue and fixed it, please share it with me and the rest of this community.

Thanks in advance

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC

Who is online

Users browsing this forum: No registered users and 0 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group