It is currently Fri Dec 19, 2014 3:53 am


All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: GNS3 Labs
PostPosted: Fri Jul 29, 2011 10:30 pm 
Offline

Joined: Fri Jul 29, 2011 10:15 pm
Posts: 3
I've got several issues.

1 - I have a three router (3725) set-up and im trying to set up a serial interface on each using encap frame-relay. I use sub-intefaces on each, i.e.
R1
interface Serial2/0
encapsulation frame-relay
serial restart-delay 0
no shut
!
interface Serial2/0.13 point-to-point
ip address 10.1.13.1 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 103
!
interface Serial2/0.12 point-to-point
ip address 10.1.12.1 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 102
!
interface Loopback1
ip address 192.168.1.1 255.255.255.0
!
ip forward-protocol nd
ip route 192.168.2.0 255.255.255.0 10.1.12.2
ip route 192.168.3.0 255.255.255.0 10.1.13.3

R2
interface Serial2/0
encapsulation frame-relay
serial restart-delay 0
no shut
!
interface Serial2/0.21 point-to-point
ip address 10.1.12.2 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 201
!
interface Loopback2
ip address 192.168.2.2 255.255.255.0
!
ip forward-protocol nd
ip route 10.1.13.0 255.255.255.0 10.1.12.1
ip route 192.168.1.0 255.255.255.0 10.1.12.1
ip route 192.168.3.0 255.255.255.0 10.1.12.1

R3
interface Serial2/0
encapsulation frame-relay
serial restart-delay 0
no shut
!
interface Serial2/0.31 point-to-point
ip address 10.1.13.3 255.255.255.0
snmp trap link-status
frame-relay interface-dlci 301
!
interface Loopback3
ip address 192.168.3.3 255.255.255.0
!
ip forward-protocol nd
ip route 10.1.12.0 255.255.255.0 10.1.13.1
ip route 192.168.1.0 255.255.255.0 10.1.13.1
ip route 192.168.2.0 255.255.255.0 10.1.13.1

however, when I am doing a ping test, I am unable to ping to any interface.

2 - I can use the link button to connect s2/0 to from R1 to R2, but when I try to connect R3 to R1 on s2/0, it won't allow me which makes sense but on my cisco lab in shows the subinterfaces connecting, is there a way I can connect the sub-interfaces?

3 - When I do a show route on R1, I see my routes, on R2 and R3, I do not.

Pretty much I need to know if there are any special set-up I need to do in order to get this working.




Top
 Profile  
 
 Post subject: Re: GNS3 Labs
PostPosted: Sat Jul 30, 2011 5:52 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
Need more information - like your topology file

To show us that, click in the Dynagen management console window.
Then issue a show run command
Now right-click in the Dynagen management console window, and select all
Now right-click in the Dynagen management console window, and copy
Now paste this in your reply.

Better still, download the GNS3-WorkBench and check out the frame relay topologies in the Odom's (and other) Examples Desktop shortcut. If you don't have GNS3 WorkBench, click on the link in my signature.

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 Labs
PostPosted: Mon Aug 01, 2011 2:30 pm 
Offline

Joined: Fri Jul 29, 2011 10:15 pm
Posts: 3
rednectar,

Thanks for your prompt response, attached is the set-up that I am trying to acheive.

Please advise if anything else is needed.


Regards,
Jefferson


Attachments:
img.png
img.png [ 26.98 KiB | Viewed 900 times ]
Top
 Profile  
 
 Post subject: Re: GNS3 Labs
PostPosted: Mon Aug 01, 2011 8:06 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
As you can see from the diagram, R1 (in the middle) has sub-interfaces on S2/0, specifically S2/0. 12 (connected to R2 on the left) and S2/0.13 (connected to R3 on the right). Therefore, we can assume that the connection is a frame-relay connection.

If you don't know how to set up frame-relay, then again, I suggest you download the GNS3-WorkBench and check out the frame relay topologies. The one that matches yours best is the ICND2 EIGRP Frame Relay Exercise. If you don't have GNS3 WorkBench, click on the link in my signature.

FYI, I have included the topology file for the frame-relay example from the GNS3-WorkBench example below:

Code:
autostart = False
[127.0.0.1:7200]
    workingdir = /opt/GNS3/Working
    udp = 10000
    [[3725]]
        image = /opt/GNS3/IOS/c3725-adventerprisek9-mz.124-15.T10.image
        ram = 128
        idlepc = 0x60c05928
        ghostios = True
    [[FRSW FRSW]]
        1:102 = 2:201
        1:103 = 3:301
        2:201 = 1:102
        2:203 = 3:302
        3:301 = 1:103
        3:302 = 2:203
        1 = Belrose s0/0
        2 = Mascot s0/0
        3 = Blacktown s0/0
        x = -96.5
        y = -38.5
        hx = -3.0
        hy = 40.0
    [[ROUTER Blacktown]]
        model = 3725
        console = 2001
        cnfg = configs/Blacktown.cfg
        wic0/0 = WIC-2T
        s0/0 = FRSW 3
        f0/0 = SW3 1
        x = 19.0
        y = 23.0
        hx = -10.0
        hy = 14.0
    [[ROUTER Belrose]]
        model = 3725
        console = 2000
        cnfg = configs/Belrose.cfg
        wic0/0 = WIC-2T
        s0/0 = FRSW 1
        f0/0 = SW1 1
        x = -107.292893219
        y = -172.74011537
        hx = -1.0
        hy = 14.0
    [[ETHSW SW1]]
        1 = access 1 Belrose f0/0
        2 = access 1 NIO_udp:30000:127.0.0.1:20000
        x = -110.792893219
        y = -269.74011537
        hx = 10.0
        hy = 12.0
    [[ETHSW SW3]]
        1 = access 1 Blacktown f0/0
        2 = access 1 NIO_udp:30002:127.0.0.1:20002
        x = 18.5
        y = 132.0
        hx = 10.0
        hy = 12.0
    [[ETHSW SW2]]
        1 = access 1 Mascot f0/0
        2 = access 1 NIO_udp:30001:127.0.0.1:20001
        x = -240.5
        y = 129.0
        hx = 10.0
        hy = 12.0
    [[ROUTER Mascot]]
        model = 3725
        console = 2002
        cnfg = configs/Mascot.cfg
        wic0/0 = WIC-2T
        s0/0 = FRSW 2
        f0/0 = SW2 1
        x = -236.0
        y = 20.0
        hx = 2.5
        hy = 14.0
[GNS3-DATA]
    configs = configs
    workdir = /opt/GNS3/Working
    [[NOTE 1]]
        text = DLCIs:\nBelrose 102 -> Mascot\nBelrose 103 -> Blacktown\nMascot 201 -> Belrose\nMascot 203 -> Blacktown\nBlacktown 301 -> Belrose\nBlacktown 302 -> Mascot
        x = -342.5
        y = -172.5
        color = "#101010"
    [[NOTE 2]]
        text = Fa0/0 192.0.2.30/27
        x = -35.5
        y = -212.5
        color = "#101010"
    [[NOTE 3]]
        text = WAN IPs\nBelrose: DLCI 102         192.168.0.129/30\nBelrose: DLCI 103         192.168.0.133/30\nMascot: DLCI 201         192.168.0.130/30\nMascot: DLCI 203         192.168.0.137/30\nBlacktown: DLCI 301     192.168.0.134/30\nBlacktown: DLCI 302     192.168.0.138/30
        x = -1.0
        y = -172.5
        color = "#101010"
    [[NOTE 4]]
        text = Loopback IPs:\nBelrose:      192.0.2.255/32\nMascot:      192.0.2.254/32\nBlacktown:  192.0.2.253/32
        x = -344.0
        y = -281.5
        color = "#101010"
    [[NOTE 5]]
        text = 192.0.2.65/27
        x = 79.5
        y = 222.5
        color = "#101010"
    [[NOTE 6]]
        text = Fa0/0 192.0.2.62/27
        x = -181.5
        y = 64.5
        color = "#101010"
    [[NOTE 7]]
        text = Fa0/0 192.0.2.94/27
        x = 79.5
        y = 64.5
        color = "#101010"
    [[NOTE 8]]
        text = 192.0.2.33/27
        x = -181.5
        y = 222.5
        color = "#101010"
    [[NOTE 9]]
        text = 192.0.2.1/27
        x = -35.5
        y = -385.5
        color = "#101010"
    [[Cloud PC1]]
        symbol = computer
        x = -107.792893219
        y = -383.24011537
        hx = 13.0
        hy = 6.0
        connections = SW1:2:NIO_udp:30000:127.0.0.1:20000
    [[Cloud PC2]]
        symbol = computer
        x = -237.5
        y = 218.5
        hx = 13.0
        hy = 6.0
        connections = SW2:2:NIO_udp:30001:127.0.0.1:20001
    [[Cloud PC3]]
        symbol = computer
        x = 23.5
        y = 216.5
        hx = 13.0
        hy = 6.0
        connections = SW3:2:NIO_udp:30002:127.0.0.1:20002

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 Labs
PostPosted: Mon Aug 01, 2011 8:37 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
OK I built your config for you: Adjust image and router model to suit your setup.
Code:
Dynagen management console for Dynamips (adapted for GNS3)
Copyright (c) 2008-2010 GNS3 Project

=> show run
autostart = False
[127.0.0.1:7200]
    workingdir = /opt/GNS3/Project/Working
    udp = 10000
    [[3725]]
        image = /opt/GNS3/IOS/c3725-adventerprisek9-mz.124-15.T10.image
        ram = 256
        idlepc = 0x6026b804
        sparsemem = True
        ghostios = True
    [[FRSW FR1]]
        1:102 = 2:201
        1:103 = 3:301
        2:201 = 1:102
        3:301 = 1:103
        1 = R1 s2/0
        2 = R2 s2/0
        3 = R3 s2/0
    [[ROUTER R1]]
        model = 3725
        console = 2000
        wic0/0 = WIC-1T
        wic0/1 = WIC-1T
        wic0/2 = WIC-1T
        slot2 = NM-4T
        s2/0 = FR1 1
    [[ROUTER R2]]
        model = 3725
        console = 2001
        wic0/0 = WIC-1T
        wic0/1 = WIC-1T
        wic0/2 = WIC-1T
        slot2 = NM-4T
        s2/0 = FR1 2
[127.0.0.1:7201]
    workingdir = /opt/GNS3/Project/Working
    udp = 10100
    [[3725]]
        image = /opt/GNS3/IOS/c3725-adventerprisek9-mz.124-15.T10.image
        ram = 256
        idlepc = 0x6026b804
        sparsemem = True
        ghostios = True
        jitsharing = True
    [[ROUTER R3]]
        model = 3725
        console = 2002
        wic0/0 = WIC-1T
        wic0/1 = WIC-1T
        wic0/2 = WIC-1T
        slot2 = NM-4T
        s2/0 = FR1 3
=>

Attachment:
Simple3R-FR.jpg
Simple3R-FR.jpg [ 20.6 KiB | Viewed 892 times ]

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 Labs
PostPosted: Wed Aug 03, 2011 6:20 am 
Offline

Joined: Fri Jul 29, 2011 10:15 pm
Posts: 3
RedNectar,

Thanks, that helped.

I have another Lab that I was trying to simulate, however, I am unable to get it to work.

Please advise on how to set this up as I have to turn in this lab asap. I think I've got the right configs, just unable to get the devices to ping, am I missing a piece? Is this like the frame relay lab where I need another device?

Thanks




Attachments:
img2.png
img2.png [ 56.06 KiB | Viewed 900 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO