It is currently Fri Oct 30, 2020 4:25 am


All times are UTC




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Tue Sep 13, 2011 10:50 pm 
Offline

Joined: Tue Mar 22, 2011 5:22 am
Posts: 9
Greets.

Working with SciLinux 6.1, GNS3 0.8.1 and a patched qemu-0.14.1. I'm having trouble getting qemu to work inside of GNS3.

sequence:

telnet localhost 10525

drag qemu guest named QEMU1 based on linux-microcore-3.8.2.img over to work area
128MB
1 nic
rtl8139 <- is this right?
-no-acpi
use KVM

Right-click on QEMU1, Start.
Right-click on QEMU1, Console

see the following in the QEMU1 console:

Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.

Hit enter a couple of times, cursor moves down a line, otherwise no response.

Watch one of the cores hit 100% and stay there

No action at all in telnet localhost 10525.

extract qemu command line with "ps ax |grep qemu". It's

Code:
/usr/local/bin/qemu -name QEMU1 -m 256 /home/lthomison/GNS3/tmp/QEMU1/FLASH -hdb /home/lthomison/GNS3/tmp/QEMU1/SWAP -enable-kvm -net nic,vlan=0,macaddr=00:00:ab:62:00:00,model=rtl8139 -serial telnet:127.0.0.1:3000,server,nowait -no-acpi


right-click-> stop QEMU1

100% Core drops to zero.

exit GNS3.

Paste qemu QEMU1 command line into bash box.

Code:
$ /usr/local/bin/qemu -name QEMU1 -m 256 /home/lthomison/GNS3/tmp/QEMU1/FLASH -hdb /home/lthomison/GNS3/tmp/QEMU1/SWAP -enable-kvm -net nic,vlan=0,macaddr=00:00:ab:62:00:00,model=rtl8139 -serial telnet:127.0.0.1:3000,server,nowait -no-acpi
Warning: vlan 0 is not connected to host network
VNC server running on `127.0.0.1:5900'


telnet localhost 3000

hit enter, get a tc login prompt.

Not sure what I'm doing wrong or what to do next. Any suggestions?

One thing I do notice that seems a bit weird is shouldn't the line

Quote:
-net nic,vlan=0,macaddr=00:00:ab:62:00:00,model=rtl8139


be -net usb or have something with a usb in it?

Thanks in advance!




Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Tue Sep 13, 2011 10:54 pm 
Offline

Joined: Tue Mar 22, 2011 5:22 am
Posts: 9
BTW, here's where I got the 0.14.1 patches:

download/file.php?id=859

If it matters.


Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Fri Sep 16, 2011 4:55 pm 
Offline

Joined: Tue Mar 22, 2011 5:22 am
Posts: 9
Ok have tried all combinations of:

qemu-0.13.0
qemu-0.14.1
qemu-0.15.0

with

GNS-0.7.3
GNS-0.7.4
GNS-0.8.1

On SciLinux 6.1

Exact same symptoms for all combinations as described above.

I would have tried on ubuntu lucid as well, but the way ubuntu lucid is set up self-compiling qemu is not compatible with the way ubuntu wants to use kvm; I'm not really sure what the problem is but didn't feel like chasing it down.

Thoughts?


Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Mon Sep 19, 2011 10:00 pm 
Offline

Joined: Tue Mar 22, 2011 5:22 am
Posts: 9
I messed around a bit over the weekend, and here's the combo I finally got to work:

GNS3-0.7.4
qemu-0.14.1 (patched)
microcore-linux-3.4.1.img

OS were scilinux 6.1 and ubuntu lucid. Solved previous problem with lucid by manually modprobing kvm -and- kvm-amd.

/sbin/modprobe kvm
/sbin/modprobe kvm-amd

no qemu version worked with GNS3-0.8.1. Same symptoms as described above. I don't know why, nothing suspicious in debug log.


Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Tue Sep 20, 2011 11:03 am 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
joeblow:
>no qemu version worked with GNS3-0.8.1.
huh? but worked on 0.7.4?
try to copy qemuwrapper.py from 0.7.x to 0.8.x and tell us if this helps...

Inside GNS3, you can always use "ver" command to see which wrapper(s) are active.


Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Thu Sep 29, 2011 4:24 am 
Offline

Joined: Tue Mar 22, 2011 5:22 am
Posts: 9
Hi, apologies for the delay.

I copied qemuwrapper.py from /opt/GNS3-0.7.4/qemuwrapper/qemuwrapper.py to /opt/GNS3-0.8.1/qemuwrapper

Code:
~$ sudo cp /opt/GNS3-0.7.4/qemuwrapper/qemuwrapper.py /opt/GNS3-0.8.1/qemuwrapper/

~$ ls -la /opt/GNS3-0.8.1/qemuwrapper/
total 96
drwxrwxrwx  2 gns3 gns3  4096 2011-09-27 19:39 .
drwxrwxrwx 13 gns3 gns3  4096 2011-09-17 11:17 ..
-rwxrwxrwx  1 gns3 gns3   109 2010-12-14 05:52 make-qemuwrapper-exe.py
-rwxrwxrwx  1 gns3 gns3 34153 2011-09-28 20:23 qemuwrapper.py
-rwxrwxrwx  1 gns3 gns3 41685 2011-07-13 09:26 qemuwrapper.py.org
-rwxrwxrwx  1 gns3 gns3    54 2011-05-22 16:04 startqemuwrapper.bat

started /opt/GNS3/gns3.pyw

Code:
~$ /opt/GNS3/gns3.pyw
source_path =  /opt/GNS3/src


then clicked on Preferences -> QEMU -> Test
and got:
Quote:
Failed to start :Qemuwrapper


from within gns3 I couldn't copy the ver output (any clue how to copy it so I can paste it in a document?), but, manually:

GNS3 version is 0.8.1
Qt version is 4.6.2
PyQt version is 4.7.2
SIP version is 4.10.1
Python version is 2.6.5
Dynagen version is 0.13.110507
Hypervisor version(s): <blank> <- big glaring clue here?

and then credits.

What now?

Thanks!



details:

Code:
# ls -la /opt
total 2988
drwxr-xr-x  7 root root    4096 2011-09-28 20:12 .
drwxr-xr-x 33 root root    4096 2011-09-28 17:08 ..
lrwxrwxrwx  1 root root      10 2011-09-28 20:12 GNS3 -> GNS3-0.8.1
-rw-r--r--  1 gns3 gns3 3030109 2010-12-14 09:00 GNS3-0.7.3-src.tar.bz2
drwxr-xr-x 11 gns3 gns3    4096 2011-09-17 18:53 GNS3-0.7.4
drwxrwxrwx 13 gns3 gns3    4096 2011-09-17 11:17 GNS3-0.8.1
drwxrwxrwx 11 gns3 gns3    4096 2011-04-05 17:39 GNS3-7.3


Top
 Profile  
 
 Post subject: Re: qemu-0.14.1 (patched) and GNS3-0.8.1
PostPosted: Thu Sep 29, 2011 2:52 pm 
Offline

Joined: Fri Mar 11, 2011 7:39 pm
Posts: 603
Location: Israel
qemuwrapper.py from 0.7.x should work with GNS3 v0.8.x.

>Hypervisor version(s): <blank> <- big glaring clue here?

After you add some Qemu machines to topology, it will show wrappers and their versions. (including Dynamips, qemuwrapper and vboxwrapper)




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO