It is currently Sat Sep 20, 2014 3:58 pm


All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: DMVPN in framerelay
PostPosted: Fri Jan 27, 2012 9:30 am 
Offline

Joined: Fri Jan 27, 2012 8:16 am
Posts: 2
Topology
Image

R1 Config:

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname DM_VPN
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip cef
!
!
!
no ip domain lookup
!
!
!
crypto isakmp policy 2
encr aes 192
authentication pre-share
group 2
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set DM_TRANS esp-aes esp-sha-hmac
!
crypto ipsec profile CISCO
set security-association lifetime seconds 120
set transform-set DM_TRANS
!
!
!
!
interface Tunnel0
ip address 192.168.1.1 255.255.255.0
no ip redirects
ip mtu 1440
ip nhrp authentication cisco123
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip ospf network broadcast
ip ospf priority 200
tunnel source Serial0/0
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile CISCO
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 131.1.123.1 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 131.1.123.2 102 broadcast
frame-relay map ip 131.1.123.3 103 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 1.1.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


R2 Config:

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
!
!
!
crypto isakmp policy 3
encr aes 192
authentication pre-share
group 2
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set MY_TRANS esp-aes esp-sha-hmac
!
crypto ipsec profile CISCO
set security-association lifetime seconds 120
set transform-set MY_TRANS
!
!
!
!
interface Tunnel0
ip address 192.168.1.2 255.255.255.0
no ip redirects
ip mtu 1440
ip nhrp authentication cisco123
ip nhrp map 192.168.1.1 131.1.123.1
ip nhrp map multicast 131.1.123.1
ip nhrp network-id 1
ip nhrp nhs 192.168.1.1
ip ospf network broadcast
ip ospf priority 0
tunnel source Serial0/0
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile CISCO
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 131.1.123.2 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 131.1.123.1 201 broadcast
frame-relay map ip 131.1.123.3 201 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 2.2.2.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip route 3.3.3.0 255.255.255.0 Tunnel0
!
!
no ip http server
no ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


R3 Config:
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
memory-size iomem 5
ip cef
!!
no ip domain lookup
!
!
!
crypto isakmp policy 3
encr aes 192
authentication pre-share
group 2
crypto isakmp key cisco123 address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set MY_TRANS esp-aes esp-sha-hmac
!
crypto ipsec profile CISCO
set security-association lifetime seconds 120
set transform-set MY_TRANS
!
!
!
!
interface Tunnel0
ip address 192.168.1.3 255.255.255.0
no ip redirects
ip mtu 1440
ip nhrp authentication cisco123
ip nhrp map 192.168.1.1 131.1.123.1
ip nhrp map multicast 131.1.123.1
ip nhrp network-id 1
ip nhrp nhs 192.168.1.1
ip ospf network broadcast
ip ospf priority 0
tunnel source Serial0/0
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile CISCO
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 131.1.123.3 255.255.255.0
encapsulation frame-relay
clock rate 2000000
frame-relay map ip 131.1.123.1 301 broadcast
frame-relay map ip 131.1.123.2 301 broadcast
no frame-relay inverse-arp
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
log-adjacency-changes
network 3.3.3.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.255 area 0
!
ip route 2.2.2.0 255.255.255.0 Tunnel0
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end


Image
Packet capture output
Image


:)



_________________
Your's...........
.................Midhun Kumar


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO