It is currently Tue Dec 10, 2019 3:50 am


All times are UTC




Post new topic Reply to topic  [ 95 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6 ... 10  Next
Author Message
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 1:25 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

The links to download the last test version have been updated (see first post).



_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 5:58 am 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi,

Good work :)

* [Not tested, yet] But should be fixed as well (if not already)
Qemu capture file path must have double quotes
Code:
Before:
-net dump,vlan=0,file=X:\Work Folder\QEMU1_to_R1.cap
After:
-net "dump,vlan=0,file=X:\Work Folder\QEMU1_to_R1.cap"


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 7:55 am 
Offline

Joined: Mon Oct 13, 2008 2:28 pm
Posts: 36
Hi,

I am unable to load attached project file after installing the latest 083 beta.
This lab was saved using the first 083 beta.

Niklas
Code:
GNS3 management console. Running on GNS3 version 0.8.3
Copyright (c) 2006-2012 GNS3 Project
=> ---------Traceback lines (saved in exception.log)----------
Traceback (most recent call last):
  File "GNS3\ProjectDialog.pyo", line 121, in __openProject
  File "GNS3\Workspace.pyo", line 1334, in openFile
  File "GNS3\Workspace.pyo", line 1343, in loadNetfile
  File "GNS3\Workspace.pyo", line 994, in load_netfile
  File "GNS3\NETFile.pyo", line 670, in import_net_file
  File "GNS3\NETFile.pyo", line 472, in apply_gns3_data
IndexError: string index out of range
-----------------------------------------------------------


Attachments:
topology.net [5.35 KiB]
Downloaded 194 times
Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 1:59 pm 
Offline

Joined: Thu Apr 19, 2012 11:23 am
Posts: 31
Hi!

I still get this error message when trying to start.

6/5/12 3:56:06.217 PM GNS3: GNS3 Error
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: ---------Traceback lines (saved in exception.log)----------
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: Traceback (most recent call last):
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "/Applications/GNS3.app/Contents/Resources/__boot__.py", line 60, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "/Applications/GNS3.app/Contents/Resources/__boot__.py", line 57, in _run
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "/Applications/GNS3.app/Contents/Resources/gns3.pyw", line 82, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "GNS3/Main.pyo", line 25, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "GNS3/Application.pyo", line 26, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "GNS3/Dynagen/dynamips_lib.pyo", line 29, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "GNS3/Dynagen/portTracker_lib.pyo", line 28, in <module>
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: File "GNS3/Dynagen/portTracker_lib.pyo", line 40, in portTracker
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: NameError: name 'debug' is not defined
6/5/12 3:56:08.824 PM [0x0-0x7c07c].net.gns3: -----------------------------------------------------------
6/5/12 3:56:08.911 PM com.apple.launchd.peruser.502: ([0x0-0x7c07c].net.gns3[1664]) Exited with code: 255


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 3:57 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

I've updated the links. All 3 last issues reported should have been fixed now.

Cheers,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 05, 2012 6:35 pm 
Offline

Joined: Mon Oct 13, 2008 2:28 pm
Posts: 36
Confirmed, my issue solved.

Thanks

Niklas


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Wed Jun 06, 2012 7:01 pm 
Offline

Joined: Tue Jun 15, 2010 3:19 pm
Posts: 32
I've checked running the ASA with spaces in the project path and that all looks ok now. I've tried both 8.05 and 8.42 images with spaces in the project path and spaces in the image path.

I've now noticed a funny problem with the routers and restarting a project after saving it.
1, Open GNS3, name the project, check both checkboxes.
2, place router on main screen (I've tried 1700 and 2600).
2, configure interface with IP address.
3, wr mem.
4, File > save (in GNS3).
5, stop the topology using red square.
6, start the topology using the green triangle

The router won't start properly.
I've also tried from a blank topology, configuring the router, "save the topology as" (which stops the topology) and then starting from the green triangle and that also doesn't start properly.

If you;
1, stop the topology
2, choose new blank topology
3, open the saved topology
It all works fine.
I don't know if it's always been there but I've just noticed in my testing today. I'm using the 0.8.3 test version which I downloaded today.

if you need any more information please let me know.
Rochey


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Wed Jun 06, 2012 8:46 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi rochey,

This will be fixed officially in GNS3 v0.8.3 release...
Till that moment you must disable "enable sparse memory support" from "GNS3 Properties->Dynamips" to fix it
This bug is present in Dynamips for c1700 and c2600 (not c2691) only :)


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Thu Jun 07, 2012 11:40 am 
Offline

Joined: Sun Apr 25, 2010 4:57 pm
Posts: 214
Thanks for new update.
My probs with updated 0.8.3 are away now.
ASA 8.4, Juniper, PIX, IDS works fine.

Also IMPORTANT that all old topos opening and works fine withot any crash !

just one, it continues from all old releases:
If I close Console window (CRT, PUTTY) on working ASA or Juniper, no way to get it back with working screen. CRT opens, but it is blank., shows that connected but with empty screen...
Maybe it's because console port is busy with previous connection ?...

Jeremy,
is it possible to remove some default routers from left side list, 1700 and 2600 series? I understand that this hardcoded in GNS, but maybe I can do it for self in some way?
Im never used it, just getting lot of crashes and problems.

Uldis


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Fri Jun 08, 2012 7:31 am 
Offline

Joined: Thu Apr 19, 2012 11:23 am
Posts: 31
Hi!

The latest build now starts on my macbook, however seems that the "failed to start VBoxwrapper" issue is back.

Clicking the "Test Settings" or "Refresh VM List" doesn't write anything to /tmp/gns3-vboxwrapper-log.txt

It can be started manually though.

Code:
RFMB:Resources root# python vboxwrapper.py
Log file = /tmp/gns3-vboxcontroller_4_1-log.txt
Log file = /tmp/gns3-vboxwrapper-log.txt
Starting vboxwrapper
debuglevel =  3

class VBoxWrapperRequestHandler
VirtualBox Wrapper (version 0.8.3)
Copyright (c) 2007-2012
Jeremy Grossmann and Alexey Eromenko "Technologov"

vboxwrapper.py    main()
Using VirtualBox 4.1.16 r78094
starting server on host  (port 11525)
VBoxWrapperServer::__init__()
VBoxWrapper TCP control server started (port 11525).
Listening on all network interfaces
VBoxWrapperRequestHandler::handle()
Connection from ('127.0.0.1', 49346)
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request =
VBoxWrapperRequestHandler::check_cache()
cur_time = 1339139993.15, CACHED_TIME = 0.0
cache miss on time
VBoxWrapperRequestHandler::__get_tokens()
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', [])
VBoxWrapperRequestHandler::send_reply(code=200, done=1, msg=At least a module and a command must be specified)
VBoxWrapperRequestHandler::handle_one_request()
[Errno 54] Connection reset by peer
VBoxWrapperRequestHandler::handle()
Connection from ('127.0.0.1', 49347)
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request = vboxwrapper version

VBoxWrapperRequestHandler::check_cache(vboxwrapper version)
cur_time = 1339139993.17, CACHED_TIME = 1339139993.17
cache miss on instruction
VBoxWrapperRequestHandler::__get_tokens(vboxwrapper version)
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', ['vboxwrapper', 'version'])
('handle_one_request(), module = ', 'vboxwrapper', ' command = ', 'version', ' data = ', [])
('handle_one_request(), 1: mname = ', 'do_vboxwrapper_version')
handle_one_request(), if not hasattr success
handle_one_request(), if len(data) success
VBoxWrapperRequestHandler::do_vboxwrapper_version([])
VBoxWrapperRequestHandler::send_reply(code=100, done=1, msg=0.8.3)
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request = vbox version



Ok, checked the permissions and after chmod +x on vboxwrapper.py I get the "Failed to load vboxapi.." again.

Code:
Starting vboxwrapper
debuglevel =  3

class VBoxWrapperRequestHandler
vboxwrapper.py    main()
starting server on host 127.0.0.1 (port 11525)
VBoxWrapperServer::__init__()
VBoxWrapperRequestHandler::handle()
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request =
VBoxWrapperRequestHandler::check_cache()
cur_time = 1339141268.41, CACHED_TIME = 0.0
cache miss on time
VBoxWrapperRequestHandler::__get_tokens()
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', [])
VBoxWrapperRequestHandler::send_reply(code=200, done=1, msg=At least a module and a command must be specified)
VBoxWrapperRequestHandler::handle_one_request()
VBoxWrapperRequestHandler::handle()
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request = vboxwrapper version

VBoxWrapperRequestHandler::check_cache(vboxwrapper version)
cur_time = 1339141268.61, CACHED_TIME = 1339141268.41
cache miss on instruction
VBoxWrapperRequestHandler::__get_tokens(vboxwrapper version)
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', ['vboxwrapper', 'version'])
('handle_one_request(), module = ', 'vboxwrapper', ' command = ', 'version', ' data = ', [])
('handle_one_request(), 1: mname = ', 'do_vboxwrapper_version')
handle_one_request(), if not hasattr success
handle_one_request(), if len(data) success
VBoxWrapperRequestHandler::do_vboxwrapper_version([])
VBoxWrapperRequestHandler::send_reply(code=100, done=1, msg=0.8.3)
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request = vbox version

VBoxWrapperRequestHandler::check_cache(vbox version)
cur_time = 1339141268.61, CACHED_TIME = 1339141268.61
cache miss on instruction
VBoxWrapperRequestHandler::__get_tokens(vbox version)
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', ['vbox', 'version'])
('handle_one_request(), module = ', 'vbox', ' command = ', 'version', ' data = ', [])
('handle_one_request(), 1: mname = ', 'do_vbox_version')
handle_one_request(), if not hasattr success
handle_one_request(), if len(data) success
VBoxWrapperRequestHandler::do_vbox_version([])
VBoxWrapperRequestHandler::send_reply(code=212, done=1, msg=Failed to load vboxapi, please check your VirtualBox installation.)
VBoxWrapperRequestHandler::handle_one_request()
handle_one_request(), request =
VBoxWrapperRequestHandler::check_cache()
cur_time = 1339141268.61, CACHED_TIME = 1339141268.61
cache miss on instruction
VBoxWrapperRequestHandler::__get_tokens()
('VBoxWrapperRequestHandler::__get_tokens(),    returns tokens = ', [])
VBoxWrapperRequestHandler::send_reply(code=200, done=1, msg=At least a module and a command must be specified)
VBoxWrapperRequestHandler::handle_one_request()




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 95 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6 ... 10  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO