It is currently Sat Jul 04, 2020 8:33 pm


All times are UTC




Post new topic Reply to topic  [ 95 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10  Next
Author Message
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Thu Jun 21, 2012 9:50 am 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
* One small issue about starting a Qemuwrapper as external process from the script/cli "qemuwrapper --listen 127.0.0.1 --port 10525"
It is happening every time GNS3 is (re)connecting to it.

Quote:
Qemu Emulator Wrapper (version 0.8.3)
Copyright (c) 2007-2011 Thomas Pani & Jeremy Grossmann

Qemu path (qemu) is valid
Qemu-img path (qemu-img) is valid
Qemu TCP control server started (port 10525).
Listening on 127.0.0.1
Connection from ('127.0.0.1', 11494)
[Errno 10053] An established connection was aborted by the software in your host machine
----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 11494)
Traceback (most recent call last):
File "SocketServer.pyc", line 582, in process_request_thread
File "SocketServer.pyc", line 323, in finish_request
File "SocketServer.pyc", line 640, in __init__
File "SocketServer.pyc", line 693, in finish
File "socket.pyc", line 303, in flush

error: [Errno 10053] An established connection was aborted by the software in your host machine
----------------------------------------
Connection from ('127.0.0.1', 11495)
Shutdown in progress...
Shutdown completed.


* Using the same qemuwrapper and adding a (corrupted) PIX in the topology...
Quote:
Qemu path is now X:\GNS3\qemu.exe
Qemu-img path is now X:\GNS3\qemu-img.exe
Working directory is now X:\GNS3\Work
!! PIX1.console = 3000
!! PIX1.netcard = e1000
!! PIX1.image = X:\Images\PIX\pix721.bin
!! PIX1.ram = 128
!! PIX1.serial = 0x1826ddcd
!! PIX1.key = xxxxxxxx,xxxxxxxx,xxxxxxxx,xxxxxxxx
Command => X:\GNS3\pemu.exe -net nic,vlan=0,macaddr=00:00:ab:a1:ee:00,model=e1000 -net nic,vlan=1,macaddr=00:00:ab:92:23:01,model=e1000 -net nic,vlan=2,macaddr=00:00:ab:7f:9b:02,model=e1000 -net nic,vlan=3,macaddr=00:00:ab:8f:f2
:03,model=e1000 -net nic,vlan=4,macaddr=00:00:ab:ec:62:04,model=e1000 -net nic,vlan=5,macaddr=00:00:ab:22:cc:05,model=e1000 -m 128 FLASH -serial telnet:127.0.0.1:3000,server,nowait
#######################[Pemu output]##########################
Values read from pemu.ini:
Serial = 0x1826ddcd (405200333)
Image = "X:\Images\PIX\pix721.bin"
key = xxxxxxxx,xxxxxxxx,xxxxxxxx,xxxxxxxx
Using Internal BIOS for 0xd8000
Using Internal BIOS for 0xe0000
Image file X:\Images\PIX\pix721.bin read 8202240 bytes, @100000
Unable to find image start address, Aborting
#######################[Wrapper output]##########################
pid: 10112
Setting priority class to BELOW_NORMAL

#######################[GNS3 console output]##########################
11:39:41: DEBUG (1): sending to qemuwrapper at 127.0.0.1:10525 -> qemu start PIX1
11:39:42: DEBUG (1): returned -> ["100-Qemu 'PIX1' started"]
11:41:42: DEBUG (2): Start console program putty.exe -telnet 127.0.0.1 3000 -wt "PIX1 - Console Port [127.0.0.1:3000]" -gns3 2 -skin 3
11:41:42: DEBUG (2): PIX1 has 1 terminal program(s) connected to it

Checking the folder "X:\GNS3\Work\Pix1" there is no "FLASH" file inside.
This is happening because pemu can't create the FLASH file from the pix image (corrupted .bin file) and automatically exits with code 0 (normal, but still error)
The problem is that GNS3 is assuming that the PIX is running ok and is making it green/on :)
So, can you recode qemuwrapper to give the response from "qemu start PIX1" depending on the pemu/qemu output, or if the pemu/qemu process becomes dead immediately after start return a error message instead of "100-Qemu 'PIX1' started".




Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Sat Jun 23, 2012 5:06 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
* Crazy stuff :D
If you have a SW "MAC Address Table" window open and close GNS3 that will remain :))


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jun 26, 2012 7:08 am 
Offline

Joined: Thu May 17, 2012 3:26 pm
Posts: 4
when I am adding second ASA and trying to connect on first asa all is ok (port 3001). Another putty connection to second asa node (port 3002) got error: Network error: Connection refused! (Inactive)


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Fri Jun 29, 2012 4:06 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

I've updated the packages on first page.

Here are the last modifications:

- Support for binding addresses when loading a topology
- GNS3 identifiers are now used as hostnames for Vbox nodes.
- New putty included (post15846.html).
- Track opened consoles in order to close them when deleting a node (as an option).
- IPv6 support (with correct functions).

Cheers,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Sat Jun 30, 2012 3:43 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi,

* I've updated PuTTY -> topic5016.html

* Found a very ugly BUG! :)
- Open GNS3
- Drag a Router
- Drag a Cloud and configure it with a NIO Ethernet (Windows)
- Connect the router to the cloud
- Save as topology .net (no need for projects). Make a backup of this file (b1)!
- Activate "Show interfaces labels" <- this triggers the problem
- Save again + Make a backup (b2)
- Compare the files. There are some "text" elements added after the second save...
- Open the backup file b1. (All good!)
- Clear the topology and open the last saved file. ERROR: GNS3 can't find the NIO specified in the topology file :D
And is asking the user to choose another interface...
Attachment:
nic.jpg
nic.jpg [ 18.54 KiB | Viewed 9225 times ]
If the user is saying Cancel, all is good again :D
But if is answering OK. The problem is getting bigger...
Quote:
GNS3 management console. Running on GNS3 version 0.8.3
Copyright (c) 2006-2012 GNS3 Project

=>
Error in loading .net file:
Parse error in value at line 20.
text = "nio_gen_eth:\device\npf_{2ffce2ae-2192-438f-a880-be382627cf0f}

Press ENTER to continue
(Pressing enter will exit GNS3)
Later comparing the files b2 with last opened file there are some ugly modifications as well...
Quote:
####[ b2 ]####
[GNS3-DATA]
[[NOTE 1]]
text = "nio_gen_eth:\device\npf_{2ffce2ae-2192-438f-a880-be382627cf0f}"

####[ last ]####
[GNS3-DATA]
[[NOTE 1]]
text = "nio_gen_eth:\device\npf_{2ffce2ae-2192-438f-a880-be382627cf0f}
Deleting from that "text" element all " and save/reopen the file it works ...
This has to be introduced from the moment you fixed the # character in notes at my request :)

* Another killer...
Adding a Qemu/Pemu node + plus any other devices on the map and then saving it as topology/project
Then reopening this, will give this error and nothing more.
Quote:
Traceback (most recent call last):
File "GNS3\NETFile.pyo", line 631, in import_net_file
File "GNS3\Dynagen\dynagen.pyo", line 1087, in import_config
File "GNS3\DynagenSub.pyo", line 180, in open_config
File "GNS3\Config\Objects.pyo", line 50, in __getattr__
AttributeError: 'super' object has no attribute '__getattr__'

* For "vbox", in node configurator after dragging a vbox inside the topology:
It has the "VMName/UUID" editable

* The user can change the console/aux port of a node (Router, for Qemu/Pemu/Vbox are already forbidden) and if later is choosing to open the console (telnet to it) GNS3 will open the telnet to the new port which is not used (offline) until that node is restarted.
Quote:
=> list
Name Type State Server Console AUX
R1 2621 running 127.0.0.1:7200 2009 2509

19:46:16: DEBUG (1): sending to dynamips at 127.0.0.1:7200 -> vm set_con_tcp_port R1 9999
19:46:16: DEBUG (1): returned -> ['100-OK']
19:46:16: DEBUG (1): PORT TRACKER: adding port 9999
19:46:16: DEBUG (1): PORT TRACKER: freeing port 2009

19:46:24: DEBUG (2): Start console program putty.exe -telnet 127.0.0.1 9999 -wt R1 -gns3 5
19:46:24: DEBUG (2): R1 has 1 terminal program(s) connected to it (which failed to connect!)

* Deleting a started Pemu/Qemu node which has a link attached to it, is not allowed -> "Qemuwrapper doesn't support hot link removal"
For new users this doesn't means anything that can explain first to stop the node then to delete it :D
Can you change that function to act like this: first to stop the node, second to remove any links and then to delete it?

* Issue related to dynamips binding (new GNS3 with old Dynamips 0.2.8-RC3-x86)
If I change the binding for Dynamips in global settings, you know that the hypervisor part goes ok (with both IPv4/IPv6) but the console is supported from last Dynamips version (not included in all-in-one setup)
If the binding is IPv4 in global settings all goes ok
But if is IPv6 dynamips will still use IPv4 (0.0.0.0) for console/aux, as expected, but GNS3 uses the IPv6 address from binding in PuTTY for telnet connectivity, witch fail :)


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Sat Jun 30, 2012 8:19 pm 
Offline

Joined: Mon Oct 13, 2008 2:28 pm
Posts: 36
I get this error when trying to open attached project with latest 0.8.3

GNS3 management console. Running on GNS3 version 0.8.3
Copyright (c) 2006-2012 GNS3 Project

=> Traceback (most recent call last):
File "GNS3\NETFile.pyo", line 631, in import_net_file
File "GNS3\Dynagen\dynagen.pyo", line 1087, in import_config
File "GNS3\DynagenSub.pyo", line 180, in open_config
File "GNS3\Config\Objects.pyo", line 50, in __getattr__
AttributeError: 'super' object has no attribute '__getattr__'


Attachments:
topology.net [5.49 KiB]
Downloaded 833 times
Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Sat Jun 30, 2012 11:06 pm 
Offline

Joined: Mon Sep 19, 2011 6:19 am
Posts: 192
Location: Australia
SecureCRT error message when using it under Mac OS X.

Image

_________________
ImageImageImageImage


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Sun Jul 01, 2012 7:34 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi,

Khaled wrote:
SecureCRT error message when using it under Mac OS X.

"/T" option is used to open each new session in a new tab instead of new window...
One of the greatest features from this software ;)

For sure, you are using a old version of SecureCRT.
Please check a on-line material (Look for "Tabbed sessions") -> http://www.vandyke.com/products/securecrt/features.html
There is specified for all platforms Win,Linux,MAC
It can't be as a command line option only for windows :D

salkindnul wrote:
I get this error when trying to open attached project with latest 0.8.3

This is duplicate, but thanks for reporting! :)

Cheers!


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jul 03, 2012 3:28 am 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

I have updated the packages (see first post).

Cheers,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: GNS 0.8.3 pre-release testing
PostPosted: Tue Jul 03, 2012 3:38 am 
Offline

Joined: Mon Oct 13, 2008 2:28 pm
Posts: 36
confirmed, solves my issue, thanks.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 95 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO