It is currently Sat Dec 07, 2019 5:20 am


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: ERROR: vboxapi module cannot be loaded
PostPosted: Mon Jun 18, 2012 12:36 pm 
Offline

Joined: Tue Jun 05, 2012 1:44 pm
Posts: 3
I haven’t been able to get my gns3 to work with vbox. My GNS3 version is 0.8.2 and my Vbox is 4.1.16r78094.

I get the following error every time I try to test connectivity between them.

$ python vboxwrapper.py
VirtualBox Wrapper (version 0.8.2)
Copyright (c) 2007-2012
Jeremy Grossmann and Alexey Eromenko "Technologov"

ERROR: vboxapi module cannot be loaded
Please check your VirtualBox installation.


After some research on google I followed the following instructions:

Notes for Mac OS X:
• OSX 10.7 Lion: to use GNS3 with VirtualBox, you must copy a library included in our GNS3 Application to VirtualBox Application. (i.e. /Applications/GNS3.app/Contents/Resources/VBoxPython2.7.so to /Applications/VirtualBox.app/Contents/MacOS/VBoxPython2.7.so)

so, I have renamed the following file VBoxPython2_7.so and copy the GNS3’s version to vbox location:

cd /Applications/VirtualBox.app/Contents/MacOS/
sudo mv VBoxPython2_7.so Backup_VBoxPython2_7.so
sudo cp /Applications/GNS3.app/Contents/Resources/VBoxPython2_7.so .

I restarted the PC with no luck because the same error message is coming up on the terminal and GUI.

Can someone please help me to solve this issue?

Thanks!!!




Attachments:
Screen Shot 2012-06-18 at 8.22.45 AM.png
Screen Shot 2012-06-18 at 8.22.45 AM.png [ 52.86 KiB | Viewed 4559 times ]
Top
 Profile  
 
 Post subject: Re: ERROR: vboxapi module cannot be loaded
PostPosted: Mon Jun 18, 2012 4:26 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

Last VirtualBox version (4.1.16r78094) installs the necessary module. I just did the following test and it works perfectly:

- Install this test version of GNS3 as there is an issue with vboxapi in version 0.8.2 -> topic4942.html
- Download the DMG image, open it and use the provided tool to uninstall the previous version of VirtualBox (check that there is no VirtualBox.app inside Applications folder).
- Install the new version from the DMG.
- Start GNS3 and click on test settings, you should see a successful message.

Cheers,



_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO