It is currently Tue Dec 10, 2019 3:46 am


All times are UTC




Post new topic Reply to topic  [ 33 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Tue Jan 15, 2013 7:06 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi,

Ok, I just test it with Dynagen and works great ;)

First you should get SuperPutty up and running as specified in this topic, then configure "dynagen.ini" with the telnet option as:
Quote:
telnet = start "" "X:\<SuperPutty_Path>\SuperPutty.exe" -telnet "%h -P %p -wt %d"

Note: "-wt" works only if you use my version of Putty. Also you need to adapt SuperPutty installation form GNS3 folder to "C:\Program Files (x86)\Dynamips"

Have Fun!




Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Mon Jan 21, 2013 7:28 am 
Offline

Joined: Wed Dec 26, 2012 9:55 am
Posts: 3
hi still having no luck.
can u please post ur dynagen.ini settings file?

and i assume that superputty should be installed in dynamips folder?

thnks


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Thu Apr 11, 2013 1:23 am 
Offline

Joined: Wed Jun 20, 2012 10:34 am
Posts: 10
tranzitwww wrote:
Command line support for "Super PuTTY" without any AutoHotKey scripts.
This tool has native command line support and works very nice ;)
For portable GNS3 version you will need .NET Framework 2.0 or newer installed on the machine!


Amazing. This is absolutely perfect! Great job!


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Thu Apr 11, 2013 1:25 am 
Offline

Joined: Wed Jun 20, 2012 10:34 am
Posts: 10
gundja wrote:
hi still having no luck.
can u please post ur dynagen.ini settings file?

and i assume that superputty should be installed in dynamips folder?

thnks


I installed mine into the GNS3 folder following the directions provided. I used the SupperPutty GNS version provided as well as the provided settings file, although I bet the settings file within the GNS3 version is already patched. I already had SuperPutty installed, so I deleted the SuperPutty directory in the Documents folder. I ran into some problems (it did nothing when I tried to run inside GNS3), so I manually configured SuperPutty (double clicking it with the GNS3 directory and unchecked "ask this question every time") using the screenshots provided. After manual configuration, it worked like a charm!


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Thu Apr 11, 2013 10:09 am 
Offline

Joined: Tue Dec 28, 2010 5:10 am
Posts: 90
Location: INDIA
hi tranzitwww,

i am facing one issue my super putty is working fine in windows but concosole to routers are opeing as individual window
how can i open all as tab in single window ?

regards
aksplease


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Fri Nov 08, 2013 7:57 pm 
Offline

Joined: Fri Nov 08, 2013 7:53 pm
Posts: 1
im not sure if i missed it or am not understanding the first port but i am running windows 8 and am getting this error below

Image


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Fri Nov 08, 2013 8:09 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
This is not an error. It is a feature. I'm not sure what you would like to have as the desired behaviour, but you can change the way PuTTY starts in GNS3 Preferences | General settings under the [Terminal] tab by changing the Terminal command. Changing this is tricky - but if you read this sample chapter from GNS3 Network Simulator Guide you should get the idea.

[Disclaimer: I am the author of GNS3 Network Simulator Guide]

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Mon Dec 16, 2013 9:47 pm 
Offline

Joined: Mon Apr 22, 2013 12:45 pm
Posts: 2
Does it works with GNS 0.7.4 version.

I am having trouble opening my old topologies files with new GNS. SP was working f9 with new GNS but my topologies aren't, so I am stuck with old one....

ANd, your file on first page """"SuperPutty-for-GNS3.zip"""", is giving error, while opening. So I downloaded the SuperPutty from code.google.........the said version....SuperPutty-1.3.0.11...

Still giving error, unkown option wt...


Attachments:
Unkown.png
Unkown.png [ 141.78 KiB | Viewed 4474 times ]
Setting.png
Setting.png [ 32.8 KiB | Viewed 4474 times ]
GNS.png
GNS.png [ 47.65 KiB | Viewed 4474 times ]
Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Sun Dec 22, 2013 3:59 pm 
Offline

Joined: Thu Jun 24, 2010 3:58 pm
Posts: 411
Location: [email protected]
Hi,
Thats because you have another "putty.exe" in your system PATH, and SuperPuTTY is using that one instead of the patched version from GNS3 installation folder.

You have 2 solutions:
1) Remove/Rename any other putty.exe from your system PATH (You may have one in c:\wndows, I do this at work on remote systems :))
If you still have problems, update putty path in SuperPutty options.
2) Remove -wt, -gns3 and -skin from terminal options (better use the first option!)

Merry Christmas!!!
HO HO HO :))


Top
 Profile  
 
 Post subject: Re: PuTTY Patch - GNS3 Build
PostPosted: Fri Mar 14, 2014 10:10 pm 
Offline

Joined: Fri Mar 14, 2014 9:57 pm
Posts: 1
aksplease wrote:
hi tranzitwww,

i am facing one issue my super putty is working fine in windows but concosole to routers are opeing as individual window
how can i open all as tab in single window ?

regards
aksplease



I have the same issue. Specifically, if I click on the icon to start console sessions to all devices, Superputty works fine, giving a tab to each device. However, if I attempt to manually open a session after that, the session will open in a new standalone putty window and not merely add another tab.

Looking at the superputty log output when I try this, this line seems to indicate the issue:

Warn - ApplicationPanel - Unable to get handle for process on first try

Everything works with respect to connectivity in the console windows, it just doesn't open up tab'bed and superputty seems to indicate that it couldn't grab it for some reason when created.

Any insight appreciated.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 33 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO