It is currently Mon Sep 01, 2014 1:36 pm


All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: can't start Dynamips on port 7200
PostPosted: Thu Feb 19, 2009 10:00 am 
I'm using mac os x v. 10.5.6 on mackbook intel. i installed gns 3, but i loaded the image of c2691 it gave me this error msg "can't start Dynamips on port 7200" i tried to change the port, but still gave me on test "failed to start Dynamips".

the port I used was "8000".

note: I rechecked IOS images and hypervisor, it didn't save my settings. It rested all the fields to a different router model and RAM to "0".

Thanks for help.
Adi




Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Fri Mar 13, 2009 11:00 pm 
hey

I just followed these steps from another thread and it worked (also on MAC OS X ..)

1. Go to the IOS images and hypervisor
2. Go to the external hypervisor tab
3. Add and external hypervisor with the following settings:
- host :127.0.0.1
- port: 7200
- base udp: 10000
- base console 2000
4. Go to the images tab
5. select the image that you want to use and uncheck the @use the hyoervision manager
6. Select the 127.0.0.1:7200 hypervisor


cheers


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Sat Apr 25, 2009 2:45 am 
This was tricky, but I think I finally figured out a way to make it work. Here are the steps I followed. I installed both GNS3 and Dynamips/Dynagen from SourceForge (http://sourceforge.net/project/showfile ... _id=235898).

Before launching GNS3, launch the dynamips server from SourceForge. Then:

1. Under GNS3 Preferences > Dynamips > Dynamips > Executable path, type the path for the dynamips bin file in the package contents.
2. Under GNS3 Preferences > Dynamips > Hypervisor Manager, clear the "Use Hypervisor Manger When Importing" check box
3. Under IOS Images and Hypervisors > IOS Images, double click the image in the image window. This should populate the image filename in the image file window.
4. Click on the External hypervisors button
5. Ensure that the default settings are selected (127.0.0.1, 7200, 10000, 2000)
6. Highlight the settings in the right pane of the window
7. Click the save button
8. Go back to the IOS Images button
9. Clear the "Use the hypervisor manager" check box
10. In the window immediately below that check box, highlight the entry that is there. It should be 127.0.0.1:7200
11. Click the save button

I'm still working out the details of configuration, but I can open a console session from the GUI, which opens in the standard terminal.

It worked for me, that's all I can say.


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Mon Mar 01, 2010 3:50 pm 
In my case, the reason my dynamips test was failing was that the default working directory ( /tmp ) did not seem to allow it to start. I thin I noticed this because when I tried to start the dynamips binary from the command line instead, it complained about not being able to write to a lock file or a log file ( unless I started it with sudo )

I changed the working directory ( within the dynamips config page within GNS3 ) to a tmp directory somewhere under my home directory and I was suddenly able to get a nice green response to clicking that test button.


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Sun Jun 20, 2010 3:07 pm 
Hi,
I am running OS X 10.6.4 on my 2.53 GHz MacBook Pro and have issues with getting GNS3 to start Dynamips.
I have downloaded the Dynamips 0.2.8-RC2 binary for Mac OS X (Intel) package from GNS3.net site, created folders in my home directory for IOS images, Working directory and Projects. In GNS3 under the "GNS3" -> "Preferences" -> "Dynamips" -> "Dynamips" tab -> "Executable path" I have pointed to the Dynamips file I have downloaded previously:
/Users/myname/GNS3_Labs/dynamips-0.2.8-RC2-OSX-Leopard.intel.bin

The "Working directory" under "Dynamips" menu points to existing folder I have created named "Working":
/Users/myname/GNS3_Labs/Working

I have changed directories, "Hypervisor Manage" settings, "Capture" path, basically followed suggestions from previous posts on this issue but still get the same "Can't start Dynamips on port 7200" message.

The questions: Is there something else that needs to be done with Dynamips/Dynagen before starting GNS3 and does the "Executable path" need to be something other than what I have?

Your help is highly appreciated,
Thank you.


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Tue Jul 06, 2010 4:21 pm 
adi wrote:
I'm using mac os x v. 10.5.6 on mackbook intel. i installed gns 3, but i loaded the image of c2691 it gave me this error msg "can't start Dynamips on port 7200" i tried to change the port, but still gave me on test "failed to start Dynamips".

the port I used was "8000".

note: I rechecked IOS images and hypervisor, it didn't save my settings. It rested all the fields to a different router model and RAM to "0".

Thanks for help.
Adi


chmod 777 your bin file to make it executable.


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Wed Jul 21, 2010 7:11 pm 
Can you please help?

I have the same problem i am running OS X 10.6.4 I have been using gns3 on vmware for a while because I came to the conclusion that Dynamips just does not work on MAC OS X.

I have installed gns3.....I have downloaded and placed dynamips in the resources directory and then point gns3 to it but it still doesnt start.

I have changed the file permissions chmod 755 and 777 and 111 still does not start is it just the case that it doesnt work on 10.6.4

Any help would be appreciated or sadly it is back to a windows machine which I have to say in this case is so much easier to install configure and run.

regards

Red


Top
  
 
 Post subject: Re: can't start Dynamips on port 7200
PostPosted: Thu Nov 18, 2010 8:56 pm 
I'm running 10.6.4 and starting dynamips would fail because of incorrect permissions. A soon as I changed permissons to 744, the test through the preference window was successful. I then reverted back to using Hypervisor Manager, that is Use Hypervisor Manager checked on Preferences->Dynamips, and IOS Images and Hypervisor. This fixed the cannot connect to localhost:7200 error I was getting.




Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO