It is currently Thu Feb 25, 2021 7:57 am


All times are UTC




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Router on a stick - can't ping default router (easy fix?)
PostPosted: Mon Sep 17, 2012 1:03 am 
Offline

Joined: Mon Sep 17, 2012 12:46 am
Posts: 1
I'm trying to figure out what's wrong here but all attempts have proved futile so far. The important sections are pasted below and everything is on a c3600 Router, with the switch using the 16 port network module:

R1
Code:
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.2.1 255.255.255.0


SW1
Code:
interface FastEthernet0/0
switchport mode trunk
no ip address
!
interface FastEthernet0/1
switchport access vlan 10
no ip address
!
interface FastEthernet0/2
switchport access vlan 20
no ip address
!


PC1 - times out when pinging R1
Code:
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
ip default-gateway 192.168.1.1
no ip http server
no ip http secure-server
ip classless


PC2
Code:
interface FastEthernet0/0
ip address 192.168.2.2 255.255.255.0
duplex auto
speed auto
!
ip default-gateway 192.168.2.1
no ip http server
no ip http secure-server
ip classless
!



Any help would be appreciated!




Attachments:
help.jpg
help.jpg [ 12.84 KiB | Viewed 5762 times ]
Top
 Profile  
 
 Post subject: Re: Router on a stick - can't ping default router (easy fix?
PostPosted: Wed Sep 26, 2012 3:27 am 
Offline

Joined: Wed Sep 26, 2012 2:33 am
Posts: 2
Hi,

I am going to suggest next time maybe attaching the lab, or a link to somewhere to download it, this will get people (like me) to download it and tinker with it, ultimately bring a solution that we couldn't think of from looking at your configs.

If I get time I will set it up and play with it, as I have a few ideas that come to mind, however with the fact you say PC1 cannot ping but you don't say anything about PC2 leaves it open for people to interpret if PC2 is working or not, at one point I assumed it couldn't but now I think it might, so you need to clarify these things in your question, if it could ping then I would be looking at the individual PC1 problem, as opposed to an overall problem if nothing could ping. (just point this out, dont take it the wrong way as most people do when it comes to criticism in posts).


Top
 Profile  
 
 Post subject: Re: Router on a stick - can't ping default router (easy fix?
PostPosted: Thu Sep 27, 2012 11:16 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
Please post your topology.net file. I want to know what that switch is!!!

If you don't need help any more, please tell ust so no-one else wastes time trying to solve a problem you don't have.

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: Router on a stick - can't ping default router (easy fix?
PostPosted: Sun Feb 17, 2013 4:50 pm 
Offline

Joined: Sun Feb 17, 2013 4:41 pm
Posts: 1
Did you add vlans?? where is your vlan config?


SW1 config

Code:

sw1#sh vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12
10   VLAN0010                         active    Fa1/14
20   VLAN0020                         active    Fa1/15



Code:

sw1#sh run int fa1/13
Building configuration...

Current configuration : 72 bytes
!
interface FastEthernet1/13
switchport mode trunk
no ip address
end

sw1#sh run int fa1/14
Building configuration...

Current configuration : 76 bytes
!
interface FastEthernet1/14
switchport access vlan 10
no ip address
end

sw1#sh run int fa1/15
Building configuration...

Current configuration : 76 bytes
!
interface FastEthernet1/15
switchport access vlan 20
no ip address
end

sw1#





Code:
pc2#ping 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/24/40 ms
pc2#ping 192.168.2.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/28 ms
pc2#ping 192.168.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/43/88 ms
pc2#




Attachments:
topology.net [1.89 KiB]
Downloaded 374 times
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO