It is currently Mon Jun 17, 2019 10:54 pm


All times are UTC




Post new topic Reply to topic  [ 51 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Thu Mar 28, 2013 3:24 am 
Offline

Joined: Thu Mar 28, 2013 2:44 am
Posts: 1
Could you help me please?
I receive this error:
Using argc 3 argv qemu -hda /Users/jeancog84/GNS3/linux-microcore-4.0.2-clean.img
Segmentation fault: 11


Thanks in advance




Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Mon May 06, 2013 11:41 pm 
Offline

Joined: Mon May 06, 2013 11:25 pm
Posts: 5
Hi all, im having some problems compiling Qemu, everything went well until the last part compiling it...can someone give me a hand to figure this out the log is in attach.


Attachments:
File comment: Make log file after patching it.
log.txt [318.14 KiB]
Downloaded 159 times
Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Mon May 06, 2013 11:46 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi,

I strongly recommend using a compiled version of Qemu -> https://sourceforge.net/projects/gns-3/ ... %20OS%20X/

I've always ended up with Qemu crashing when compiling it myself. Jason made these packages and they are stable!

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Tue May 07, 2013 12:03 am 
Offline

Joined: Mon May 06, 2013 11:25 pm
Posts: 5
Thanks its almost working (i think) the only problem now is that is saying that is an "...old and unpatched version of qem...". would appreciate any tips :)...


grossmj wrote:
Hi,

I strongly recommend using a compiled version of Qemu -> https://sourceforge.net/projects/gns-3/ ... %20OS%20X/

I've always ended up with Qemu crashing when compiling it myself. Jason made these packages and they are stable!


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Tue May 07, 2013 2:37 am 
Offline

Joined: Tue Jul 17, 2012 1:34 pm
Posts: 214
Quote:
...old and unpatched version of qemu...

You can disregard the error and qemu should work fine. GNS3 versions below 0.8.4 don't look for the version branding I placed in the code, and are thus unaware of the patches.

Best of luck,
-Jason

_________________
J.Neumann, GNS3 Contributor & Forum Moderator (Minion ID: sin.zx81.1981ad)
Author: Cisco Routers for Small Business (Apress)


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Tue May 07, 2013 1:03 pm 
Offline

Joined: Mon May 06, 2013 11:25 pm
Posts: 5
Jason wrote:
Quote:
...old and unpatched version of qemu...

You can disregard the error and qemu should work fine. GNS3 versions below 0.8.4 don't look for the version branding I placed in the code, and are thus unaware of the patches.

Best of luck,
-Jason


Thanks Jason everything is working...thanks a lot for all the help, big thumbs up.


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Sat Jun 22, 2013 1:31 am 
Offline

Joined: Sat Jun 22, 2013 1:27 am
Posts: 3
Hi there,
I really through I'm flying until I reached the minute 19:58 in the video.
I attached the screenshot with the error I got along the way.
when I type brew install qemu, it fails after overwriting gmp

I did go further and tried to install it but can not do make.


--now put each indivdual patch command into terminal (one at a time not all at the same time)

patch -p1 -i qemu-0.14.1_hw_e1000_c.patch
patch -p1 -i qemu-0.14.1_block_raw-win32_c.patch
patch -p1 -i qemu-0.14.1_Makefile_objs.patch
patch -p1 -i qemu-0.14.1_net_c.patch
patch -p1 -i qemu-0.14.1_net_h.patch
patch -p1 -i qemu-0.14.1_net_udp_c.patch
patch -p1 -i qemu-0.14.1_net_udp_h.patch

- Now configure Qemu with the following

./configure --prefix=/usr/local --disable-sdl --enable-cocoa --disable-docs --target-list="i386-softmmu x86_64-softmmu" --cc=/usr/bin/gcc-4.2 --host-cc=/usr/bin/gcc-4.2

Compile and Install :

make


Attachments:
Screen Shot 2013-06-22 at 02.25.52.png
Screen Shot 2013-06-22 at 02.25.52.png [ 583.49 KiB | Viewed 3516 times ]
Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Sat Jun 22, 2013 1:39 am 
Offline

Joined: Sat Jun 22, 2013 1:27 am
Posts: 3
I did a brew doctor as advised per document and here is the output:

Can you please hep me resolve this ?
I don't even understand this.


Mariusz-Piankas-MacBook-Pro-3:qemu mariuszpianka$ brew doctor
Warning: Some directories in /usr/local/share/locale aren't writable.
This can happen if you "sudo make install" software that isn't managed
by Homebrew. If a brew tries to add locale information to one of these
directories, then the install will fail during the link step.
You should probably `chown` them:

/usr/local/share/locale/be
/usr/local/share/locale/be/LC_MESSAGES
/usr/local/share/locale/el
/usr/local/share/locale/el/LC_MESSAGES

Warning: Some directories in /usr/local/share/man aren't writable.
This can happen if you "sudo make install" software that isn't managed
by Homebrew. If a brew tries to add locale information to one of these
directories, then the install will fail during the link step.
You should probably `chown` them:

/usr/local/share/man/man7

Warning: An outdated version of Git was detected in your PATH.
Git 1.7.10 or newer is required to perform checkouts over HTTPS from GitHub.
Please upgrade: brew upgrade git

Warning: Unbrewed dylibs were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected dylibs:
/usr/local/lib/libMonoPosixHelper.dylib
/usr/local/lib/libmpc.3.dylib
/usr/local/lib/libmpfr.4.dylib
/usr/local/lib/libSFFileMonitor.32.dylib
/usr/local/lib/libSFIPC.32.dylib
/usr/local/lib/libSFIPC.I.dylib
/usr/local/lib/libSFsqlite3.7.4.dylib
/usr/local/lib/libSFSyncEngine.I.dylib

Warning: Unbrewed .la files were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected .la files:
/usr/local/lib/libgmp.la
/usr/local/lib/libmpc.la
/usr/local/lib/libmpfr.la

Warning: Unbrewed static libraries were found in /usr/local/lib.
If you didn't put them there on purpose they could cause problems when
building Homebrew formulae, and may need to be deleted.

Unexpected static libraries:
/usr/local/lib/libmpc.a
/usr/local/lib/libmpfr.a

Warning: Your compilers are different from the standard versions for your Xcode.
If you have Xcode 4.3 or newer, you should install the Command Line Tools for
Xcode from within Xcode's Download preferences.
Otherwise, you should reinstall Xcode.


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Sat Jun 22, 2013 1:48 am 
Offline

Joined: Mon May 06, 2013 11:25 pm
Posts: 5
Hi,

Have you tried this tip from grossmj, i think you're having the same problem that i did.


grossmj wrote:
Hi,

I strongly recommend using a compiled version of Qemu -> https://sourceforge.net/projects/gns-3/ ... %20OS%20X/

I've always ended up with Qemu crashing when compiling it myself. Jason made these packages and they are stable!


Top
 Profile  
 
 Post subject: Re: Installing qemu on 10.8 mountain lion
PostPosted: Sat Jun 22, 2013 9:29 am 
Offline

Joined: Sat Jun 22, 2013 1:27 am
Posts: 3
Thank You for your reply.
I have downloaded both version 0.14 and 0.11.
Checked what's in the install file and set the directories for qemu as per text file.

The ASA image still doesn't start.
When I click test settings it says "You are running and old AND unpatched version of qemu"

Any ideas?




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 51 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO