It is currently Tue Mar 02, 2021 4:14 pm


All times are UTC




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: MPLS with vpn & internet connection
PostPosted: Mon Apr 15, 2013 7:21 pm 
Offline

Joined: Sat Mar 23, 2013 12:17 am
Posts: 2
MPLS for internet & VPN

Image

PE-1#
ip vrf cu1
rd 100:1
route-target export 100:1
route-target import 100:1
route-target import 100:100
!
mpls label protocol ldp
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip vrf forwarding cu1
ip address 61.8.158.1 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
router ospf 1
log-adjacency-changes
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
neighbor 20.20.20.20 remote-as 100
neighbor 20.20.20.20 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
neighbor 20.20.20.20 activate
neighbor 20.20.20.20 send-community extended
exit-address-family
!
address-family ipv4 vrf cu1
redistribute static
neighbor 61.8.158.2 remote-as 65001
neighbor 61.8.158.2 activate
neighbor 61.8.158.2 as-override
neighbor 61.8.158.2 soft-reconfiguration inbound
no synchronization
network 61.8.158.0 mask 255.255.255.252
exit-address-family
!
ip forward-protocol nd
ip route vrf cu1 192.168.1.0 255.255.255.0 61.8.158.2 name FOR-VPN-REDIST-IN-VRF
!
no ip http server
no ip http secure-server
!
mpls ldp router-id Loopback0

@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@22
PE2 #
ip vrf cu1
rd 100:1
route-target export 100:1
route-target import 100:1
route-target import 100:100
!
!
mpls label protocol ldp
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
ip ospf 2 area 0
!
interface FastEthernet0/0
ip vrf forwarding cu1
ip address 61.8.158.5 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.0.0.6 255.255.255.252
ip ospf 2 area 0
duplex auto
speed auto
mpls ip
!
router ospf 2
log-adjacency-changes
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 20.20.20.20 remote-as 100
neighbor 20.20.20.20 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 20.20.20.20 activate
neighbor 20.20.20.20 send-community extended
exit-address-family
!
address-family ipv4 vrf cu1
redistribute static
neighbor 61.8.158.6 remote-as 65002
neighbor 61.8.158.6 activate
no synchronization
network 61.8.158.4 mask 255.255.255.252
exit-address-family
!
ip forward-protocol nd
ip route vrf cu1 192.168.2.0 255.255.255.0 61.8.158.6 name FOR-VPN-REDIST-IN-VRF
!
mpls ldp router-id Loopback0
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@2

INT-GTW#
ip vrf int
rd 100:100
route-target export 100:100
route-target import 100:100
route-target import 100:1
!
mpls label protocol ldp
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
ip ospf 20 area 0
!
interface Loopback1
ip vrf forwarding int
ip address 8.8.8.8 255.255.255.255
!
interface Loopback3
ip vrf forwarding int
ip address 4.2.2.2 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.0.0.9 255.255.255.252
ip ospf 20 area 0
duplex auto
speed auto
mpls ip
!
router ospf 20
log-adjacency-changes
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community extended
exit-address-family
!
address-family ipv4 vrf int
no synchronization
network 4.2.2.2 mask 255.255.255.255
exit-address-family
!
ip forward-protocol nd
ip route vrf int 4.2.2.2 255.255.255.255 Null0
!
mpls ldp router-id Loopback0
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@22

CU1-S1 #
interface FastEthernet0/0
ip address 61.8.158.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.1.254 255.255.255.0
duplex auto
speed auto
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 61.8.158.1 remote-as 100
no auto-summary
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@22
CU1-S2 #
interface FastEthernet0/0
ip address 192.168.2.254 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 61.8.158.6 255.255.255.252
duplex auto
speed auto
!
router bgp 65002
no synchronization
bgp log-neighbor-changes
neighbor 61.8.158.5 remote-as 100
no auto-summary
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@2
PE#
mpls label protocol ldp
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 10.0.0.5 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/1
ip address 10.0.0.2 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
interface FastEthernet1/0
ip address 10.0.0.10 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
mpls ip
!
!
mpls ldp router-id Loopback0




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO