It is currently Fri Apr 10, 2020 9:14 am


All times are UTC




Post new topic Reply to topic  [ 31 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Mon Jul 15, 2013 11:24 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
Thankyou for the report, I have discovered it was an oversight on my part dring the build process! I was building under the UNSTABLE distribution, upon checking the packages.debian.org I have discovered it has a much higher version than wheezy.

I shall rebuild the amd64 and hopefully end up with a lower dependency. (Interestingly, the i386 package does not suffer the same problem and only depends on libc6 (>= 2.7)... very confusing!)



_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Mon Jul 15, 2013 12:04 pm 
Offline

Joined: Sat Jul 28, 2012 2:03 pm
Posts: 54
claydon_dan wrote:
Thankyou for the report, I have discovered it was an oversight on my part dring the build process! I was building under the UNSTABLE distribution, upon checking the packages.debian.org I have discovered it has a much higher version than wheezy.

I shall rebuild the amd64 and hopefully end up with a lower dependency. (Interestingly, the i386 package does not suffer the same problem and only depends on libc6 (>= 2.7)... very confusing!)


Thanks. I will wait them. Will it be GNS3 0.8.4 stable release or GNS3 0.8.4-RC3 again? It will be more attractive to test 0.8.4 stable on Stable Debian 7.1, so users can catch and contribute bugs for you regarding compilation and for general 0.8.4 project regarding it bugs itself


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Thu Jul 18, 2013 5:53 am 
Offline

Joined: Sat Jul 28, 2012 2:03 pm
Posts: 54
claydon_dan
I'am sorry, when GNS3 fixed packages will be available? Thanks in advance.


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Thu Jul 18, 2013 11:00 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
No worries, took a little longer than I had expected due to some issues with the build environment, thankfully all sorted now.

Dynamips 0.2.8 - http://gns3.serverb.co.uk/download/dynamips/0.2.8/
GNS3 0.8.4 - http://gns3.serverb.co.uk/download/gns3/0.8.4/

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Thu Jul 18, 2013 3:58 pm 
Offline

Joined: Sat Jul 28, 2012 2:03 pm
Posts: 54
claydon_dan wrote:
No worries, took a little longer than I had expected due to some issues with the build environment, thankfully all sorted now.

Dynamips 0.2.8 - http://gns3.serverb.co.uk/download/dynamips/0.2.8/
GNS3 0.8.4 - http://gns3.serverb.co.uk/download/gns3/0.8.4/


Thank you! I will begin testing tomorrow morning. By the way, on main page links are still pointing to old version


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Sun Jul 21, 2013 12:28 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
@Daniel

Currently GNS3 depends on xterm to run VPCS and the Tools | Terminal command.

Can xterm be made a dependancy of the GNS3 install so that it gets installed automatically when you install GNS3? Most distors install xterm by default, but Linux Mint doesn't.

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Sun Jul 21, 2013 7:30 pm 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
rednectar wrote:
@Daniel

Currently GNS3 depends on xterm to run VPCS and the Tools | Terminal command.

Can xterm be made a dependancy of the GNS3 install so that it gets installed automatically when you install GNS3? Most distors install xterm by default, but Linux Mint doesn't.


Absolutely, I did look at the dependancy on xterm the other week, to see if it could be made more 'universal'. But soon found out that not all the terminal programs comply with the same command line options.

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Fri Mar 28, 2014 12:59 am 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
@Dan - is there something wrong with the GNS3 ppa?

Yesterday (LInux mint 16 64 bit) I did:
Code:
sudo apt-add-repository ppa:gns3/ppa


then when I downloaded dynamips, gns3 and vpcs I got:

dynamips v0.2.11-amd64/Linux stable
GNS3 v0.8.6
VPCS v0.5b0

Today (Linux Mint 15 32 bit) I did:
Code:
sudo apt-add-repository ppa:gns3/ppa


then when I downloaded dynamips, gns3 and vpcs I got:

dynamips v0.2.8-RC2-x86
GNS3 v0.8.3
VPCS - E: unable to locate package vpcs

I have previously been able to download the latest versions on a similar Linux Mint 15 32 bit, including VPCS v0.5b2 (Which is a little older than v0.5b0 actually)

Am I missing something?

I was about to release GNS3 WorkBench v8.6 (https://sourceforge.net/projects/gns3workbench/files/) as an install script (just 733 lines long), but it depends on getting the latest versions of GNS3, dynamips and VPCS via apt-get install

I've disabled downloads temporarily until this is sorted

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Fri Mar 28, 2014 4:37 pm 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
rednectar wrote:
@Dan - is there something wrong with the GNS3 ppa?

No problems persay...
rednectar wrote:
Yesterday (LInux mint 16 64 bit) I did:
Code:
sudo apt-add-repository ppa:gns3/ppa


then when I downloaded dynamips, gns3 and vpcs I got:

dynamips v0.2.11-amd64/Linux stable
GNS3 v0.8.6
VPCS v0.5b0

Today (Linux Mint 15 32 bit) I did:
Code:
sudo apt-add-repository ppa:gns3/ppa


then when I downloaded dynamips, gns3 and vpcs I got:

dynamips v0.2.8-RC2-x86
GNS3 v0.8.3
VPCS - E: unable to locate package vpcs

I have previously been able to download the latest versions on a similar Linux Mint 15 32 bit, including VPCS v0.5b2 (Which is a little older than v0.5b0 actually)

Am I missing something?

Looking at the table here: http://www.linuxmint.com/oldreleases.php
Linux Mint 15 is based on Ubuntu Raring.... unfortunately support for raring has been dropped from Launchpad (the peril of a 3rd party system!), as support ended in January.

Quote:
I was about to release GNS3 WorkBench v8.6 (https://sourceforge.net/projects/gns3workbench/files/) as an install script (just 733 lines long), but it depends on getting the latest versions of GNS3, dynamips and VPCS via apt-get install

I've disabled downloads temporarily until this is sorted

I have toyed with the idea of creating an apt repository purely just for the GNS3 packages, that would be in our control... unfortunately I have nowhere to host such a service as it would need a VPS/Dedicated Server with shell access.

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 and Dynamips DEB Packages
PostPosted: Tue Apr 01, 2014 6:19 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Hi Daniel,
Quote:
I have toyed with the idea of creating an apt repository purely just for the GNS3 packages, that would be in our control... unfortunately I have nowhere to host such a service as it would need a VPS/Dedicated Server with shell access.


I can give you root access to a VPS.

Can you provide me with a SSH public key?

Thanks,



_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 31 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO