It is currently Wed Jun 28, 2017 10:35 am


All times are UTC




Post new topic Reply to topic  [ 45 posts ]  Go to page 1, 2, 3, 4, 5  Next
Author Message
 Post subject: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Thu Jul 18, 2013 11:48 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
To enable easier installation of gns3 and dynamips, I have created a PPA (Personal Package Archive) on Launchpad. This enables the installation of gns3 etc using a package manager. It will also enable you to upgrade your gns3 installation easily when new versions are released.

The archive contains packages for:
  • Ubuntu 12.04 'Precise'
  • Ubuntu 12.10 'Quantal' (Also supported on Linux Mint 14)
  • Ubuntu 13.10 'Saucy' (Also supported on Linux Mint 16)
  • Ubuntu 14.04 'Trusty' *SUPPORT ADDED*

The following packages are available from the PPA:
  • GNS3 0.8.6
  • Dynamips 0.2.12 *UPDATED*
  • VPCS 0.5b0

Launchpad Link: https://launchpad.net/~gns3/+archive/ppa

To add the GNS3 Launchpad to your system (source: https://launchpad.net/+help-soyuz/ppa-sources-list.html):
If you're using the most recent version of Ubuntu (or any version from Ubuntu 9.10 onwards), you can add a PPA to your system with a single line in your terminal.

Step 1: Open a terminal and enter:
Code:
sudo add-apt-repository ppa:gns3/ppa

Your system will now fetch the PPA's key. This enables your Ubuntu system to verify that the packages in the PPA have not been interfered with since they were built.

Step 2: Now, as a one-off, you should tell your system to pull down the latest list of software from each archive it knows about, including the PPA you just added:
Code:
sudo apt-get update

Now you're ready to start installing software from the PPA!

To install GNS3 and Dynamips:

Step 1: Open a terminal and enter:
Code:
sudo apt-get install dynamips gns3

GNS3 and Dynamips will now download and install.



_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions (apt)
PostPosted: Thu Jul 18, 2013 12:19 pm 
Offline

Joined: Fri Mar 05, 2010 11:33 am
Posts: 1494
Location: Australia
AWESOME! And thanks.

Any progress on vpcs?

_________________
RedNectar
http://rednectar.net
@rednectarchris
GNS3 WorkBench-a VMware image of Ubuntu with GNS3 and VPCS installed and a collection of exercises/labs


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions (apt)
PostPosted: Thu Jul 18, 2013 12:42 pm 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
rednectar wrote:
AWESOME! And thanks.

Any progress on vpcs?


That's quite okay :)

VPCS is next on my list and will be added to the PPA as well.

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Wed Jul 24, 2013 1:56 am 
Offline

Joined: Fri Dec 02, 2011 2:12 pm
Posts: 120
Location: Paris
Cool initiative! Is qemu included in your packages and what version is there?

_________________
A Collection of GNS3 Labs: https://learningnetwork.cisco.com/message/232820
i7 4700MQ quad-core 2.6 Ghz and 16 GB RAM
CCNA - CCDA
Beta Test Team
GNS3 0.8.6 on Windows 7 64 bits
GNS3 0.8.6 on Ubuntu 13.10 and Qemu 1.5.2
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Thu Jul 25, 2013 7:42 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
actionmystique wrote:
Cool initiative! Is qemu included in your packages and what version is there?

Qemu isn't included in the package but I may look at making a Qemu package available (as I'm doing for vpcs). Because of how the software is packaged they have to all be separate, but the gns3 package can reference it.

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Thu Jul 25, 2013 9:20 am 
Offline

Joined: Fri Dec 02, 2011 2:12 pm
Posts: 120
Location: Paris
I've tested all qemu versions with GNS3 on Ubuntu 13.04 up to the last one.
There are issues with all releases from 1.1.1 up to 1.5.1 (ASA crashes).
1.1.0 works, but I had to manually patch it to be able to link it: https://bugs.launchpad.net/qemu/+bug/1193628

_________________
A Collection of GNS3 Labs: https://learningnetwork.cisco.com/message/232820
i7 4700MQ quad-core 2.6 Ghz and 16 GB RAM
CCNA - CCDA
Beta Test Team
GNS3 0.8.6 on Windows 7 64 bits
GNS3 0.8.6 on Ubuntu 13.10 and Qemu 1.5.2
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Sat Jul 27, 2013 9:47 am 
Offline

Joined: Fri Dec 02, 2011 2:12 pm
Posts: 120
Location: Paris
On Ubuntu 13.04 - latest Dynamips version
Great news: qemu 1.5.2 (freshest release http://wiki.qemu.org/Download) works almost like a charm with GNS3 0.8.4 and 2 ASAs!

1) No more crashes!
2) Qemu options for the ASAs:
+ ASA 1: -vnc none -vga none -icount 1
+ ASA 2: -vnc none -vga none -icount 1
+ kernel: -append ide_generic.probe_mask=0x01 ide_core.chs=0.0:980,16,32 auto nousb console=ttyS0,9600 bigphysarea=65536 no-hlt
3) Yet, when started with other devices connected to them and already started, the ASAs see only 5 out of 6 interfaces!

If you want to try it out, you should download the tar.bz2 file and avoid "git fetch": the compilation of those source files leads to errors (7/26)!

_________________
A Collection of GNS3 Labs: https://learningnetwork.cisco.com/message/232820
i7 4700MQ quad-core 2.6 Ghz and 16 GB RAM
CCNA - CCDA
Beta Test Team
GNS3 0.8.6 on Windows 7 64 bits
GNS3 0.8.6 on Ubuntu 13.10 and Qemu 1.5.2
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@


Last edited by actionmystique on Sun Mar 16, 2014 7:17 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Thu Aug 01, 2013 5:08 pm 
Offline

Joined: Thu Nov 18, 2010 7:56 pm
Posts: 9
Hello.
I tried to compile qemu 1.5.2 on Ubuntu 12.04 and got the following error:

[email protected]:/home/xxx/Desktop/qemu-1.5.2# ./configure --target-list=i386-softmmu
Install prefix /usr/local
BIOS directory /usr/local/share/qemu
binary directory /usr/local/bin
library directory /usr/local/lib
libexec directory /usr/local/libexec
include directory /usr/local/include
config directory /usr/local/etc
local state directory /usr/local/var
Manual directory /usr/local/share/man
ELF interp prefix /usr/gnemul/qemu-%M
Source path /home/xxx/Desktop/qemu-1.5.2
C compiler cc
Host C compiler cc
Objective-C compiler cc
CFLAGS -O2 -D_FORTIFY_SOURCE=2 -g
QEMU_CFLAGS -fPIE -DPIE -m32 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wstrict-prototypes -Wredundant-decls -Wall -Wundef -Wwrite-strings -Wmissing-prototypes -fno-strict-aliasing -Wendif-labels -Wmissing-include-dirs -Wempty-body -Wnested-externs -Wformat-security -Wformat-y2k -Winit-self -Wignored-qualifiers -Wold-style-declaration -Wold-style-definition -Wtype-limits -fstack-protector-all -I/usr/include/libpng12 -I$(SRC_PATH)/pixman/pixman -I$(BUILD_DIR)/pixman/pixman -I$(SRC_PATH)/dtc/libfdt
LDFLAGS -Wl,--warn-common -Wl,-z,relro -Wl,-z,now -pie -m32 -g
make make
install install
python python
smbd /usr/sbin/smbd
host CPU i386
host big endian no
target list i386-softmmu
tcg debug enabled no
gprof enabled no
sparse enabled no
strip binaries yes
profiler no
static build no
-Werror enabled no
pixman internal
SDL support yes
GTK support no
curses support yes
curl support no
mingw32 support no
Audio drivers oss
Block whitelist
Mixer emulation no
VirtFS support no
VNC support yes
VNC TLS support no
VNC SASL support no
VNC JPEG support no
VNC PNG support yes
VNC WS support no
xen support no
brlapi support no
bluez support no
Documentation no
NPTL support yes
GUEST_BASE yes
PIE yes
vde support no
Linux AIO support no
ATTR/XATTR support yes
Install blobs yes
KVM support yes
TCG interpreter no
fdt support yes
preadv support yes
fdatasync yes
madvise yes
posix_madvise yes
sigev_thread_id yes
uuid support yes
libcap-ng support no
vhost-net support yes
vhost-scsi support yes
Trace backend nop
Trace output file trace-<pid>
spice support no (/)
rbd support no
xfsctl support no
nss used no
libusb no
usb net redir no
GLX support yes
libiscsi support no
build guest agent yes
seccomp support no
coroutine backend ucontext
GlusterFS support no
virtio-blk-data-plane no
gcov gcov
gcov enabled no
TPM support no
libssh2 support no
TPM passthrough no
QOM debugging yes
[email protected]:/home/xxx/Desktop/qemu-1.5.2# make
GEN config-host.h
(cd /home/xxx/Desktop/qemu-1.5.2/pixman; autoreconf -v --install)
/bin/sh: 1: autoreconf: not found
make: *** [/home/xxx/Desktop/qemu-1.5.2/pixman/configure] Error 127

[email protected]:/home/xxx/Desktop/qemu-1.5.2#

How can I make it work?
Thanks in advance.


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Thu Aug 01, 2013 7:51 pm 
Offline

Joined: Thu Jul 26, 2012 11:19 pm
Posts: 143
Location: U.K.
manuel wrote:
[email protected]:/home/xxx/Desktop/qemu-1.5.2# make
GEN config-host.h
(cd /home/xxx/Desktop/qemu-1.5.2/pixman; autoreconf -v --install)
/bin/sh: 1: autoreconf: not found
make: *** [/home/xxx/Desktop/qemu-1.5.2/pixman/configure] Error 127

[email protected]:/home/xxx/Desktop/qemu-1.5.2#


It looks like you need to install the autoreconf package.

HTH,
Nick.

_________________
GNS3 0.8.4 running on Windows 8.1
GNS3 0.8.4 running on CentOS 6.5


Top
 Profile  
 
 Post subject: Re: GNS3 Launchpad Instructions. Or HOW TO DOWNLOAD .deb pgk
PostPosted: Fri Aug 02, 2013 12:51 pm 
Offline

Joined: Thu Nov 18, 2010 7:56 pm
Posts: 9
I installed autoreconf package and compiled qemu. Everything work fine. I even tried ASA with GNS3 0.8.4 and qemu 1.5.2 (like actionmystique suggested) and it work!. Thanks.




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 45 posts ]  Go to page 1, 2, 3, 4, 5  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO