It is currently Wed Oct 22, 2014 3:09 am


All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: GNS3, Console and 64 bit Vista
PostPosted: Sun Apr 05, 2009 12:55 pm 
Hi,

I cannot console onto anything in GNS3 (0.6). I've checked the terminal command path is correct for 64 bit and enabled Telnet, still no joy. I have putty and Secure CRT but can't get either working!

I trawled through pages of same issue and tried the fixes-nothing fixes it.

Can you give me a hand?

Rich




Top
  
 
 Post subject: Re: GNS3, Console and 64 bit Vista
PostPosted: Thu Apr 09, 2009 11:17 pm 
I had the same problem, on Windows Vista 64 double check to make sure you have the path exactly as listed below a lot of people forget the space it is best to copy the path. Also the first time this runs if you happen to press the keys and bypass the Windows Vista Security warning it will attempt to block the connection you have to select UNBLOCK if you have to hit enter you may have blocked it. Check to make sure Windows Vista Firewall is not blocking

Control Panel > Security > Under Windows Firewall Select allow a program through Windows Firewall verify there is a checkmark next to dynamips-wxp

Verify the Path
Open GSN3
Go under Edit > Preferences
Under the General tab Where it says "Terminal Command"
It will say the following command line:
"C:\Program Files\PuTTY\putty.exe -telnet %h %p"

IT SHOULD SAY
"C:\Program Files (x86)\PuTTY\putty.exe -telnet %h %p"

Because Putty is a 32bit application windows puts it in the C:\Program Files (x86) directory instead of C:\Program Files which is reserved for 64 bit applications
Copy the path "C:\Program Files (x86)\PuTTY\putty.exe -telnet %h %p" without the quotes and paste it in the space that says "Terminal Command" replacing the current command line. Then follow the directions for setting up the telnet client in Windows Vista in the GSN3 Manual.


This fixed my problem with the console error


Top
  
 
 Post subject: Re: GNS3, Console and 64 bit Vista
PostPosted: Sun May 03, 2009 4:04 am 
Hi All-

Need help on this exact issue too, please.

I have copied the path stated in the previous post for putty, though it is still not responding.

I have firewall off, av off, telnet client enabled; can run windows telnet client; putty, securecrt etc, though no matter which one when I try to console into any router in GNS3 the telnet client doesn't return anything; no response. I've tried using a loopback adapter and telnet to that; have moved it from com1 to com2 to com3 etc.

I'm running 64 bit vista; the same situation occurs in vmware using 32 bit win xp as well. The stack is good.

I've tried using different settings in the client as well like vt100 from esc to vt400--same issue.

To summarize:

The telnet client comes up, but does not respond to any key/cmd etc...it's not timing out, it's just not responding---lights are on, but no one is home scenario-

If you have any suggestions, or need further info please let me know. Your help would be really appreciated!

Thanks in advance-


Top
  
 
 Post subject: Re: GNS3, Console and 64 bit Vista
PostPosted: Sun May 03, 2009 4:47 am 
i just posted a thread about this, check it ,, might help you, and please reply on it, so i will be sure it works for others too please..

topic834.html


Top
  
 
 Post subject: Re: GNS3, Console and 64 bit Vista
PostPosted: Mon May 17, 2010 2:32 pm 
What fixed it for me was that I found that I was using too little default RAM for the IOS image. I had it set to 64MB, and it needed to be at least 128MB. The router would not boot without enough RAM, thus causing the Putty session to appear to hang.




Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO