It is currently Tue May 30, 2017 7:16 am


All times are UTC




Post new topic Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Sun Apr 20, 2014 1:18 am 
Offline

Joined: Sun Apr 20, 2014 1:02 am
Posts: 7
Hi there,

I have followed CHP's instruction and been able to start the image without any problems - however the issues start once I am in the prompt at "rrot@%" I try to type in "cli" and after that it just grinds to hold - I can still see the cursor blinking however no further typing is possible. I feel like I am so close to have this working and it's so frustrating when it actually stops right where you can actually start using it...

Anybody experienced something similar? Any advices?

Thank you in advance...




Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Wed Apr 30, 2014 1:46 pm 
Offline

Joined: Tue Apr 30, 2013 9:23 pm
Posts: 12
cole0424 wrote:
This does not work in Windows.



I run it in Ubuntu. Never tried in Windows.


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Wed Apr 30, 2014 1:47 pm 
Offline

Joined: Tue Apr 30, 2013 9:23 pm
Posts: 12
gogers13 wrote:
Hi there,

I have followed CHP's instruction and been able to start the image without any problems - however the issues start once I am in the prompt at "rrot@%" I try to type in "cli" and after that it just grinds to hold - I can still see the cursor blinking however no further typing is possible. I feel like I am so close to have this working and it's so frustrating when it actually stops right where you can actually start using it...

Anybody experienced something similar? Any advices?

Thank you in advance...



When you first boot the vsrx in qemu, without using KVM it will lag big time. After some long load times it will speed up significantly.

Thanks


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Wed Apr 30, 2014 5:16 pm 
Offline

Joined: Sun Apr 20, 2014 1:02 am
Posts: 7
Hi again,

thanks a lot for your reply. I have figured it out - I have actually removed the -smp 2 -device vmxnet3 statement all together and that seemed to do the trick - It no longer slows down after the "cli" comand...

another thing - still cant get two routers connected unfortunately - also, when I configure gig interfaces they dont show up in the config...

one day...


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Thu May 01, 2014 10:28 am 
Offline

Joined: Thu May 01, 2014 10:19 am
Posts: 6
chp wrote:
brezular wrote:
I'm quite sure that Qemu 1.6.1 and 1.7.0rc cannot run vmdk v3 images. What qemu version did you use?

$ qemu-img info junos-vsrx-12.1X44-D10.4-domestic-disk1.vmdk qemu-img: 'image' uses a vmdk feature which is not supported by this qemu version: VMDK version 3
qemu-img: Could not open 'junos-vsrx-12.1X44-D10.4-domestic-disk1.vmdk': Could not open 'junos-vsrx-12.1X44-D10.4-domestic-disk1.vmdk': Wrong medium type


Sorry this is so late...

[email protected]:~$ /usr/local/bin/qemu-system-i386 -version
QEMU emulator version 1.5.0, Copyright (c) 2003-2008 Fabrice Bellard


I am using windows 7, how can I verify the Qemu version?


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Thu May 01, 2014 10:33 am 
Offline

Joined: Thu May 01, 2014 10:19 am
Posts: 6
gogers13 wrote:
Hi there,

I have followed CHP's instruction and been able to start the image without any problems - however the issues start once I am in the prompt at "rrot@%" I try to type in "cli" and after that it just grinds to hold - I can still see the cursor blinking however no further typing is possible. I feel like I am so close to have this working and it's so frustrating when it actually stops right where you can actually start using it...

Anybody experienced something similar? Any advices?

Thank you in advance...


Are you using Windows and are you running it on gns3? I can't get it work on Windows 7 running gns3, only works on wmware player & workstation. Please help!


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Thu May 01, 2014 10:49 am 
Offline

Joined: Sun Apr 20, 2014 1:02 am
Posts: 7
Hi,

I'm using windows 8.1 and latest version of gns3. I don't know where exactly it fails for you? Make sure you use the image created by VMPlayer - so go to your virtual machines location, copy the VMDK file and paste to your gns3 location. Then make sure that you specify the path to the pasted image in gns3 under preferences/qemu/Junos

I hope this helps...


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Sat May 03, 2014 3:26 am 
Offline

Joined: Thu May 01, 2014 10:19 am
Posts: 6
gogers13 wrote:
Hi,

I'm using windows 8.1 and latest version of gns3. I don't know where exactly it fails for you? Make sure you use the image created by VMPlayer - so go to your virtual machines location, copy the VMDK file and paste to your gns3 location. Then make sure that you specify the path to the pasted image in gns3 under preferences/qemu/Junos

I hope this helps...


I did exactly what you mentioned but when I start Juniper router on gns3 Qemu works only without the Qemu Options: -smp 2 -device vmxnet3 and I did not see any working interfaces.


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Sat May 03, 2014 9:01 am 
Offline

Joined: Sun Apr 20, 2014 1:02 am
Posts: 7
Hi,

so you got to the same point that I have - I am still not able to connect two routers together in GNS3 using the firefly image - you can still edit interfaces:
[edit]
root# edit interfaces ge-0/0/0

[edit interfaces ge-0/0/0]

however they will not show up when you do "show interfaces terse" - hopefully one day...

Sorry I could not help any further though


Top
 Profile  
 
 Post subject: Re: vSRX Firefly on GNS3
PostPosted: Thu May 08, 2014 4:28 am 
Offline

Joined: Thu May 01, 2014 10:19 am
Posts: 6
For those who got it working with physical interfaces shown, can anyone share the image junos-vsrx-12.1X44-D10.4-domestic-disk1.vmdk? As I got it working on Qemu and on vmware player but still no physical interface shown when I did a Show interface terse.

Thanks in advance!




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 35 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO