It is currently Sat Apr 20, 2019 4:33 pm


All times are UTC




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: CDP nei not shown on the virtual router
PostPosted: Fri Dec 13, 2013 4:53 pm 
Offline

Joined: Fri Dec 13, 2013 4:43 pm
Posts: 3
hi
i followed the topology presented in QinQ however something is not working correctly. From the real switch i can see the virtual router as a neighbor however on the virtual router i cant see anything. any advise/help would be much appreciated. i am using a 3570 as breakout

thanks


Switch-1#sh cdp n
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID Local Intrfce Holdtme Capability Platform Port ID
R3 Fas 0/1 137 R S I 2691 Fas 0/0
Switch-1#sh cdp n d
-------------------------
Device ID: R3
Entry address(es):
IP address: 10.1.1.1
Platform: Cisco 2691, Capabilities: Router Switch IGMP
Interface: FastEthernet0/1, Port ID (outgoing port): FastEthernet0/0
Holdtime : 133 sec

Version :
Cisco IOS Software, 2600 Software (C2691-ADVENTERPRISEK9-M), Version 12.4(25d), RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Wed 18-Aug-10 05:35 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Duplex: full
Management address(es):

Switch-1#

R3#sh run int f0/0
Building configuration...

Current configuration : 92 bytes
!
interface FastEthernet0/0
ip address 10.1.1.1 255.255.255.0
speed 100
full-duplex
end

R3#
R3#sh cdp n
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID
R3#




Top
 Profile  
 
 Post subject: Re: CDP nei not shown on the virtual router
PostPosted: Fri Dec 13, 2013 10:24 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
Quote:
i am using a 3570 as breakout


Please post the config for this breakout switch. CDP must be tunneled.

Regards,

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: CDP nei not shown on the virtual router
PostPosted: Mon Dec 16, 2013 9:46 am 
Offline

Joined: Fri Dec 13, 2013 4:43 pm
Posts: 3
Hi Jeremy.
thanks for coming back. below are the configs for switch -1 and the breakout switch. although i can see the router (including details) on the real switch the router doesn't pick it up. pings also fail as expected.

R3#sh cdp
Global CDP information:
Sending CDP packets every 60 seconds
Sending a holdtime value of 180 seconds
Sending CDPv2 advertisements is enabled
R3#
R3#
R3#

Switch-1#
Switch-1#sh run
Building configuration...

Current configuration : 3232 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch-1
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
system mtu routing 1500
vtp domain mydomain
vtp mode transparent
authentication mac-move permit
ip subnet-zero
no ip domain-lookup
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 101
!
!
!
interface FastEthernet0/1
description ## Link to Router-1 ##
switchport mode access
spanning-tree portfast
!

interface Vlan1
ip address 10.1.1.254 255.255.255.0
!
ip classless
ip http server
ip http secure-server
!
ip sla enable reaction-alerts
!
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end

Switch-1#


Breakout#
Breakout#
Breakout#sh run
Building configuration...

Current configuration : 2135 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Breakout
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts
system mtu routing 1500
vtp mode transparent
ip subnet-zero
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
vlan 101-102
!
!
!
!
interface GigabitEthernet1/0/1
description Down to SW1 f0/1
switchport access vlan 101
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet1/0/2
description Down to SW2 f0/1
switchport access vlan 102
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
spanning-tree portfast
!
!
interface GigabitEthernet1/0/24
description Up to PC interface
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 101-104
switchport mode trunk
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
spanning-tree portfast
!
!
interface Vlan1
no ip address
shutdown
!
ip classless
ip http server
ip http secure-server
!
!
!
control-plane
!
!
line con 0
line vty 0 4
login
line vty 5 15
login
!
end

Breakout#sh ver
Cisco IOS Software, C3750 Software (C3750-ADVIPSERVICESK9-M), Version 12.2(40)SE, RELEASE SOFTWARE (fc3)
Copyright (c) 1986-2007 by Cisco Systems, Inc.
Compiled Fri 24-Aug-07 00:56 by myl
Image text-base: 0x00003000, data-base: 0x01700000

ROM: Bootstrap program is C3750 boot loader
BOOTLDR: C3750 Boot Loader (C3750-HBOOT-M) Version 12.1(14r)EA1a, RELEASE SOFTWARE (fc1)

Breakout uptime is 33 minutes
System returned to ROM by power-on
System image file is "flash:c3750-advipservicesk9-mz.122-40.SE/c3750-advipservicesk9-mz.122-40.SE.bin"


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
[email protected].

cisco WS-C3750G-24TS (PowerPC405) processor (revision F0) with 118784K/12280K bytes of memory.
Processor board ID CAT0836R0SW
Last reset from power-on
1 Virtual Ethernet interface
28 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:12:00:E4:44:80
Motherboard assembly number : 73-7058-10
Power supply part number : 341-0045-01
Motherboard serial number : CAT08350K56
Power supply serial number : LIT0829050X
Model revision number : F0
Motherboard revision number : A0
Model number : WS-C3750G-24TS-S
System serial number : CAT0836R0SW
Hardware Board Revision Number : 0x09


Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 28 WS-C3750G-24TS 12.2(40)SE C3750-ADVIPSERVICESK


Configuration register is 0xF

Breakout#


Top
 Profile  
 
 Post subject: Re: CDP nei not shown on the virtual router
PostPosted: Mon Dec 16, 2013 11:55 am 
Offline

Joined: Thu Jul 26, 2012 11:19 pm
Posts: 143
Location: U.K.
Try increasing system MTU on the breakout switch as per http://www.gns3.net/articles/ccie-routing-switching-lab/qinq-with-virtual-switch-option/
Code:
system mtu 1998

_________________
GNS3 0.8.4 running on Windows 8.1
GNS3 0.8.4 running on CentOS 6.5


Top
 Profile  
 
 Post subject: Re: CDP nei not shown on the virtual router
PostPosted: Mon Dec 16, 2013 2:20 pm 
Offline

Joined: Fri Dec 13, 2013 4:43 pm
Posts: 3
changing the MTU doesn't help
Breakout#
Breakout#show sy
Breakout#show system mtu

System MTU size is 1998 bytes
System Jumbo MTU size is 1998 bytes
Routing MTU size is 1500 bytes
Breakout#
Breakout#

the real switch can still see the neighbor where the virtual router cant.

cheers




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO