It is currently Wed Oct 21, 2020 4:58 am


All times are UTC




Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Fri Jan 24, 2014 5:53 am 
Offline

Joined: Tue Dec 28, 2010 5:10 am
Posts: 90
Location: INDIA
Dear jermy /team ,

can some thing be done to fix the bug of duplex mismatch messsge coming in router again and again

regards
aksplease




Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Fri Jan 24, 2014 10:42 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
I'm not sure if anything can be done to 'fix' the duplex with regards to Dynamips (due to the lack of a physical layer), but you can get rid of the messages by forcing the duplex on the interface using:
Code:
duplex full

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Fri Jan 24, 2014 7:37 pm 
Offline
Site Admin

Joined: Sat Oct 11, 2008 1:41 pm
Posts: 2668
Location: Canada
There is also this command that globally disables the messages.

Code:
no cdp log mismatch duplex


By the way, why not adding it to our default startup-config?

_________________
Jeremy, GNS3 Programmer & Benevolent Dictator for Life.


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Wed Mar 26, 2014 10:03 am 
Offline

Joined: Wed May 22, 2013 7:48 am
Posts: 93
Location: Portugal
What router model(s) and hardware was being used? Could be a bug in the emulation of a particular device, dunno.

PS- This error hasn't happened to me yet

_________________
Dynamips maintainer and sporadic developer
https://github.com/GNS3/dynamips


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Wed Mar 26, 2014 12:28 pm 
Offline

Joined: Sat Aug 17, 2013 7:59 pm
Posts: 123
Location: Upper Silesia, Poland
It happened me quite often (always?) with 3640 and NM-4E card (with several IOSes used). Don't remember if 3660 routers has the same issue.
Of course, forcing both interfaces connected to full (or both to half) duplex fixed the problem without need to force CDP to ignore duplexes ("no cdp log mismatch duplex").

_________________
If you can see any inaccuracies or other language-related mistakes in my post(s), please forgive me - English is not my native language


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Wed Mar 26, 2014 3:59 pm 
Offline

Joined: Wed May 22, 2013 7:48 am
Posts: 93
Location: Portugal
3640 with NM-4E uses dev_am79c971 (AMD Am79c971 chip) of type 10baseT.
Now I have something to focus on. =)

If it's a hardware emulation bug then the IOS version shouldn't matter, what matters is what hardware is connecting to what hardware.
So... a 3640 with NM-4E connected to what?

_________________
Dynamips maintainer and sporadic developer
https://github.com/GNS3/dynamips


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Wed Mar 26, 2014 6:03 pm 
Offline

Joined: Sat Aug 17, 2013 7:59 pm
Posts: 123
Location: Upper Silesia, Poland
Case 1: Two 3640 routers, both equipped with NM-1FE-TX in slot 0 and NM-4E in slot 1. Do "no shutdown" on all interfaces. Do "sh run int f0/0" and "sh run int e1/0" on both routers - you will see defaults, which is: full autonegotiation on F0/0 and 10/Half on E1/0.
Connect E1/0 to other router, also to E1/0 - no problem, since both interfaces are 10/half.
Connect F0/0 on one router to E1/1 on other router - you will see duplex mismatch messages: "%CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on Ethernet1/1 (not full duplex), with R2 FastEthernet0/0 (full duplex)."

Case 2: 3640 connecting to Etherswitch router - with default configuration of all ports on EtherSwitch routers (which is 100/FD without autonego) - but we all know that it WILL cause these messages. With all port on switch set to full autonego I do not see duplex mismatch messages. 3640 E2/0 Connected to router 3725 F0/0 (set to auto/auto): all OK.

Case 3: 3640 E2/0 (10/HD) connected to 3660 F0/0 (auto/auto) - duplex mismatch; 3640 E2/0 <==> 3660 F1/0 (added card to slot 1) - duplex mismatch; 3640 E2/0 to 3660 E2/0 - all OK (both ifaces are 10/HD, ao it has to be OK); 3640 E2/0 to 3660 FastEth 3/15 on NM-16ESW (set to auto/auto): all ok

IOSes tested:
- c3640-telco-mz.124-13
- c3660-jk9o3s-mz.124-18
- c3725-adventerprisek9-mz.124-15.T14

Hope this will help - and it would be good if anyone can confirm that (maybe even with other IOSes)

P.S.
Personally I don't think it is a big problem, as in real life I expected MANY situations when I had to change duplexes on interfaces :)

_________________
If you can see any inaccuracies or other language-related mistakes in my post(s), please forgive me - English is not my native language


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Thu Mar 27, 2014 1:00 am 
Offline

Joined: Wed May 22, 2013 7:48 am
Posts: 93
Location: Portugal
Thanks, I can reproduce it. =)
Broadly speaking, it's when you connect ethernet to/from fast ethernet.

This issue being fixable or not depends on how IOS detects the duplex mismatch. (fingers crossed)

_________________
Dynamips maintainer and sporadic developer
https://github.com/GNS3/dynamips


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Thu Mar 27, 2014 9:52 am 
Offline

Joined: Sun Sep 16, 2012 9:55 pm
Posts: 541
Location: England
flaviojs wrote:
Thanks, I can reproduce it. =)
Broadly speaking, it's when you connect ethernet to/from fast ethernet.

This issue being fixable or not depends on how IOS detects the duplex mismatch. (fingers crossed)

Hi flaviojs,

Probably more difficult for you to reproduce... but it also occurs when you connect a FastEthernet interface out to the real world. I can easily reproduce the issue here, so if there's anything I can do to assist... please say!

_________________
Daniel
Forum Moderator & Debian Package Maintainer for GNS3, Dynamips & VPCS.
Standalone DEB Packages are available from http://gns3.serverb.co.uk - To be updated!


Top
 Profile  
 
 Post subject: Re: DUPLEX MISMATCH BUG MESSEAGE
PostPosted: Sat Mar 29, 2014 10:24 pm 
Offline

Joined: Wed May 22, 2013 7:48 am
Posts: 93
Location: Portugal
Unfortunately it's getting the info from network packets of the cdp protocol. (for more details search for 'duplex' in this page)

But there is still hope...
Even if it's the same code, for some unknown reason the 10Mbit interfaces default to half-duplex and the 100Mbit interfaces to full-duplex.
If I can get it to change to full-duplex (with fake auto-negotiation?) then it won't be a problem.
This depends on how the device driver for the device is coded inside IOS.
It might be expecting something that's missing from the emulation and using a safe default instead. Fingers crossed. =~~



_________________
Dynamips maintainer and sporadic developer
https://github.com/GNS3/dynamips


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 19 posts ]  Go to page 1, 2  Next

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO