I hope you are doing great;
Has some one face the following error message:
$ gns3GNS3 GUI version 1.0a2.dev1
Copyright (c) 2007-2014 GNS3 Technologies Inc.
---------Traceback lines (saved in exception.log)----------
Traceback (most recent call last):
File "/usr/local/bin/gns3", line 9, in <module>
load_entry_point('gns3-gui==1.0a2.dev1', 'console_scripts', 'gns3')()
File "/usr/local/lib/python3.2/dist-packages/gns3_gui-1.0a2.dev1-py3.2.egg/gns3/main.py", line 60, in main
raise RuntimeError("Python 3.3 or higher is required")
RuntimeError: Python 3.3 or higher is required
-- I already installed python 3.4 but I still get the same error when trying to start the gns3server and gns3.
I'm running ubuntu 12.04 64 bits, I am not totally new to linux but I am not a master.
If you can help me I would really appreciate it.
This happens because the Python3 package (and I would assume all associated packages, such as python3-pyqt4, etc.) for Ubuntu 12.04 is actually Python3.2.something. So, even if you had managed to get the Python3.4 or 3.3 package from somewhere (it's not in the default package repository afaik) and install it, then you would still need to find the correct additional packages that are made for python3.4 or 3.3 and then instead of typing "python3" for the commands in the guide, you would need to do "python3.4" or "python3.3" (depending on which one you installed). Otherwise, you end up with everything still using Python 3.2.whatever.