It is currently Mon Nov 18, 2019 10:31 pm


All times are UTC




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 11:22 am 
Hi,

I have an issue with a gre tunnel. I have a simple topology with 2 routers and I am trying to create a simple gre tunnel from 1 router to another router. The routers are able to ping each other with their interfaces which are connected directly. running sh ip int bri shows the tunnel as up/down.

Here is a sinipet of the running config:
Router1:
interface Tunnel0
ip address 10.0.2.1 255.255.255.0
keepalive 10 10
tunnel source FastEthernet0/0
tunnel destination 172.16.1.2
!
interface FastEthernet0/0
ip address 10.0.1.1 255.255.255.0
duplex half
!
interface FastEthernet1/0
ip address 172.16.1.1 255.255.255.0
duplex half
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0

Router2:
interface Tunnel0
ip address 10.0.2.2 255.255.255.0
keepalive 1 5
tunnel source FastEthernet1/0
tunnel destination 172.16.1.1
!
interface FastEthernet0/0
ip address 172.16.1.2 255.255.255.0
duplex full
!
interface FastEthernet1/0
ip address 10.0.3.2 255.255.255.0
duplex half
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 10.0.0.0 0.0.0.255 area 0
!




Top
  
 
 Post subject: Re: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 1:57 pm 
Offline

Joined: Thu Mar 25, 2010 3:19 am
Posts: 2
Hi,
you have keepalive mismatch.

On Router1 you set keepalive interval to 10 seconds and 10 retries, and on Router 2 keepalive period is 1 seconds, with five retries.

So, 5 seconds after you set up GRE, tunnel is down.

Just set keepalive timer to the same values,or turn off keepalives on both interfaces.

Regards


Top
 Profile  
 
 Post subject: Re: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 2:28 pm 
Hi,

I tried changing the keepalive values to match, I also tried removing them but still got the same issue.

Thanks for the ideas


Top
  
 
 Post subject: Re: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 2:52 pm 
Offline

Joined: Mon Oct 13, 2008 11:26 am
Posts: 817
Location: Finland
You have wrong tunnel sources/destinations. Double check them.

_________________
Br,
Kaage
Image Image


Top
 Profile  
 
 Post subject: Re: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 3:01 pm 
Hi,

I have checked the tunnel interfaces and sources again and they look right to me.

could you tell me what they should be?

Thanks
Daniel


Top
  
 
 Post subject: Re: GRE tunnel issue
PostPosted: Mon Mar 29, 2010 3:26 pm 
Thanks Kaage, you where right.

After a bit of playing round with it i found that the source interfaces where the opposite of what I thought they should be.




Top
  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO