It is currently Sun Sep 20, 2020 11:04 pm


All times are UTC




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: qemu issue after upgrade
PostPosted: Wed Jun 08, 2011 4:42 pm 
Offline

Joined: Wed Apr 27, 2011 8:40 pm
Posts: 50
asa or ids won't console after upgrade, using gns3 0.8 beta3 on ubuntu 11.04 64 bit.
if run from command-line everything works fine.
this is output from qemuwrapper console


:/opt/GNS3/qemuwrapper$ sudo python ./qemuwrapper.py
Qemu Emulator Wrapper (version 0.8.0)
Copyright (c) 2007-2011 Thomas Pani & Jeremy Grossmann

Qemu TCP control server started (port 10525).
Listenning on all network interfaces
Connection from ('127.0.0.1', 33542)
----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 33542)
Traceback (most recent call last):
File "/usr/lib/python2.7/SocketServer.py", line 582, in process_request_thread
self.finish_request(request, client_address)
File "/usr/lib/python2.7/SocketServer.py", line 323, in finish_request
self.RequestHandlerClass(request, client_address, self)
File "/usr/lib/python2.7/SocketServer.py", line 641, in __init__
self.finish()
File "/usr/lib/python2.7/SocketServer.py", line 694, in finish
self.wfile.flush()
File "/usr/lib/python2.7/socket.py", line 303, in flush
self._sock.sendall(view[write_offset:write_offset+buffer_size])
error: [Errno 32] Broken pipe
----------------------------------------
Connection from ('127.0.0.1', 33548)
Shutdown in progress...
Shutdown completed.
!! ASA2.console = 3000
!! ASA2.kernel = /opt/images/asa805.kernel
!! ASA2.netcard = e1000
!! ASA2.ram = 512
!! ASA2.kernel_cmdline = console=ttyS0,9600n8 bigphysarea=16384 auto nousb ide1=noprobe hda=980,16,32
!! ASA2.initrd = /opt/images/asa805_cpio.gz
!! ASA2.options = -hdachs 980,16,32
!! ASA1.console = 3001
!! ASA1.kernel = /opt/images/asa805.kernel
!! ASA1.netcard = e1000
!! ASA1.ram = 512
!! ASA1.kernel_cmdline = console=ttyS0,9600n8 bigphysarea=16384 auto nousb ide1=noprobe hda=980,16,32
!! ASA1.initrd = /opt/images/asa805_cpio.gz
!! ASA1.options = -hdachs 980,16,32
!! IPS.console = 3002
!! IPS.netcard = e1000
!! IPS.nics = 5
!! IPS.ram = 1024
!! IPS.image2 = /opt/images/ide2.img
!! IPS.image1 = /opt/images/ide1.img
!! IPS.options = -smbios type=1,product=IDS-4235,serial=12345789012,uuid=E0A32395-8DFE-D511-8C31-001FC641BA6B,sku=011,family=IDS-4235/4250
command: ['qemu', '-name', 'IPS', '-m', '1024', '-hda', '/opt/GNS3/Project/iewb-sc/working/IPS/DISK1', '-hdb', '/opt/GNS3/Project/iewb-sc/working/IPS/DISK2', '-net', 'nic,vlan=0,macaddr=00:aa:00:18:3a:00,model=e1000', '-net', 'udp,vlan=0,sport=20008,dport=10008,daddr=127.0.0.1', '-net', 'nic,vlan=1,macaddr=00:aa:00:18:3a:01,model=e1000', '-net', 'udp,vlan=1,sport=20009,dport=10009,daddr=127.0.0.1', '-net', 'nic,vlan=2,macaddr=00:aa:00:18:3a:02,model=e1000', '-net', 'udp,vlan=2,sport=20010,dport=10010,daddr=127.0.0.1', '-net', 'nic,vlan=3,macaddr=00:aa:00:18:3a:03,model=e1000', '-net', 'udp,vlan=3,sport=20011,dport=10011,daddr=127.0.0.1', '-net', 'nic,vlan=4,macaddr=00:aa:00:18:3a:04,model=e1000', '-net', 'udp,vlan=4,sport=20012,dport=10012,daddr=127.0.0.1', '-serial', 'telnet::3002,server,nowait', '-smbios', 'type=1,product=IDS-4235,serial=12345789012,uuid=E0A32395-8DFE-D511-8C31-001FC641BA6B,sku=011,family=IDS-4235/4250']
qemu: -net udp,vlan=0,sport=20008,dport=10008,daddr=127.0.0.1: Parameter 'type' expects a network client type
pid: 2373
Renicing to 19
2373: old priority 0, new priority 19




Top
 Profile  
 
 Post subject: Re: qemu issue after upgrade
PostPosted: Thu Nov 17, 2011 8:39 am 
Offline

Joined: Thu Nov 17, 2011 5:50 am
Posts: 68
Hello,

I experience the same issue when using a qemu host inside GNS3 0.8.1. Whenever I start a qemu host the console freezes and does not boot. I'm using python 2.7.2 on ArchLinux
If I start qemuwrapper script before GNS3 everything works.
Here is the output from qemuwrapper.

$./qemuwrapper
Qemu Emulator Wrapper (version 0.8.0)
Copyright (c) 2007-2011 Thomas Pani & Jeremy Grossmann

Qemu TCP control server started (port 10525).
Listening on all network interfaces
Connection from ('127.0.0.1', 34890)
----------------------------------------
Exception happened during processing of request from ('127.0.0.1', 34890)
Traceback (most recent call last):
File "/usr/lib/python2.7/SocketServer.py", line 582, in process_request_thread
self.finish_request(request, client_address)
File "/usr/lib/python2.7/SocketServer.py", line 323, in finish_request
self.RequestHandlerClass(request, client_address, self)
Connection from ('127.0.0.1', 34891)
File "/usr/lib/python2.7/SocketServer.py", line 641, in __init__
self.finish()
File "/usr/lib/python2.7/SocketServer.py", line 694, in finish
self.wfile.flush()
File "/usr/lib/python2.7/socket.py", line 303, in flush
Shutdown in progress...
Shutdown completed.
self._sock.sendall(view[write_offset:write_offset+buffer_size])
error: [Errno 32] Broken pipe
----------------------------------------
Qemu path is now qemu
Qemu-img path is now qemu-img
!! QEMU1.console = 3000
!! QEMU1.netcard = e1000
!! QEMU1.image = /home/cioby/Downloads/linux-microcore-4.0.2-clean.img
!! QEMU1.ram = 512
!! QEMU1.options = -no-acpi
Deleting old flash file: /opt/GNS3/QEMU1/FLASH
Deleting old swap file: /opt/GNS3/QEMU1/SWAP
Formatting '/opt/GNS3/QEMU1/FLASH', fmt=qcow2 size=209715200 backing_file='/home/cioby/Downloads/linux-microcore-4.0.2-clean.img' encryption=off cluster_size=65536
qemu-img returned with 0
Formatting '/opt/GNS3/QEMU1/SWAP', fmt=qcow2 size=1073741824 encryption=off cluster_size=65536
qemu-img returned with 0
command: ['qemu', '-name', 'QEMU1', '-m', '512', '/opt/GNS3/QEMU1/FLASH', '-hdb', '/opt/GNS3/QEMU1/SWAP', '-net', 'nic,vlan=0,macaddr=00:00:ab:5e:a2:00,model=e1000', '-net', 'nic,vlan=1,macaddr=00:00:ab:a6:89:01,model=e1000', '-net', 'nic,vlan=2,macaddr=00:00:ab:e0:57:02,model=e1000', '-net', 'nic,vlan=3,macaddr=00:00:ab:07:7f:03,model=e1000', '-net', 'nic,vlan=4,macaddr=00:00:ab:db:3e:04,model=e1000', '-net', 'nic,vlan=5,macaddr=00:00:ab:46:7b:05,model=e1000', '-serial', 'telnet::3000,server,nowait', '-no-acpi']
Warning: vlan 0 is not connected to host network
Warning: vlan 1 is not connected to host network
Warning: vlan 2 is not connected to host network
Warning: vlan 3 is not connected to host network
Warning: vlan 4 is not connected to host network
Warning: vlan 5 is not connected to host network
pid: 16756
Renicing to 19
16756 (process ID) old priority 0, new priority 19

Is there a solution to this ?
I also tried to copy and older version of qemuwrapper from GNS3 0.7.4 but it does not work because it complains about missing pemubin module.

Thank you,




Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 9 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group

phpBB SEO