GNS3 0.8.3 released
Page 1 of 1

Author:  grossmj [ Fri Jul 13, 2012 5:48 am ]
Post subject:  GNS3 0.8.3 released

GNS3 0.8.3 is finally released! You can download it right away on our download page.

This release brings new features and fixes many issues. It is the most stable release to date and we hope you will enjoy it.

New features

  • Option to freely use the first VBox interface inside VMs (i.e. eth0 on Linux).
  • New base configuration (startup-config) for devices with NM-16ESW (named baseconfig_sw.txt).
  • Console and headless mode support for VirtualBox devices.
  • Embedded console/terminal server to access VirtualBox VM consoles using Telnet.
  • Support for drag & drop of topology files inside GNS3.
  • Double quote support for Qemu options and ASA kernel/initrd command lines.
  • Import & export for GNS3 configuration file (gns3.ini).
  • Global TCP port tracker to allocate ports and avoid conflicts (console + AUX ports for IOS routers and console ports for Qemu-like/VirtualBox devices are tracked)
  • Scripts for using consoles with VBox VMs (Windows only).
  • Backup nvram export when Dynamips has crashed.
  • New command line option for patched Putty on Windows (for details: post15744.html).
  • Experimental live pipe capture (Windows only).
  • Option (activated by default) to use GNS3 identifier names as hostnames for Vbox nodes.
  • Option (deactivated by default) to automatically close associated terminal program(s) when closing a node.
  • IPv6 support (with correct functions).
  • Support for binding addresses when loading a topology
  • Track opened consoles in order to close them when deleting a node (as an option).
  • New Dynamips 0.2.8-RC4 community (full IPv6 support), only included in Windows all-in-one package for now.
  • A patched putty is included (Windows packages)

Fixes and other improvements

  • Fixed issue when saving as a project.
  • Workaround: sparse memory feature is not activated on c2600 and c1700 platforms because Dynamips can freeze after IOS restarts (Windows only).
  • Added Idle PC help button to gives some hints how to get good idle pc values.
  • Prevent tail processes staying in memory after stopping captures.
  • Fixed/improved some console command lines (SecureCRT, TeraTerm, Putty)
  • Fixed issue when connecting recent Qemu (new -net syntax) to other non-Qemu devices.
  • Fixed vboxwrapper loading issue for DMG version on OSX.
  • Fixed rpcap interface name parsing on Windows.
  • Improved securecrt.vbs to "press" a enter into the device console to show the prompt.
  • Modified default IOS startup-config (baseconfig.txt).
  • Handle connection lost during Idle pc calculation.
  • Warn users if their working directories are not accessible and/or writable.
  • Allow dash and brackets for device hostnames.
  • Option to clear stopped captures from the captures dock.
  • Italian and Chinese translations updated.
  • Fixed bug that prevented loading topologies with non-existing IOS paths.
  • Some minor fixes for recent files menu (add saved file paths, order, non existing path entries are removed etc.)
  • New key shortcuts for object rotation (notes, ellipses, rectangles). ALT and + (or P) / ALT and - (or M).
  • Removed default shell execution for console programs.
  • Default delay between each device start when starting all devices is now 1 second.
  • Auto-increment base AUX port for external hypervisors.
  • MessageBox "Object moved to a background layer ..." is now displayed only once by execution.
  • Fixed issue when starting a capture on a node without any links (!)
  • Fixed problem with version comparison in "Check for Update" feature.
  • Fixed multi-window opening issue with snapshot dialog.
  • Added recent files button for the project window.
  • Press escape to stop adding a link.
  • Detect old GNS3 configuration and ask user to clear it.
  • Fixed minor issues with the Ethernet Switch.
  • Prevent capture for Pemu and decorative nodes.
  • Show VirtualBox version in ver command.
  • Support for more characters (e.g. #) in annotations.
  • New wrappers installation directory on Linux.
  • Prevent to use the same VBox VM multiple times.
  • Check that the first 10 ports of every TCP base are free to use when testing the settings in preferences.
  • Fixed minor issue with path normalization on Windows.
  • Time reference for debugs, auto saving messages and logged exceptions.
  • Log file dynagen_exception.log has been renamed import_exception.log (date + GNS3 version is added into the file).
  • Command 'show ports' to display all port allocations.
  • NVRAM configuration extractor utility for Windows.
  • Smarter handling of errors when starting/stopping/suspending all nodes.
  • Do not show special cursors when a rectangle or ellipse is on the background layer.
  • Qemuwrapper base UDP has been changed from 20000 to 40000.
  • Qemuwrapper base console has been changed from 3000 to 3001.
  • VBoxwrapper base console has been changed from 3900 to 3501.

To conclude, I would like to give big thanks to Ninel Piroi who greatly contributed to this new version of GNS3.

Author:  Khaled [ Fri Jul 13, 2012 6:41 am ]
Post subject:  Re: GNS3 0.8.3 released

Good work, Jeremy!

Author:  rivanstudents [ Fri Jul 13, 2012 7:28 am ]
Post subject:  Re: GNS3 0.8.3 released

Thank you for great application.

Author:  rednectar [ Sat Jul 14, 2012 12:29 pm ]
Post subject:  Re: GNS3 0.8.3 released

How exciting - GNS3 0.8.3 released the day I bring my new OSX Lion Server home!

So I get to test an install from scratch on Lion!

1. I notice in the Mac install, the baseconfig.txt and baseconfig_sw.txt don't get copied to the default Projects directory as they do in the Windows install. Would be nice if they did.
2. When I add a host (cloud) and connect the en0 or en1 interfaces to a router, I get a
206-unable to create generic ethernet NIO
error. I suspect it has something to do with permissions, if anyone has any ideas on how to fix this, I'd love to know, and it would be good to be able to fix it as part of the install.
3. I set my terminal Settings to iTerm (Mac OS x) - but got this when I tried to console to a router:
GNS3 Problem3.jpg
GNS3 Problem3.jpg [ 39.23 KiB | Viewed 8961 times ]

4. I then set my terminal settings to Terminal (Mac OS X) - and got this:
GNS3 Problem4.jpg
GNS3 Problem4.jpg [ 24.25 KiB | Viewed 8961 times ]

5. I added a .bin to my images - I thought that somewhere in the development we "uncompressed" these images for the user - I can't find where this is done. What am I missing?

The default terminal settings need some work for OS X (Lion)

Idle PC window now has some help - nice. But it also needs a [Try Again] button, I don't know, but I'm having a hard time finding an idle-pc on my favourite 3725 image. Sometimes I get three possible values, sometimes up to 5 - but none with an *. In the end I tried two approaches:
1. Manually setting the idle-pc with values that I know work well on my MacBook Pro (2.8 GHz Intel Core 2 Duo). They left the %CPU on my new Mac Mini Server (2 GHz Intel Core i7) at 100% - so now I can say definitively that a good idle-pc on on platform does not necessary make a good idle-pc on another.
2. In desperation, I started choosing any of the idle-pc values that were suggested (without a *) and notices that they nearly all dropped the CPU to below 10% anyway.

Author:  Khaled [ Sat Jul 14, 2012 12:35 pm ]
Post subject:  Re: GNS3 0.8.3 released

rednectar wrote:
2. When I add a host (cloud) and connect the en0 or en1 interfaces to a router, I get a
206-unable to create generic ethernet NIO
error. I suspect it has something to do with permissions, if anyone has any ideas on how to fix this, I'd love to know, and it would be good to be able to fix it as part of the install.

Hi Chris,

This was explained in one of the videos I uploaded to YouTube. It's a permission issue so you need to run GNS3 in root access mode (similar to Linux):

Mac:~ Khaled$ sudo /Applications/

Edited: Check out from minute 4:00 at

Author:  rednectar [ Sun Jul 15, 2012 6:43 am ]
Post subject:  Re: GNS3 0.8.3 released

Thanks Khaled - but I actually found a better way! Just install Wireshark!

The Wireshark install puts an extra entry in /Library/StartupItems/ called ChmodBPF - which changes the owner on the /dev/bpf* items to a group called access-bpf and gives that group rw rights to the BPF devices (BPF=Berkeley Packet Filter).

See the READme files for Wireshark for more info.

BUT it does mean that we should include something like this in the install. In fact, with Windows, we include Wireshark. Why not in OSX too? Especially if it has the answer to one of the install problems.

Page 1 of 1 All times are UTC
Powered by phpBB® Forum Software © phpBB Group